The SQL Server Agent service does not start after you upgrade from SQL Server 2008 Express or from SQL Server 2008 Express with Advanced Services to SQL Server 2008 Developer, to SQL Server 2008 Enterprise, or to SQL Server 2008 Standard

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Article ID: 955763 - View products that this article applies to.
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SYMPTOMS

Consider the following scenario.
  • You install Microsoft SQL Server 2008 Express or Microsoft SQL Server 2008 Express with Advanced Services.
  • You upgrade to Microsoft SQL Server 2008 Developer, to Microsoft SQL Server 2008 Enterprise, or to Microsoft SQL Server 2008 Standard by using the following command-line command:
    setup.exe /q /action=editionupgrade /instancename=instance name /pid=appropriate edition product ID
    Or, you upgrade to SQL Server 2008 Developer, to SQL Server 2008 Enterprise, or to SQL Server 2008 Standard by using the Setup Graphical User Interface (GUI).
  • You start the Service Control Manager.

    Note To do this, click Start, click Run, and then type services.msc.
  • You locate the SQL Server Agent service and then try to start the service.
In this scenario, the SQL Server Agent service does not start successfully. Additionally, the following error message is recorded in the event log:
SQLServerAgent could not be started (reason: Error creating a new session)

CAUSE

This issue occurs because in SQL Server 2008 Express and in SQL Server 2008 Express with Advanced Services, the SQL Server Agent service is created but not enabled. This condition is by design.

RESOLUTION

To resolve this issue, use one of the following procedures, as appropriate for the operating system that you are running.

Windows Server 2003 or Windows XP

Use one of the following methods.

Method 1: Enable the SQL Server Agent service by using SQL Server Configuration Manager

To do this, follow these steps:
  1. Click Start, click Programs, and then click SQL Server 2008.
  2. Click Configuration Tools, and then click SQL Server Configuration Manager.
  3. Expand SQL Server 2008 Services.
  4. Locate the SQL Server Agent service. The SQL Server Agent service is named "SQL Server Agent" for default instances and is named "SQL Server Agent (Instance name)" for named instances.
  5. Right-click SQL Server Agent, and then click Properties.
  6. On the Log On tab, click to select the This account check box. Specify a different account name and password.
  7. In the Service status section, click Start, and then click OK.

Method 2: Enable the SQL Server Agent service by using Service Control Manager

To have us enable the SQL Server Agent service for you, go to the "Fix it for me" section. If you prefer to enable the SQL Server Agent service yourself, go to the "Let me fix it myself" section.

Fix it for me



To enable the SQL Server Agent service automatically, click the Fix it button or link. Then click Run in the File Download dialog box, and follow the steps in the Fix it wizard.


Enable the SQL Server Agent service
Microsoft Fix it 50766


Notes
  • After you install this automatic fix, you must manually change the default log-in account of the SQL Server Agent service. Also, make sure that the service account that you specified is a member of the SQL Server Agent local group.
  • This wizard may be in English only. However, the automatic fix also works for other language versions of Windows.
  • If you are not on the computer that has the problem, save the Fix it solution to a flash drive or a CD and then run it on the computer that has the problem.

Then, go to the "Did this fix the problem?" section.



Let me fix it myself

To do this, follow these steps.
  1. Click Start, click Run, type services.msc, and then click OK.
  2. In Service Control Manager, locate the appropriate SQL Server Agent service. The SQL Server Agent service is named "SQL Server Agent" for default instances and is named "SQL Server Agent (Instance name)" for named instances.
  3. Right-click the SQL Server Agent service. On the General tab, change the startup type from Disabled to any other appropriate value.
  4. Click the Log On tab, and then click to select the This account check box. Specify the service account and password, and then click OK.
After you enable the service by using Service Control Manager, you must make sure that the service account that you specified is a member of the SQL Server Agent local group. To do this, follow these steps:
  1. Click Start, click Run, type compmgmt.msc, and then click OK.
  2. Expand System Tools, expand Local Users and Groups, and then expand Groups.
  3. In the navigation pane, locate the appropriate agent group. The agent group name is "SQLServerAgentUser$Computer name$Instance name."

    Note For default instances, Instance name is "MSSQLSERVER."
  4. Double-click the group to see the members of the group. Add the service account as a member of the group.

    If the previous service account is present, delete it.
After you make sure that the service account is a member of the SQL Server Agent local group, add the service account as a system administrator for SQL Server 2008.

Windows Server 2008 or Windows Vista

To resolve this issue in Windows Server 2008 or in Windows Vista, follow these steps.

Step 1: Enable the SQL Server Agent service by using Service Control Manager

To have us enable the SQL Server Agent service for you, go to the "Fix it for me" section. If you prefer to enable the SQL Server Agent service yourself, go to the "Let me fix it myself" section.

Fix it for me



To enable the SQL Server Agent service automatically, click the Fix it button or link. Then click Run in the File Download dialog box, and follow the steps in the Fix it wizard.


Enable the SQL Server Agent service
Microsoft Fix it 50766


Notes
  • This wizard may be in English only. However, the automatic fix also works for other language versions of Windows.
  • If you are not on the computer that has the problem, save the Fix it solution to a flash drive or a CD and then run it on the computer that has the problem.

Then, go to the "Did this fix the problem?" section.



Let me fix it myself

To do this, follow these steps:
  1. Click Start, click Run, type services.msc, and then click OK.
  2. In Service Control Manager, locate the appropriate SQL Server Agent service. The SQL Server Agent service is named "SQL Server Agent" for default instances and is named "SQL Server Agent (Instance name)" for named instances.
  3. Right-click the SQL Server Agent service, and then click Properties.
  4. On the General tab, change the startup type from Disabled to any other appropriate value.

Step 2: Add the SQL Server Agent service security principal as a system administrator for SQL Server 2008

Note The service security principal is named "NT SERVICE\MSSQLSERVER" for default instances and is named "NT SERVICE\SQLAGENT$Instance Name" for named instances.

For more information about how to add the SQL Server Agent service security principal, visit the following Microsoft Developer Network (MSDN) Web sites:
http://msdn.microsoft.com/en-us/library/aa337562(SQL.100).aspx

http://msdn.microsoft.com/en-us/library/ms179126(SQL.100).aspx

Did this fix the problem?

  • Check whether the problem is fixed. If the problem is fixed, you are finished with this section. If the problem is not fixed, you can contact support.
  • We would appreciate your feedback. To provide feedback or to report any issues with this solution, please leave a comment on the "Fix it for me" blog or send us an email message.

Properties

Article ID: 955763 - Last Review: November 1, 2011 - Revision: 4.0
APPLIES TO
  • Microsoft SQL Server 2008 Developer
  • Microsoft SQL Server 2008 Enterprise
  • Microsoft SQL Server 2008 Express
  • Microsoft SQL Server 2008 Express with Advanced Services
  • Microsoft SQL Server 2008 Standard
Keywords: 
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