Eine SSL-Verbindung kann fehlschlagen, wenn Sie Internet Explorer, verwenden um die SSL-Verbindung auf eine HTTPS-Website auf einem Computer mit Windows Server 2003 vorzunehmen

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Problembeschreibung

Auf einem Windows Server 2003-basierten Computer verwenden Sie Windows Internet Explorer, um eine Verbindung (Secure Sockets LAYER) mit einer HTTPS-Website herzustellen. Wenn diese Website mit einem Zertifikat DSS (Digital Signature Standard) zertifiziert ist, die SSL-Verbindung kann fehlschlagen, und Sie können nicht auf der Website zugreifen, mithilfe von Internet Explorer.

Dieses Problem kann auftreten, wenn eine der folgenden Bedingungen erfüllt ist:
  • Die Länge der wichtigste Modulo von den DSA Digital Signature Algorithm (), die auf dem Webserver verwendet wird ist weniger als 128 Bits.
  • Die Länge des DSS-Schlüssel, auf dem Server beträgt weniger als 128 Bits.
Dieses Problem tritt nicht auf einem Computer, auf dem Windows Server 2008 oder Windows Vista ausgeführt wird. Z. B. in Windows Server 2003 oder Windows XP, wenn Sie versuchen, eine SSL Verbindung von Internet Explorer zu einem Server, der einen Baseboard Verwaltung Chipsatz besitzt, die eine eingebettete DSS-Zertifikat verfügt, die Verbindung fehlschlägt. Die Verbindung erfolgreich jedoch in Windows Server 2008 und Windows Vista. Die Verbindung ist auch in Windows Server 2003 erfolgreich, wenn Sie Firefox anstelle von Internet Explorer verwenden.

Dieses Problem kann auch auf einem Windows XP-Computer auftreten, auf dem Windows Internet Explorer 7 oder Microsoft Internet Explorer 6 ausgeführt wird. Weitere Informationen zu diesem Problem in Windows XP finden Sie im Abschnitt "Weitere Informationen".

Ursache

Dieses Problem kann auftreten, wenn die Länge der wichtigste Modulus von DSA, die auf dem Webserver verwendet wird größer als die Länge des öffentlichen Schlüssels ist, für den Schlüsselaustausch in der SSL-Transaktion verwendet wird.

Lösung

Hotfix-Informationen

Es ist ein unterstützter Hotfix von Microsoft erhältlich. Der Hotfix ist jedoch nur die Behebung des Problems die in diesem Artikel beschriebene vorgesehen. Installieren Sie diesen Hotfix nur auf Systemen, bei die das in diesem Artikel beschriebene Problem auftritt. Dieser Hotfix kann einem späteren Zeitpunkt zusätzliche Tests unterzogen. Wenn durch dieses Problem nicht schwerwiegend beeinträchtigt ist, empfiehlt Microsoft daher, auf die nächste Softwareupdate zu warten, das diesen Hotfix enthält.

Wenn der Hotfix zum Download verfügbar ist, ist ein Abschnitt "Hotfix Download available (Hotfixdownload verfügbar" am oberen Rand dieser Knowledge Base-Artikel. Wenn in diesem Abschnitt nicht angezeigt wird, wenden Sie sich an technischen Kundendienst und Support, um den Hotfix zu erhalten.

Hinweis: Wenn weitere Probleme auftreten oder wenn eine Problembehandlung erforderlich ist, müssen Sie möglicherweise eine separate Serviceanfrage erstellen. Die normalen Supportkosten gelten die für zusätzliche Supportfragen und Probleme, die für diesen speziellen Hotfix nicht qualifizieren. Eine vollständige Liste der technischen Kundendienst und Support-Telefonnummern oder eine separate Serviceanfrage erstellen die folgende Microsoft-Website:
http://support.microsoft.com/contactus/?ws=support
Hinweis: Das Formular "Hotfix Download available (Hotfixdownload verfügbar" zeigt die Sprachen für die der Hotfix verfügbar ist. Wenn Ihre Sprache nicht angezeigt wird, ist es, da ein Hotfix nicht für diese Sprache zur Verfügung steht.

Voraussetzungen

Sie müssen eine der folgenden Programme für diesen Hotfix installiert haben, können:
  • Windows Server 2003 Service Pack 1
  • Windows Server 2003 Service Pack 2
Weitere Informationen zu Windows Server 2003 Service Packs finden Sie im folgenden Artikel der Microsoft Knowledge Base:
889100So erhalten Sie das neueste Servicepack für Windows Server 2003

Neustartanforderung

Sie müssen den Computer neu starten, nachdem Sie diesen Hotfix installiert haben.

Ersetzte Hotfixes

Dieser Hotfix ersetzt keine anderen Hotfixes.

Dateiinformationen

Die englische Version dieses Hotfixes weist die Dateiattribute (oder höher Dateiattribute), die in der folgenden Tabelle aufgelistet werden. Die Datums- und Uhrzeitangaben für diese Dateien werden in Coordinated Universal Time aufgeführt (UTC). Wenn Sie sich die Dateiinformationen ansehen, werden diese Angaben in die lokale Zeit konvertiert. Verwenden Sie die Registerkarte Zeitzone im Element Datum und Uhrzeit in der Systemsteuerung, um die Differenz zwischen UTC und der Ortszeit zu ermitteln.
Windows Server 2003 mit Service Pack 1, x 86-basierte Versionen
Tabelle minimierenTabelle vergrößern
DateinameDateiversionDateigrößeDatumUhrzeitPlattform
Schannel.dll5.2.3790.3178144,89622-Jul-200812: 12X 86
Windows Server 2003 mit Service Pack 2, x 86-basierte Versionen
Tabelle minimierenTabelle vergrößern
DateinameDateiversionDateigrößeDatumUhrzeitPlattform
Schannel.dll5.2.3790.4338147,96822-Jul-200811: 55X 86
Windows Server 2003 mit Service Pack 1, Itanium-basierte Versionen
Tabelle minimierenTabelle vergrößern
DateinameDateiversionDateigrößeDatumUhrzeitPlattformSP AnforderungServicebereich
Schannel.dll5.2.3790.3178466,94422-Jul-200810: 46IA-64SP1Nicht zutreffend
Wschannel.dll5.2.3790.3178144,89622-Jul-200810: 46X 86SP1WOW
Windows Server 2003 mit Service Pack 2, Itanium-basierte Versionen
Tabelle minimierenTabelle vergrößern
DateinameDateiversionDateigrößeDatumUhrzeitPlattformSP AnforderungServicebereich
Schannel.dll5.2.3790.4338467,45622-Jul-200811: 31IA-64SP2Nicht zutreffend
Wschannel.dll5.2.3790.4338147,96822-Jul-200811: 31X 86SP2WOW
Windows Server 2003 mit Service Pack 1, x 64-basierte Versionen
Tabelle minimierenTabelle vergrößern
DateinameDateiversionDateigrößeDatumUhrzeitPlattformSP AnforderungServicebereich
Schannel.dll5.2.3790.3178254,97622-Jul-200810: 26X 64SP1Nicht zutreffend
Wschannel.dll5.2.3790.3178144,89622-Jul-200810: 26X 86SP1WOW
Windows Server 2003 mit Service Pack 2, x 64-basierte Versionen
Tabelle minimierenTabelle vergrößern
DateinameDateiversionDateigrößeDatumUhrzeitPlattformSP AnforderungServicebereich
Schannel.dll5.2.3790.4338255,48822-Jul-200811: 34X 64SP2Nicht zutreffend
Wschannel.dll5.2.3790.4338147,96822-Jul-200811: 34X 86SP2WOW
Windows XP Professional X 64 Edition mit Servicepack 1
Tabelle minimierenTabelle vergrößern
DateinameDateiversionDateigrößeDatumUhrzeitPlattformSP AnforderungServicebereich
Schannel.dll5.2.3790.3178254,97622-Jul-200810: 26X 64SP1Nicht zutreffend
Wschannel.dll5.2.3790.3178144,89622-Jul-200810: 26X 86SP1WOW
Windows XP Professional X 64 Edition mit ServicePack 2
Tabelle minimierenTabelle vergrößern
DateinameDateiversionDateigrößeDatumUhrzeitPlattformSP AnforderungServicebereich
Schannel.dll5.2.3790.4338255,48822-Jul-200811: 34X 64SP2Nicht zutreffend
Wschannel.dll5.2.3790.4338147,96822-Jul-200811: 34X 86SP2WOW

Status

Microsoft hat bestätigt, dass dies ein Problem in Microsoft-Produkten handelt, die im Abschnitt "Gilt für" aufgeführt sind.

Weitere Informationen

Dieses Problem kann auch auf einem Windows XP-Computer auftreten, auf dem Windows Internet Explorer 7 oder Microsoft Internet Explorer 6 ausgeführt wird. Installieren Sie in der folgenden Artikel der Microsoft Knowledge Base beschriebenen Hotfix, um dieses Problem in Windows XP zu beheben:
955832Eine SSL-Verbindung kann fehlschlagen, wenn Sie Internet Explorer, verwenden um eine SSL-Verbindung zu einer HTTPS-Website vorzunehmen, die mit einem Zertifikat DSS (Digital Signature Standards) auf einem Windows-basierten Computer zertifiziert
Weitere Informationen zur Terminologie für Softwareupdates finden Sie im folgenden Artikel der Microsoft Knowledge Base:
824684Erläuterung von Standardbegriffen bei Microsoft Softwareupdates

Technischer Support für x 64-basierten Versionen von Microsoft Windows

Wenn Ihre Hardware mit einer Microsoft Windows X 64 Edition bereits installiert war, bietet der Hardwarehersteller technischen Support und Unterstützung für Windows X 64 Edition. In diesem Fall bietet der Hardwarehersteller unterstützt, da eine Windows X 64 Edition zusammen mit Ihrer Hardware geliefert wurde. Hardwarehersteller möglicherweise die Windows X 64 Edition-Installation mithilfe von spezifischen Komponenten angepasst haben. Eindeutige Komponenten gehören bestimmte Gerätetreiber oder gehören optionale Einstellungen, um die Leistung der Hardware zu optimieren. Wenn Sie technische Hilfe zu Windows X 64 Edition benötigen, bietet Microsoft in diesem Fall angemessenem Unterstützung Rahmen. Allerdings müssen Sie möglicherweise den Hersteller direkt. Der Hersteller ist am besten ihm, um die Software zu unterstützen, die der Hersteller der Hardware installiert. Wenn Sie eine Windows X 64 Edition z. B. eine Windows Server 2003 x 64 Edition) separat erworben haben, wenden Sie sich an Microsoft, für technischen Support.

Weitere Informationen zu Windows XP Professional X 64 Edition die folgende Microsoft-Website:
http://www.microsoft.com/windowsxp/64bit/default.mspx
Weitere Informationen zu x 64-basierten Versionen von Windows Server 2003 die folgende Microsoft-Website:
http://www.microsoft.com/windowsserver2003/64bit/x64/default.mspx

Eigenschaften

Artikel-ID: 955807 - Geändert am: Donnerstag, 30. Oktober 2008 - Version: 1.0
Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Datacenter Edition for Itanium-Based Systems
  • Microsoft Windows Server 2003 Service Pack 1
  • Microsoft Windows Server 2003 Service Pack 2
  • Microsoft Windows XP Professional x64 Edition
Keywords: 
kbmt kbautohotfix kbexpertiseinter kbbug kbfix kbhotfixserver kbqfe KB955807 KbMtde
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Den englischen Originalartikel können Sie über folgenden Link abrufen: 955807
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