Una connessione SSL non riesca quando si utilizza Internet Explorer per stabilire la connessione SSL a un sito Web HTTPS in un computer basato su Windows Server 2003

Traduzione articoli Traduzione articoli
Identificativo articolo: 955807 - Visualizza i prodotti a cui si riferisce l?articolo.
Espandi tutto | Chiudi tutto

In questa pagina

Sintomi

In un computer basato su Windows Server 2003, Ŕ possibile utilizzare Windows Internet Explorer per stabilire una connessione SSL (Secure Sockets Layer) a un sito Web HTTPS. Se il sito Web Ŕ certificato da un certificato DSS (Digital Signature Standard), la connessione SSL non riesca e si Impossibile accedere al sito Web utilizzando Internet Explorer.

Questo problema pu˛ verificarsi se una delle seguenti condizioni Ŕ vera:
  • La lunghezza del modulo della principale del DSA Digital Signature Algorithm () utilizzato in tale server Ŕ inferiore a 128 bit.
  • La lunghezza della chiave DSS utilizzato in tale server Ŕ inferiore a 128 bit.
Questo problema non si verifica in un computer che esegue Windows Server 2008 o Windows Vista. Ad esempio, in Windows Server 2003 o in Windows XP, quando si tenta di effettuare SSL connessione da Internet Explorer a un server che dispone di un chipset di gestione di baseboard che dispone di un certificato DSS incorporato, la connessione non riesce. Tuttavia, la connessione ha esito positivo in Windows Server 2008 e in Windows Vista. La connessione riesce anche in Windows Server 2003, se si utilizza Firefox invece di Internet Explorer.

Questo problema pu˛ verificarsi anche in un computer basato su Windows XP in cui Ŕ in esecuzione Windows Internet Explorer 7 o di Microsoft Internet Explorer 6. Per ulteriori informazioni su questo problema in Windows XP, vedere la sezione di "Informazioni".

Cause

Questo problema pu˛ verificarsi quando la lunghezza del modulo della principale del DSA utilizzato in tale server Ŕ maggiore della lunghezza della chiave pubblica utilizzato per lo scambio di chiave nella transazione SSL.

Risoluzione

Informazioni sull'hotfix

╚ disponibile un hotfix supportato. Questo hotfix Ŕ tuttavia destinato esclusivamente alla risoluzione del problema descritto in questo articolo. Consente di applicare questo aggiornamento rapido (hotfix) solo ai sistemi in cui si verifica il problema descritto in questo articolo. Questo aggiornamento rapido (hotfix) potrebbe essere eseguiti ulteriori test. Se non si Ŕ notevolmente interessati da questo problema, si consiglia pertanto di attendere il successivo aggiornamento di software che contiene questo aggiornamento rapido (hotfix).

Se l'hotfix Ŕ disponibile per il download, Ŕ una sezione "Hotfix disponibile per il download" all'inizio di questo articolo della Knowledge Base. Se non viene visualizzato in questa sezione, Ŕ necessario contattare servizio clienti Microsoft e supporto tecnico per ottenere l'hotfix.

Nota Se si verificano ulteriori problemi o se la risoluzione dei problemi Ŕ necessario, potrebbe essere necessario creare una richiesta di servizio separato. I costi di supporto normale verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare nello specifico hotfix in questione. Per un elenco completo, di Microsoft Customer Service and Support numeri di telefono o a creare una richiesta di servizio distinto, visitare il seguente sito Web Microsoft:
http://support.microsoft.com/contactus/?ws=support
Nota Il modulo "Hotfix disponibile per il download" Visualizza le lingue per cui Ŕ disponibile l'aggiornamento rapido. Se non viene visualizzata la lingua, Ŕ perchÚ un aggiornamento rapido (hotfix) non Ŕ disponibile per tale lingua.

Prerequisiti

╚ necessario disporre di una delle seguenti operazioni per applicare questo aggiornamento rapido (hotfix):
  • Windows Server 2003 Service Pack 1
  • Windows Server 2003 Service Pack 2
Per ulteriori informazioni sui service pack per Windows Server 2003, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito riportato:
889100Come ottenere il service pack pi¨ recente per Windows Server 2003

NecessitÓ di riavvio

╚ necessario riavviare il computer dopo aver applicato questo hotfix.

Informazioni sulla sostituzione della correzione

Questo aggiornamento rapido (hotfix) non sostituisce eventuali altri hotfix.

Informazioni sui file

La versione di lingua inglese di questo aggiornamento rapido (hotfix) presenta gli attributi di file (o attributi successivi) elencati nella tabella riportata di seguito. Date e ore dei file sono elencate di in ora UTC (UTC). Quando si visualizzano le informazioni sul file, viene convertito in ora locale. Per calcolare la differenza tra ora UTC e l'ora locale, utilizzare la scheda fuso orario dello Data e ora nel Pannello di controllo.
Windows Server 2003 con Service Pack 1, versioni basate su 86 su x
Riduci questa tabellaEspandi questa tabella
Nome del fileVersione del fileDimensioni fileDataOraPiattaforma
Schannel.dll5.2.3790.3178144.89622 Luglio 200812: 12x 86
Windows Server 2003 con Service Pack 2, versioni basate su 86 su x
Riduci questa tabellaEspandi questa tabella
Nome del fileVersione del fileDimensioni fileDataOraPiattaforma
Schannel.dll5.2.3790.4338147,96822 Luglio 200811: 55x 86
Windows Server 2003 con Service Pack 1, versioni basate su Itanium
Riduci questa tabellaEspandi questa tabella
Nome del fileVersione del fileDimensioni fileDataOraPiattaformaSP requisitoRamo del servizio
Schannel.dll5.2.3790.3178466,94422 Luglio 200810: 46IA-64SP1Non applicabile
Wschannel.dll5.2.3790.3178144.89622 Luglio 200810: 46x 86SP1WOW
Windows Server 2003 con Service Pack 2, versioni basate su Itanium
Riduci questa tabellaEspandi questa tabella
Nome del fileVersione del fileDimensioni fileDataOraPiattaformaSP requisitoRamo del servizio
Schannel.dll5.2.3790.4338467,45622 Luglio 200811: 31IA-64SP2Non applicabile
Wschannel.dll5.2.3790.4338147,96822 Luglio 200811: 31x 86SP2WOW
Windows Server 2003 con Service Pack 1, versioni x 64
Riduci questa tabellaEspandi questa tabella
Nome del fileVersione del fileDimensioni fileDataOraPiattaformaSP requisitoRamo del servizio
Schannel.dll5.2.3790.3178254.97622 Luglio 200810: 26x 64SP1Non applicabile
Wschannel.dll5.2.3790.3178144.89622 Luglio 200810: 26x 86SP1WOW
Windows Server 2003 con Service Pack 2, versioni x 64
Riduci questa tabellaEspandi questa tabella
Nome del fileVersione del fileDimensioni fileDataOraPiattaformaSP requisitoRamo del servizio
Schannel.dll5.2.3790.4338255.48822 Luglio 200811: 34x 64SP2Non applicabile
Wschannel.dll5.2.3790.4338147,96822 Luglio 200811: 34x 86SP2WOW
Windows XP Professional x 64 Edition con Service Pack 1
Riduci questa tabellaEspandi questa tabella
Nome del fileVersione del fileDimensioni fileDataOraPiattaformaSP requisitoRamo del servizio
Schannel.dll5.2.3790.3178254.97622 Luglio 200810: 26x 64SP1Non applicabile
Wschannel.dll5.2.3790.3178144.89622 Luglio 200810: 26x 86SP1WOW
Windows XP Professional x 64 Edition con Service Pack 2
Riduci questa tabellaEspandi questa tabella
Nome del fileVersione del fileDimensioni fileDataOraPiattaformaSP requisitoRamo del servizio
Schannel.dll5.2.3790.4338255.48822 Luglio 200811: 34x 64SP2Non applicabile
Wschannel.dll5.2.3790.4338147,96822 Luglio 200811: 34x 86SP2WOW

Status

Microsoft ha confermato che questo problema riguarda i prodotti sono elencati nella sezione "Si applica a".

Informazioni

Questo problema pu˛ verificarsi anche in un computer basato su Windows XP in cui Ŕ in esecuzione Windows Internet Explorer 7 o di Microsoft Internet Explorer 6. Per risolvere questo problema in Windows XP, Ŕ necessario applicare l'hotfix descritto nel seguente articolo della Microsoft Knowledge Base riportato di seguito:
955832Una connessione SSL non riesca quando si utilizza Internet Explorer per stabilire una connessione SSL a un sito Web HTTPS Ŕ certificato da un certificato DSS (Digital Signature Standard) in un computer
Per ulteriori informazioni sulla terminologia di aggiornamento software, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito riportato:
824684Descrizione della terminologia standard utilizzata per descrivere gli aggiornamenti software Microsoft

Supporto tecnico per versioni x 64-di Microsoft Windows

Se l'hardware con una versione x 64 di Microsoft Windows installata Ŕ stato fornito, il produttore dell'hardware offre supporto tecnico e assistenza per l'edizione x 64 di Windows. In questo caso, il produttore dell'hardware offre supporto poichÚ una versione x 64 di Windows Ŕ stato inclusa con l'hardware. Il produttore di hardware potrebbe infatti avere personalizzato l'installazione della versione x 64 di Windows utilizzando componenti univoci. Componenti univoci possono includere specifici driver di periferica o impostazioni facoltative per ottimizzare le prestazioni dell'hardware. Se Ŕ necessario disporre per assistenza tecnica con una versione x 64 di Windows, Microsoft fornirÓ assistenza impegna a. Tuttavia, potrebbe essere necessario contattare direttamente il produttore. Quanto soggetto pi¨ qualificato per supportare il software preinstallato sull'hardware. Per supporto tecnico, se Ŕ stata acquistata separatamente una versione x 64 di Windows, ad esempio Windows Server 2003 x 64 edition, contattare Microsoft.

Per informazioni su Windows XP Professional x 64 Edition, visitare il sito di Web di Microsoft:
http://www.microsoft.com/windowsxp/64bit/default.mspx
Per informazioni su x 64 e basate su versioni di Windows Server 2003, visitare il sito di Web di Microsoft:
http://www.microsoft.com/windowsserver2003/64bit/x64/default.mspx

ProprietÓ

Identificativo articolo: 955807 - Ultima modifica: giovedý 30 ottobre 2008 - Revisione: 1.0
Le informazioni in questo articolo si applicano a:
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Datacenter Edition for Itanium-Based Systems
  • Microsoft Windows Server 2003 Service Pack 1
  • Microsoft Windows Server 2003 Service Pack 2
  • Microsoft Windows XP Professional x64 Edition
Chiavi:á
kbmt kbautohotfix kbexpertiseinter kbbug kbfix kbhotfixserver kbqfe KB955807 KbMtit
Traduzione automatica articoli
Il presente articolo Ŕ stato tradotto tramite il software di traduzione automatica di Microsoft e non da una persona. Microsoft offre sia articoli tradotti da persone fisiche sia articoli tradotti automaticamente da un software, in modo da rendere disponibili tutti gli articoli presenti nella nostra Knowledge Base nella lingua madre dell?utente. Tuttavia, un articolo tradotto in modo automatico non Ŕ sempre perfetto. Potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli, pi¨ o meno allo stesso modo di come una persona straniera potrebbe commettere degli errori parlando una lingua che non Ŕ la sua. Microsoft non Ŕ responsabile di alcuna imprecisione, errore o danno cagionato da qualsiasi traduzione non corretta dei contenuti o dell?utilizzo degli stessi fatto dai propri clienti. Microsoft, inoltre, aggiorna frequentemente il software di traduzione automatica.
Clicca qui per visualizzare la versione originale in inglese dell?articolo: 955807
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com