Uma conexão SSL pode falhar quando você usar o Internet Explorer para fazer a conexão SSL com um site HTTPS em um computador com Windows Server 2003

Traduções deste artigo Traduções deste artigo
ID do artigo: 955807 - Exibir os produtos aos quais esse artigo se aplica.
Expandir tudo | Recolher tudo

Neste artigo

Sintomas

Em um computador baseado no Windows Server 2003, use o Windows Internet Explorer para estabelecer uma conexão SSL (Secure Sockets LAYER) a um site da Web HTTPS. Se este site é certificado por um certificado padrão de assinatura digital (DSS), a conexão SSL pode falhar e você não pode acessar o site usando o Internet Explorer.

Esse problema pode ocorrer se uma das seguintes condições for verdadeira:
  • O comprimento do resto dos principais do Digital Signature (ALGORITHM) usado no servidor Web é menos de 128 bits.
  • O comprimento da chave DSS usado no servidor Web é menos de 128 bits.
Esse problema não ocorre em um computador que está executando o Windows Server 2008 ou o Windows Vista. Por exemplo, no Windows Server 2003 ou no Windows XP, quando você tenta fazer um SSL conexão do Internet Explorer em um servidor que tem um chipset de gerenciamento placa-base que tem um certificado DSS incorporado, a conexão falha. No entanto, a conexão tiver êxito no Windows Server 2008 e no Windows Vista. A conexão também terá êxito no Windows Server 2003 se você usar o Firefox, em vez do Internet Explorer.

Esse problema também pode ocorrer em um computador com o Windows XP no qual você está executando o Windows Internet Explorer 7 ou o Microsoft Internet Explorer 6. Para obter mais informações sobre este problema no Windows XP, consulte a seção "Mais informação".

Causa

Esse problema pode ocorrer quando o comprimento do resto dos principais de DSA usado no servidor Web for maior que o comprimento da chave pública que é usado para a troca de chaves na transação SSL.

Resolução

Informações sobre o hotfix

Um hotfix suportado está disponível no Microsoft. No entanto, esse hotfix destina-se a corrigir o problema descrito neste artigo. Aplique-o somente aos sistemas que apresentarem o problema descrito neste artigo. Esta correcção poderá submetida a testes adicionais. Portanto, se você não tiver sido gravemente afetado por esse problema, recomendamos que você aguarde a próxima atualização de software que contém esse hotfix.

Se o hotfix está disponível para download, há uma seção "Download de Hotfix disponível" na parte superior neste artigo da Base de dados de Conhecimento. Se esta seção não for exibida, contate o atendimento e suporte para obter o hotfix.

Observação Se ocorrerem problemas adicionais ou se qualquer solução de problemas é necessária, talvez você precise criar uma solicitação de serviço separada. Os custos normais de suporte serão aplicados a questões de suporte adicionais e problemas que não se qualificam para esse hotfix específico. Para obter uma lista completa de números de telefone de suporte e Atendimento Microsoft ou para criar uma solicitação de serviço separada, visite o seguinte site:
http://support.microsoft.com/contactus/?ws=support
Observação O formulário "Download de Hotfix disponível" exibe os idiomas para os quais o hotfix está disponível. Se você não vir seu idioma, é porque um hotfix não está disponível para esse idioma.

Pré-requisitos

Você deve ter um dos seguintes itens instalado para aplicar esse hotfix:
  • Windows Server 2003 Service Pack 1
  • Windows Server 2003 Service Pack 2
Para obter mais informações sobre service packs do Windows Server 2003, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
889100Como obter o service pack mais recente para o Windows Server 2003

Requisitos de reinicialização

Reinicie o computador após aplicar esse hotfix.

Informações sobre a substituição do hotfix

Esse hotfix não substitui outros hotfixes.

Informações sobre o arquivo

A versão em inglês deste hotfix tem atributos de arquivo (ou atributos de arquivo posteriores) listados na tabela a seguir. As datas e horas desses arquivos são listadas na hora universal coordenada (UTC). Quando você exibe as informações do arquivo, ele é convertido para a hora local. Para encontrar a diferença entre o UTC e a hora local, use a guia fuso horário no item Data e hora no painel de controle.
Windows Server 2003 com Service Pack 1, versões com base em 86 x
Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataforma
Schannel.dll5.2.3790.3178144.89622 De julho de 200812: 12x 86
Windows Server 2003 com Service Pack 2, x 86-based versões
Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataforma
Schannel.dll5.2.3790.4338147.96822 De julho de 200811: 55x 86
Windows Server 2003 com Service Pack 1, versões com base em Itanium
Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataformaSP requisitoRamificação do serviço
Schannel.dll5.2.3790.3178466,94422 De julho de 200810: 46IA-64SP1Não aplicável
Wschannel.dll5.2.3790.3178144.89622 De julho de 200810: 46x 86SP1UAU
Windows Server 2003 com Service Pack 2, versões com base em Itanium
Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataformaSP requisitoRamificação do serviço
Schannel.dll5.2.3790.4338467,45622 De julho de 200811: 31IA-64SP2Não aplicável
Wschannel.dll5.2.3790.4338147.96822 De julho de 200811: 31x 86SP2UAU
Windows Server 2003 com Service Pack 1, versões com base em 64 x
Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataformaSP requisitoRamificação do serviço
Schannel.dll5.2.3790.3178254.97622 De julho de 200810: 26x 64SP1Não aplicável
Wschannel.dll5.2.3790.3178144.89622 De julho de 200810: 26x 86SP1UAU
Windows Server 2003 com Service Pack 2, versões com base em 64 x
Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataformaSP requisitoRamificação do serviço
Schannel.dll5.2.3790.4338255.48822 De julho de 200811: 34x 64SP2Não aplicável
Wschannel.dll5.2.3790.4338147.96822 De julho de 200811: 34x 86SP2UAU
Windows XP Professional x 64 Edition com Service Pack 1
Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataformaSP requisitoRamificação do serviço
Schannel.dll5.2.3790.3178254.97622 De julho de 200810: 26x 64SP1Não aplicável
Wschannel.dll5.2.3790.3178144.89622 De julho de 200810: 26x 86SP1UAU
Windows XP Professional x 64 Edition com Service Pack 2
Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataformaSP requisitoRamificação do serviço
Schannel.dll5.2.3790.4338255.48822 De julho de 200811: 34x 64SP2Não aplicável
Wschannel.dll5.2.3790.4338147.96822 De julho de 200811: 34x 86SP2UAU

Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na seção "Aplica-se a".

Mais Informações

Esse problema também pode ocorrer em um computador com o Windows XP no qual você está executando o Windows Internet Explorer 7 ou o Microsoft Internet Explorer 6. Para resolver esse problema no Windows XP, aplique o hotfix descrito no seguinte artigo na Base de dados de Conhecimento da Microsoft:
955832Uma conexão SSL pode falhar quando você usar o Internet Explorer para fazer uma conexão SSL para um site HTTPS que é certificada por um certificado padrão de assinatura digital (DSS) em um computador baseado no Windows XP
Para obter mais informações sobre terminologia de atualização de software, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
824684Descrição da terminologia padrão que é usada para descrever as atualizações de software

Suporte técnico para versões com base em 64 x do Microsoft Windows

Se o hardware veio com uma edição x 64 do Microsoft Windows instalada, o fabricante do hardware fornecerá suporte técnico e assistência para a edição x 64 do Windows. Nesse caso, o fabricante do hardware fornece suporte porque uma edição x 64 do Windows foi incluída com o hardware. O fabricante do hardware pode ter personalizado a instalação da edição x 64 do Windows do usando componentes exclusivos. Componentes exclusivos podem incluir drivers de dispositivo específico ou podem incluir configurações opcionais para maximizar o desempenho do hardware. A Microsoft fornecerá assistência razoável se você precisar de ajuda técnica com uma edição x 64 do Windows. No entanto, talvez você precise entrar em contato com o fabricante diretamente. O fabricante do seu melhor é qualificado para suportar o software que o fabricante do seu instalado no hardware. Se você comprou uma edição x 64 do Windows, como um Windows Server 2003 x 64 edition separadamente, contate a Microsoft para obter suporte técnico.

Para informações de produto sobre o Windows XP Professional x 64 Edition, visite o seguinte site:
http://www.microsoft.com/windowsxp/64bit/default.mspx
Para informações de produto sobre versões com base em 64 x do Windows Server 2003, visite o seguinte site:
http://www.microsoft.com/windowsserver2003/64bit/x64/default.mspx

Propriedades

ID do artigo: 955807 - Última revisão: quinta-feira, 30 de outubro de 2008 - Revisão: 1.0
A informação contida neste artigo aplica-se a:
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Datacenter Edition for Itanium-Based Systems
  • Microsoft Windows Server 2003 Service Pack 1
  • Microsoft Windows Server 2003 Service Pack 2
  • Microsoft Windows XP Professional x64 Edition
Palavras-chave: 
kbmt kbautohotfix kbexpertiseinter kbbug kbfix kbhotfixserver kbqfe KB955807 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 955807

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com