Se produce de CPU para seis segundos en un equipo basado en Windows Server 2003 que tiene varios adaptadores de red

Seleccione idioma Seleccione idioma
Id. de artículo: 955860 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

En esta página

Síntomas

Tiene un equipo basado en Windows Server 2003 que tiene varios adaptadores de red. En este equipo, uso de CPU aumenta al 100 por ciento durante unos seis segundos cuando el sistema intenta resolver nombres NetBIOS mediante el archivo LmHosts. En un sistema multiprocesador o multinúcleo, el uso de CPU en una CPU aumenta al 100 % durante unos seis segundos y el uso de CPU en otras CPU también es anormalmente alto. Esta situación normalmente se produce cuando muchos accesos simultáneos se producen a algunos recursos compartidos y pueden producirse varias veces.

Causa

Este problema se produce debido a una condición de carrera. Puede producirse un bucle sin fin en el siguiente escenario:
  • Se realizan varias resoluciones de nombre de red en cada adaptador.
  • Después de uno de ellos se realiza correctamente, se cancelan algunas resoluciones de nombre.
  • Se realiza una búsqueda en el archivo LmHosts.
En este escenario, la búsqueda entra en un bucle inactivo que sólo se puede terminar por un tiempo de espera. Este tiempo de espera está configurado en una entrada del registro. De forma predeterminada, este tiempo de espera se establece en seis segundos.

Solución

Nota Un equipo que tiene varios adaptadores de red es también conocida como un equipo multitarjeta. Este problema aparece cuando uno de los adaptadores de un equipo multitarjeta era "Adaptador de bucle invertido de Microsoft". Esta configuración puede ser un motivo de la condición de anticipación que se menciona en la sección causa.

Para comprobar que está experimentando este problema, recomendamos que deshabilite la búsqueda de LmHosts como una prueba para la solución de problemas. Si ya no se produce este problema después de deshabilitar la búsqueda de LmHosts, puede estar seguro que está experimentando este problema.

Información de revisiones

Hay una revisión compatible de Microsoft. Sin embargo, esta revisión se diseñó para corregir el problema descrito en este artículo. Aplíquela sólo a los sistemas que experimenten este problema específico. Esta revisión podría sometida a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere a la siguiente actualización de software que contenga este hotfix.

Si la revisión está disponible para descarga, es hay una sección de "Descarga de revisión disponibles" en la parte superior de este artículo de Knowledge Base. Póngase en contacto si no aparece en esta sección, con los Microsoft cliente Servicios de y soporte técnico para obtener la revisión de.

Nota Si se producen problemas adicionales o si cualquier solución de problemas es necesario, quizás tenga que crear una solicitud de servicio independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no guarden relación con esta revisión específica. Para obtener una lista completa de números de teléfono de servicio de atención al cliente y soporte técnico o para crear una solicitud de servicio independiente, visite el siguiente sitio Web:
http://support.microsoft.com/contactus/?ws=support
Nota El formulario "Descarga de revisión disponibles" muestra los idiomas para que la revisión está disponible. Si no ve su idioma, es porque una revisión no está disponible para ese idioma.

Requisitos previos

Para aplicar este hotfix, debe tener Windows Server 2003 Service Pack 1 o Windows Server 2003 Service Pack 2 instalado en el equipo. Para obtener más información, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
889100Cómo obtener la versión más reciente del Service Pack para Windows Server 2003

Requisito de reinicio

Tendrá que reiniciar el equipo después de aplicar este hotfix.

Información acerca de la sustitución de la revisión

Esta revisión no reemplaza una revisión lanzada anteriormente.

Información de archivo

La versión en inglés de este hotfix tiene los atributos de archivo (o atributos de último archivo) mostrados en la siguiente tabla. Las fechas y las horas de estos archivos se muestran en hora universal coordinada (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para averiguar la diferencia entre hora UTC y la hora local, utilice la ficha zona horaria el elemento fecha y hora en el panel de control.
Windows Server 2003 con Service Pack 1, x 86
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño de archivoFechaTiempoPlataforma
NetBT.sys5.2.3790.3193180,22418 De agosto de 200811: 14x 86
Windows Server 2003 con Service Pack 2, x 86
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño de archivoFechaTiempoPlataforma
NetBT.sys5.2.3790.4356180,22418 De agosto de 200811: 31x 86
Windows Server 2003 con Service Pack 1, versiones basadas en Itanium
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño de archivoFechaTiempoPlataforma
NetBT.sys5.2.3790.3193561,15218 De agosto de 200813: 06IA-64
Windows Server 2003 con Service Pack 2, versiones basadas en Itanium
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño de archivoFechaTiempoPlataforma
NetBT.sys5.2.3790.4356561,66418 De agosto de 200813: 42IA-64
Windows Server 2003 con Service Pack 1, versiones basadas en 64 x
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño de archivoFechaTiempoPlataforma
NetBT.sys5.2.3790.3193378,88018 De agosto de 200812: 59x 64
Windows Server 2003 con Service Pack 2, versiones basadas en 64 x
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño de archivoFechaTiempoPlataforma
NetBT.sys5.2.3790.4356347,13618 De agosto de 200813: 43x 64
Windows XP Professional x 64 Edition con Service Pack 1
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño de archivoFechaTiempoPlataforma
NetBT.sys5.2.3790.3193378,88018 De agosto de 200812: 59x 64
Windows XP Professional x 64 Edition con Service Pack 2
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño de archivoFechaTiempoPlataforma
NetBT.sys5.2.3790.4356347,13618 De agosto de 200813: 43x 64

Solución

Solución 1

importante Esta sección, el método o la tarea contiene pasos que indican cómo modificar el registro. Sin embargo, pueden producirse problemas graves si modifica incorrectamente el registro. Por tanto, asegúrese de que siga estos pasos cuidadosamente. Realice una para agregar protección, copia de seguridad del registro antes de modificarlo. A continuación, puede restaurar el registro si se produce un problema. Para obtener más información acerca de cómo realizar una copia de seguridad y restaurar el registro, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
322756Cómo realizar una copia de seguridad y restaurar el registro de Windows
Para reducir el efecto de este problema, puede utilizar una entrada de registro LmhostsTimeout para establecer el tiempo de espera para la resolución de nombres NetBIOS. Para ello, siga estos pasos:
  1. Haga clic en Inicio , haga clic en Ejecutar , escriba regedit y, a continuación, presione ENTRAR.
  2. Busque y haga clic en la siguiente subclave del Registro:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\netbt\parameters
  3. En el menú Edición , seleccione nuevo y, a continuación, haga clic en Valor DWORD .
  4. Escriba LmhostsTimeout y, a continuación, presione ENTRAR.
  5. Haga clic con el botón secundario del mouse en LmhostsTimeout y, a continuación, haga clic en Modificar .
  6. Haga clic en decimal en base .
  7. En el cuadro datos del valor , escriba un valor adecuado y, a continuación, haga clic en Aceptar .
  8. Editor de registro de salida.
El valor que especifique para esta entrada del registro representa el valor de tiempo de espera en milisegundos. El valor mínimo para este valor es 1000 (1 segundo). Puede establecer el tiempo de espera en un período más corto para reducir la duración de la CPU upsurge.

Para obtener más información sobre esta configuración del registro, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
314053Parámetros de configuración de TCP/IP y NBT para Windows XP

Solución 2

También puede deshabilitar la resolución de LmHosts para evitar este problema. Para ello, siga estos pasos:
  1. Abra conexiones de red en el panel de control. Para ello, haga clic en Inicio , haga clic en configuración , haga clic en Panel de control y, a continuación, haga doble clic en Conexiones de red .
  2. Haga clic con el botón secundario en la conexión de red apropiada y, a continuación, haga clic en Propiedades .
  3. Seleccione Protocolo Internet (TCP/IP) y, a continuación, haga clic en Propiedades .
  4. Haga clic en Avanzadas .
  5. En la ficha WINS , haga clic para desactivar la casilla de verificación Habilitar la búsqueda de LMHOSTS .
  6. Haga clic en Aceptar tres veces.

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "La información de este artículo se refiere a:".

Más información

Para obtener más información acerca de la terminología relativa de la actualización de software, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
824684Descripción de la terminología estándar utilizada para describir las actualizaciones de software de Microsoft

Soporte técnico para x 64 versiones de Microsoft Windows

Si su hardware venía con una edición x 64 de Microsoft Windows ya instalada, el fabricante del hardware proporciona soporte técnico y asistencia para la edición de 64 bits de Windows. En este caso, el fabricante del hardware proporciona soporte técnico porque incluyó una edición x 64 de Windows con el hardware. El fabricante del hardware podría haber personalizado instalación de la edición x 64 de Windows con componentes únicos. Esos componentes exclusivos podrían incluir controladores de dispositivo específicos o configuraciones opcionales para maximizar el rendimiento del hardware. Si necesita ayuda técnica para una edición x 64 de Windows, Microsoft ofrecerá asistencia de esfuerzo razonable. Sin embargo, es posible que deba contactar directamente con el fabricante. El fabricante es el mejor cualificado para proporcionar el soporte técnico del software que él mismo instaló en el hardware. Si adquirió una edición x 64 de Windows, como una edición x 64 de Windows Server 2003 por separado, póngase en contacto Microsoft para obtener soporte técnico.

Para información de producto acerca de Windows XP Professional x 64 Edition, visite el siguiente sitio Web de Microsoft:
http://www.microsoft.com/windowsxp/64bit/default.mspx
Para información de producto acerca de x 64 de Windows Server 2003, visite el siguiente sitio Web de Microsoft:
http://www.microsoft.com/windowsserver2003/64bit/x64/default.mspx

Propiedades

Id. de artículo: 955860 - Última revisión: miércoles, 29 de octubre de 2008 - Versión: 1.0
La información de este artículo se refiere a:
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Datacenter Edition for Itanium-Based Systems
  • Microsoft Windows Server 2003 Service Pack 1
  • Microsoft Windows Server 2003 Service Pack 2
Palabras clave: 
kbmt kbautohotfix kbexpertiseinter kbwinserv2003postsp2fix kbbug kbfix kbhotfixserver kbqfe KB955860 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 955860

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com