Une utilisation élevée du processeur se produit pour six secondes sur un ordinateur Windows Server 2003 possède plusieurs cartes réseau

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Sommaire

Symptômes

Vous disposez un ordinateur de Windows Server 2003 possède plusieurs cartes réseau. Sur cet ordinateur, l'utilisation de l'UC augmente de 100 pour cent pour environ six secondes lorsque le système essaie résoudre les noms NetBIOS à l'aide du fichier LmHosts. Sur un système multiprocesseur ou multinoyaux, l'utilisation l'UC sur un seul processeur augmente de 100 pour cent pour environ six secondes et l'utilisation du processeur sur d'autres processeurs est également anormalement élevée. Cette situation se produit généralement lorsque plusieurs accès simultanés se des ressources partagées et peuvent se produire plusieurs fois.

Cause

Ce problème se produit en raison d'une condition de concurrence. Une boucle sans fin peut se produire dans le scénario suivant :
  • Plusieurs résolutions de nom de réseau sont effectuées sur chaque carte.
  • Certaines résolutions de nom sont annulées après un d'entre eux réussit.
  • Une recherche dans le fichier LmHosts est effectuée.
Dans ce scénario, la recherche insère une boucle inactive qui peut uniquement être terminée par un délai d'expiration. Ce délai d'attente est configuré dans une entrée de Registre. Par défaut, ce délai est défini sur six secondes.

Résolution

note Un ordinateur équipé de plusieurs cartes réseau est également appelé un ordinateur multirésident. Ce problème se produit lorsque une des cartes sur un ordinateur multirésident était une « carte de bouclage Microsoft ». Cette configuration peut être une raison de la situation de concurrence mentionné dans la section Cause.

Pour vérifier que vous rencontrez ce problème, nous recommandons de désactiver recherche LmHosts comme un test résolution des problèmes. Si ce problème se produit plus après avoir désactivé la recherche LmHosts, vous pouvez être certain que vous rencontrez ce problème.

Informations sur le correctif

Un correctif est disponible auprès de Microsoft. Toutefois, ce correctif est conçu pour corriger le problème décrit dans cet article. Appliquer ce correctif uniquement aux systèmes rencontrant ce problème spécifique. Ce correctif peut subir des tests supplémentaires. Par conséquent, si vous n'êtes pas gravement touché par ce problème, nous vous recommandons d'attendre la prochaine mise à jour logicielles qui contiendra ce correctif.

Si le correctif est disponible pour téléchargement, il y a une section « téléchargement correctif disponible » au début de cet article de base de connaissances. Si cette section n'apparaît pas, contactez le service clientèle Microsoft et de support pour obtenir le correctif.

note Si des problèmes supplémentaires se produisent ou si n'importe quel dépannage est nécessaire, vous devrez peut-être créer une demande de service distincte. Les coûts habituels du support technique s'appliqueront aux autres questions et problèmes non traités par ce correctif spécifique. Pour une liste complète des Microsoft client service et support numéros de téléphone ou pour créer une demande de service distincte, reportez-vous au site de Web Microsoft suivant :
http://support.microsoft.com/contactus/?ws=support
note L'écran de « téléchargement correctif disponible » affiche les langues pour lesquelles le correctif est disponible. Si vous ne voyez pas la langue, il est car un correctif logiciel n'est pas disponible pour cette langue.

Conditions préalables

Pour appliquer ce correctif, il vous faut Windows Server 2003 Service Pack 1 ou Windows Server 2003 Service Pack 2 installé sur l'ordinateur. Pour plus d'informations, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
889100 Comment obtenir le dernier pack service pour Windows Server 2003

Demande de redémarrage

Vous devez redémarrer l'ordinateur après avoir appliqué ce correctif.

Informations sur le remplacement de correctif

Ce correctif ne remplace pas un correctif précédemment publiée.

Informations de fichier

La version anglaise de ce correctif dispose les attributs de fichier (ou attributs de fichier version ultérieure) répertoriés dans le tableau suivant. Les dates et heures de ces fichiers sont exprimées en temps universel coordonné (UTC). Lorsque vous affichez les informations de fichier, il est convertie en heure locale. Pour connaître le décalage entre l'heure UTC et l'heure locale, utilisez l'onglet Fuseau horaire dans l'élément Date et heure du Panneau de configuration.
Windows Server 2003 Service Pack 1, x 86 versions
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Nom de fichierVersion du fichierTaille de fichierDateHeurePlate-forme
NetBT.sys5.2.3790.3193180,22418-Août-200811:14x 86
Windows Server 2003 avec Service Pack 2, x 86 versions
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Nom de fichierVersion du fichierTaille de fichierDateHeurePlate-forme
NetBT.sys5.2.3790.4356180,22418-Août-200811:31x 86
Windows Server 2003 Service Pack 1, versions Itanium
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Nom de fichierVersion du fichierTaille de fichierDateHeurePlate-forme
NetBT.sys5.2.3790.3193561,15218-Août-200813:06IA-64
Windows Server 2003 avec Service Pack 2, versions Itanium
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Nom de fichierVersion du fichierTaille de fichierDateHeurePlate-forme
NetBT.sys5.2.3790.4356561,66418-Août-200813:42IA-64
Windows Server 2003 Service Pack 1, versions 64 x
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Nom de fichierVersion du fichierTaille de fichierDateHeurePlate-forme
NetBT.sys5.2.3790.3193378,88018-Août-200812:59x 64
Windows Server 2003 avec Service Pack 2, versions 64 x
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Nom de fichierVersion du fichierTaille de fichierDateHeurePlate-forme
NetBT.sys5.2.3790.4356347,13618-Août-200813:43x 64
Windows XP Professionnel Édition x 64 avec Service Pack 1
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Nom de fichierVersion du fichierTaille de fichierDateHeurePlate-forme
NetBT.sys5.2.3790.3193378,88018-Août-200812:59x 64
Windows XP Professionnel Édition x 64 avec Service Pack 2
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Nom de fichierVersion du fichierTaille de fichierDateHeurePlate-forme
NetBT.sys5.2.3790.4356347,13618-Août-200813:43x 64

Contournement

Solution de contournement 1

important Cette section, la méthode ou la tâche, contient des étapes qui vous indiquent comment modifier le Registre. Toutefois, des problèmes graves peuvent se produire si modification incorrecte du Registre. Par conséquent, assurez-vous que ces étapes avec soin. Pour la protection supplémentaire, sauvegarder le Registre avant de le modifier. Ensuite, vous pouvez restaurer le Registre si un problème se produit. Pour plus d'informations sur la façon sauvegarder et restaurer le Registre, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
322756 Comment faire pour sauvegarder et restaurer le Registre dans Windows
Pour réduire l'effet de ce problème, vous pouvez utiliser une entrée de Registre LmhostsTimeout pour définir le délai d'attente pour la résolution de nom NetBIOS. Pour ce faire, procédez comme suit :
  1. Cliquez sur Démarrer , cliquez sur Exécuter , tapez regedit et puis appuyez sur ENTRÉE.
  2. Recherchez et cliquez ensuite la sous-clé de Registre suivante :
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\netbt\parameters
  3. Dans le menu Edition , pointez sur Nouveau , puis cliquez sur valeur DWORD .
  4. Tapez LmhostsTimeout et puis appuyez sur ENTRÉE.
  5. Cliquez avec le bouton droit sur LmhostsTimeout , puis cliquez sur Modifier .
  6. Cliquez sur décimale sous base .
  7. Dans la zone données de la valeur , tapez une valeur appropriée, puis cliquez sur OK .
  8. Quittez l'Éditeur du Registre.
La valeur que vous spécifiez pour cette entrée de Registre représente la valeur de délai d'expiration en millisecondes. La valeur minimale pour cette valeur est 1 000 (1 seconde). Vous pouvez définir le délai d'attente à une période plus courte pour réduire la durée de la upsurge du processeur.

Pour plus d'informations sur ce paramètre de Registre, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
314053 Paramètres de configuration TCP/IP et NBT pour Windows XP

Solution de contournement 2

Vous pouvez également désactiver résolution LmHosts à contourner ce problème. Pour ce faire, procédez comme suit :
  1. Ouvrir Connexions réseau dans le Panneau de configuration. Pour ce faire, cliquez sur Démarrer , cliquez sur Paramètres , cliquez sur le Panneau de configuration et puis double-cliquez sur Connexions réseau .
  2. Cliquez avec le bouton droit sur la connexion réseau appropriée, puis cliquez sur Propriétés .
  3. Sélectionnez protocole Internet (TCP/IP) , puis cliquez sur Propriétés .
  4. Cliquez sur avancées .
  5. Sous l'onglet WINS , cliquez sur Désactiver la case à cocher recherche LMHOSTS activer .
  6. Cliquez sur OK à trois reprises.

Statut

Microsoft a confirmé que c'est un problème dans les produits Microsoft répertoriés dans la section « S'applique à ».

Plus d'informations

Pour plus d'informations sur la terminologie mise à jour logicielles, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
824684 Description de la terminologie standard utilisée pour décrire les mises à jour logicielles Microsoft

Support technique pour Microsoft Windows versions 64 x

Si votre matériel a été fourni avec une édition x 64 de Microsoft Windows déjà installée, le fabricant de votre matériel assure le support technique et l'assistance pour l'édition x 64 de Windows. Dans ce cas, le fabricant de votre offre prise en charge car une édition x 64 de Windows était fournie avec votre matériel. Le fabricant de votre matériel ont peut personnaliser l'installation de l'édition x 64 de Windows avec des composants uniques. Des composants uniques peuvent inclure des pilotes de périphérique spécifique ou peuvent inclure des paramètres facultatifs afin d'optimiser les performances du matériel. Microsoft vous fournira une assistance raisonnable si vous avez besoin aide technique pour une édition x 64 de Windows. Toutefois, vous devrez peut-être contacter directement. Votre est le mieux qualifié pour prendre en charge le logiciel le fabricant de votre installé sur le matériel. Si vous avez acheté une version x 64 de Windows telle que Windows Server 2003 x 64 Édition séparément, contactez Microsoft pour obtenir un support technique.

Pour plus d'informations sur Windows XP Professionnel Édition x 64, reportez-vous au site de Web Microsoft suivant :
http://www.microsoft.com/windowsxp/64bit/default.mspx
Pour plus d'informations sur x 64 et les versions de Windows Server 2003, reportez-vous au site de Web Microsoft suivant :
http://www.microsoft.com/windowsserver2003/64bit/x64/default.mspx

Propriétés

Numéro d'article: 955860 - Dernière mise à jour: mercredi 29 octobre 2008 - Version: 1.0
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Datacenter Edition for Itanium-Based Systems
  • Microsoft Windows Server 2003 Service Pack 1
  • Microsoft Windows Server 2003 Service Pack 2
Mots-clés : 
kbmt kbautohotfix kbexpertiseinter kbwinserv2003postsp2fix kbbug kbfix kbhotfixserver kbqfe KB955860 KbMtfr
Traduction automatique
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La version anglaise de cet article est la suivante: 955860
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