包含许多软件包的任务序列可能要花费更长的时间安装系统中心配置管理器 2007 Service Pack 1 或 949225 的修复程序后,运行

文章翻译 文章翻译
文章编号: 955955 - 查看本文应用于的产品
展开全部 | 关闭全部

本文内容

症状

请考虑以下情形:
  • 在计算机上安装修复程序 949225。或在计算机上安装了 Microsoft 系统中心配置管理器 2007 Service Pack 1 (SP1)。
  • 任务序列包含多个包。例如对于任务序列包含 50 软件包。
在这种情况下任务序列需要更长的时间比在系统中心配置管理器 2007 RTM 或修补程序 949225 没有完成。此外,Smsts.log 文件中记录以下消息:
等待生效的本地策略 <date and time >
此外,之间每隔两个程序包没有 90 秒的延迟。

原因

出现此问题是由于在修补程序 949225 中引入的行为更改。

此更改将添加 90 秒的延迟,以确保许多任务序列分配给客户端在同一时间时系统中心配置管理器客户端上执行所有任务序列。但是,它会导致一个任务序列采用较长的时间运行如果它包含许多软件包的副作用。

解决方案

服务包信息

若要解决此问题,获取最新的 service pack,Microsoft 系统中心配置管理器 2007,可从 Microsoft 网站: http://www.microsoft.com/downloads/details.aspx?FamilyID=3318741a-c038-4ab1-852a-e9c13f8a8140
在此服务包中解决的问题是资源列表单击下面的文章编号,在 Microsoft 知识库中:
971348修补程序和系统中心配置管理器 2007 Service Pack 2 中所包含的更新的列表

修补程序信息

可以从 Microsoft 获得支持的修补程序。但是,此修补程序被用于解决本文所述的此问题。此修补程序仅应用于出现本文所述问题的系统。此修补程序可能会接受进一步的测试。因此,如果此问题没有对您造成严重的影响,我们建议您等待包含此修补程序的下一个软件更新。

是否可供下载此修补程序没有"提供修补程序下载"部分中,在这篇知识库文章的顶部。如果不会显示此部分,请联系 Microsoft 客户服务和支持以获取此修复程序。

注意如果出现其他问题,或者如果需要进行任何故障诊断,则您可能不得不创建单独的服务请求。将正常收取支持费用将应用于其他支持问题和不需要进行此特定的修补程序的问题。有关完整列表的 Microsoft 客户服务和支持的电话号码,或创建一个单独的服务请求,请访问下面的 Microsoft 网站:
http://support.microsoft.com/contactus/?ws=support
注意"提供修补程序下载"窗体所显示的此修复程序是可用的语言。如果您看不到您的语言,则是一个修复程序不能用于该语言。

系统必备组件

您必须具有要应用此修补程序安装的系统中心配置管理器 2007 Service Pack 1。

重新启动要求

您不必在应用此修补程序包后重新启动计算机。

修补程序替换信息

此修补程序不替代以前发布的修补程序。

文件信息

此修补程序的英文版具有的文件属性 (或更新的文件属性) 在下表中列出。日期和时间对这些文件列出在协调世界时 (UTC)。当您查看文件信息时,将转换为本地时间。若要 UTC 与本地时间之间的时差使用控制面板中的 日期和时间 项中的 时区 选项卡。
收起该表格展开该表格
文件的名称文件版本文件大小日期时间平台
Mp.msi不适用8,814,0802008 年七月 20 日18: 20不适用
Policyagentendpoint.dll4.0.6221.1110471,4802008 年十一月 30 日19: 45x86
Sccm2007ac sp1 kb955955 x86.msp不适用463,3602008 年十一月 30 日19: 45不适用

安装说明

必须仅在受影响的 SMS 客户端计算机上安装此修补程序。

若要简化此修补程序的分发方案,修补程序安装程序会自动创建包,包含 SCCM2007AC SP1 KB955955 X86.msp 文件的程序。SCCM2007AC SP1 KB955955 X 86 ENU.exe 文件创建仅将软件包和程序。才能成功地在 SMS 高级客户端上安装此修补程序包,您必须创建一个广告和目标所有 SCCM 2007 SP1 高级客户端,以进行分发。若要这样做,请按照下列步骤操作:
  1. 双击 SCCM2007AC SP1 KB955955 X 的 86 ENU.exe 文件,然后按照说明创建包和程序。
  2. 单击 开始,单击 所有程序,都单击 microsoft 系统中心,都单击 配置管理器 2007年,然后都单击 ConfigMgr 控制台
  3. 配置管理器控制台中展开 计算机管理 文件夹,展开 软件分发、 展开 ,用鼠标右键单击 KB955955-高级客户端修补程序-SCM、 指向 分布,然后单击 软件
  4. 按照分发软件向导公布和部署修补程序软件包中。

如果您要手动安装 SMS 客户端计算机上的修复程序,您可以安装 SCCM2007AC SP1 KB955955 X86.msp 文件从 SMS 客户端计算机上的命令行,如下所示:
msiexec.exe/P SCCM2007AC SP1 KB955955 X86.msp/L * v %temp% \ SCCM2007AC-SP1-KB955955-X86.log X86.log/q 重新安装所有重建都 = 都 = mous
注意%temp% 占位符是安装日志文件的位置。SCCM2007AC-SP1-KB955955-X86.log 占位符是安装日志文件的名称。

对于操作系统部署 KB955955 hotifx 必须安装期间在"安装 Windows 和 ConfigMgr"任务中 ConfigMgr OSD 任务序列。否则,该问题仍然存在任务顺序执行时。此外,因此"安装软件"任务不能用于安装此修补程序试图执行将导致 ConfigMgr 客户端服务停止,这将导致该任务序列失败。

要安装 KB955955 修补程序过程 ConfigMgr OSD 任务序列中,使用该 修补 = 以下 Microsoft 知识库文章中描述的选项:
907423如何在系统管理服务器 2003年高级客户端的初始安装中包括的更新
要安装 KB955955 修补程序过程 ConfigMgr 2007 OSD 任务序列中,请按照下列步骤操作:
  1. 在网站服务器上应用此修复程序。
  2. 一旦在站点服务器上应用此修补程序,ConfigMgr 客户端安装文件将更新以包括下的 ConfigMgr 客户端安装文件目录 \i386\hotfix\KB955955\ KB955955 修补程序。因为已更新 ConfigMgr 客户端安装文件,请务必更新存在 ConfigMgr 客户端安装软件包的分发点。
  3. 用鼠标右键单击您需要更改,任务序列,然后单击 编辑
  4. 单击 设置窗口和 ConfigMgr
  5. 安装属性 框中键入以下内容:
    PATCH="%_SMSTSMDataPath%\OSD\ <Package_ID> \i386\hotfix\KB955955\SCCM2007AC-SP1-KB955955-x86.msp"
    注意请确保引号包含该路径的一部分。此外,该 <Package_ID > 占位符是 ConfigMgr 客户端安装程序包 ConfigMgr 2007 中不用方括号 (&lt; &gt;) 的包 ID。此外,请确保它是 ConfigMgr 客户端安装程序包和 $ 不 KB955955 修补程序软件包的包 ID。

状态

Microsoft 已经确认这是在"适用于"一节中列出的 Microsoft 产品中的问题。

更多信息

有关详细的信息请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:
824684用于描述 Microsoft 软件更新的标准术语的说明

属性

文章编号: 955955 - 最后修改: 2010年2月26日 - 修订: 7.0
这篇文章中的信息适用于:
  • Microsoft System Center Configuration Manager 2007
关键字:?
kbmt kbautohotfix kbexpertiseinter kbbug kbfix kbhotfixserver kbqfe kbpubtypekc KB955955 KbMtzh
机器翻译
注意:这篇文章是由无人工介入的微软自动的机器翻译软件翻译完成。微软很高兴能同时提供给您由人工翻译的和由机器翻译的文章, 以使您能使用您的语言访问所有的知识库文章。然而由机器翻译的文章并不总是完美的。它可能存在词汇,语法或文法的问题,就像是一个外国人在说中文时总是可能犯这样的错误。虽然我们经常升级机器翻译软件以提高翻译质量,但是我们不保证机器翻译的正确度,也不对由于内容的误译或者客户对它的错误使用所引起的任何直接的, 或间接的可能的问题负责。
点击这里察看该文章的英文版: 955955
Microsoft和/或其各供应商对于为任何目的而在本服务器上发布的文件及有关图形所含信息的适用性,不作任何声明。 所有该等文件及有关图形均"依样"提供,而不带任何性质的保证。Microsoft和/或其各供应商特此声明,对所有与该等信息有关的保证和条件不负任何责任,该等保证和条件包括关于适销性、符合特定用途、所有权和非侵权的所有默示保证和条件。在任何情况下,在由于使用或运行本服务器上的信息所引起的或与该等使用或运行有关的诉讼中,Microsoft和/或其各供应商就因丧失使用、数据或利润所导致的任何特别的、间接的、衍生性的损害或任何因使用而丧失所导致的之损害、数据或利润不负任何责任。

提供反馈

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com