Información acerca de 3.2 en Windows Vista del Monitor de red

Seleccione idioma Seleccione idioma
Id. de artículo: 955998 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

INTRODUCCIÓN

Este artículo contiene información acerca de Microsoft Network Monitor 3.2. El Monitor de red 3.2 es un analizador de protocolo que permite capturar, ver y analizar datos de la red. Puede utilizar para ayudar a solucionar problemas con aplicaciones en la red.

Este artículo contiene descarga y información de soporte técnico, notas de instalación y 3.2 del Monitor de red de información de uso general.

Más información

3.2 Del Monitor de red es la versión más reciente de Network Monitor. En la lista siguiente contiene información sobre las nuevas características de 3.2 de Monitor de red:
  • Seguimiento de procesos. Puede ver el nombre de proceso y el PID de todos los procesos que generan tráfico de red en un equipo. Además, puede utilizar el árbol de conversación para ver las tramas que están asociadas con cada proceso.
  • Busque las conversaciones. Puede aislar rápidamente marcos en la misma conversación de red. Esto incluye secuencias TCP, flujos HTTP y otros tipos de tráfico de red.
  • Compatibilidad con archivo de captura PCAP.

    Nota

    Red Monitor 3.2 incluye software desarrollado por las entidades siguientes:
    • La Universidad de California, Berkeley y sus colaboradores
    • Kungliga Tekniska Hogskolan y sus colaboradores
    • Yen yen LIM y Universidad Dakota del Norte
  • El diseño del motor de captura se ha modificado para mejorar la velocidad de captura para redes de alta velocidad. Monitor de red colocaciones 3.2 considerablemente menos marcos que 3.1 del Monitor de red.
    • Conjunto de analizador amplia. Monitor de red 3.2 ahora admite analizadores de protocolos de más de 300. Esto incluye los protocolos que están cubiertos por las especificaciones de protocolo abierto de Windows. Para obtener más información al respecto, visite el siguiente sitio Web de Microsoft:
      http://msdn.microsoft.com/en-us/library/cc216517.aspx
    • API de Monitor de red. Puede crear sus propias aplicaciones que capturar, analizar y analizan el tráfico de red.
    • Administración mejorada del Analizador. De forma predeterminada, se carga sólo un subconjunto de analizadores. Puede cargar el Analizador completo establecer cambiando el orden de búsqueda de analizador. Puede hacerlo en el elemento Analizador en el menú Opciones .
    • Compatibilidad con marco truncamiento. Puede limitar el número de bytes capturados por trama para mejorar el rendimiento. Puede hacerlo en el elemento Opciones en el menú Herramientas .
    • Documentación más amplia de la NPL. Esta documentación incluye documentación sobre el nuevo NMAPI. Puede obtener acceso a esta documentación desde el elemento NPL y documentación de API en el menú Ayuda .
    • Mejorado filtrado de elementos dentro de NPL mientras bucles o matrices. Puede especificar un índice de la matriz o en el tiempo bucle que desea filtrar.
    • Disponibilidad de una versión de IA-64.
    • ContainsBin complemento. Puede buscar tramas para secuencias de bytes arbitrarias o cadenas. Por ejemplo, puede buscar "msn" mediante la consulta siguiente:
      ContainsBin (FrameData, ASCII, ? msn ?)
    • Indicadores de interfaz de usuario más. Indicadores nuevos incluyen el estado de conversación, fotogramas descartados y el número de tramas en el búfer de captura.

Descargar e información de soporte técnico

Para descargar 3.2 de Monitor de red, visite el siguiente sitio Web de Microsoft:
https://connect.microsoft.com/site/sitehome.aspx?SiteID=216
Nota Este sitio incluye descargas de 3.2 de Monitor de red para las versiones de Windows Vista x 86 - versiones basadas en para Windows Vista x 64 - basado y para las versiones de Windows Vista IA - 64 - basado.

Para información de soporte técnico sobre 3.2 de Monitor de red, visite el siguiente sitio Web de Microsoft:
http://connect.microsoft.com
Debes iniciar sesión este sitio Web utilizando un Windows Live ID. Después de iniciar la sesión, puede aplicar a participar en el programa. Para ello, haga clic en Aplicar junto al Monitor de red 3 en la columna Opciones de la tabla. Después de inscribirse en el sistema, tendrá acceso a grupos de noticias y puede enviar informes de errores.

Notas de instalación

El Monitor de red 3.2 puede coexistir con el Monitor de red 2. x y versiones anteriores. De forma predeterminada, 3.2 de Monitor de red se instala en la carpeta % Program Files%\Microsoft Network Monitor 3. Por lo tanto, no se produzcan conflictos si está instalada una versión anterior en una carpeta diferente en el equipo. Cuando instala 3.2 de Monitor de red, se desinstalan las versiones anteriores de Monitor de red 3.

Red Monitor 3.2 incluye un controlador para equipos basados en Windows Vista. Este controlador admite nuevas características de red controlador interfaz especificación (NDIS) 6.0 controlador. Si estás utilizando herramientas que se basan en Monitor de red 2. x NPPTools, estas herramientas ya no funcionará. Para capturar datos de red en Windows Vista, debe utilizar 3.2 de Monitor de red. 2 De Monitor de red. x no captura datos de la red correctamente en Windows Vista.

Éstos son los requisitos de hardware sugerido para 3.2 de Monitor de red:
  • procesador de 1 gigahercio (GHz) o más rápido
  • 1 gigabyte (GB) o más de memoria
  • 25 megabytes (MB) de espacio libre en el disco duro y espacio en disco adicional para almacenar los archivos de captura
3.2 Del Monitor de red es compatible con los sistemas operativos siguientes:
  • Windows Vista
  • Windows Server 2008
  • Windows XP
  • Windows Server 2003
Las advertencias y precauciones

Actualmente, no se recomienda que ejecute el Monitor de red 3 en sistemas de producción. En escenarios donde es importante la carga, utilice la siguiente versión de la línea de comandos de Monitor de red 3 para capturar datos de red:
nmcap.exe
Para obtener más información acerca de Nmcap.exe, consulte la sección "Herramienta de línea de comandos de Nmcap.exe".

El Monitor de red 3.2 puede consumir muchos recursos del sistema. Los siguientes son algunas consideraciones importantes.
  • espacio en disco

    Cuando inicia una sesión de captura, Monitor de red 3 almacena marcos en una secuencia de archivos de captura que se encuentran en la TEMP carpeta. De forma predeterminada, el tamaño de cada archivo de captura es 20 MB. Si no detiene la sesión de captura, Monitor de red 3 continúa almacenar archivos de captura en la carpeta temporal hasta que el espacio libre en el disco duro en el equipo está por debajo 2 por ciento. A continuación, Monitor de red 3 detiene la sesión de captura.

    Puede configurar el tamaño de archivo de captura, la ubicación en que la captura se almacenan los archivos, el límite de espacio libre en el disco duro y otros opciones de captura. Para ello, seleccione Opciones en el menú Herramientas y haga clic en la ficha captura .
  • uso de memoria

    Además de capturar datos, Monitor de red 3 asigna propiedades a marcos y, a continuación, utiliza estas propiedades para agrupar los marcos en las conversaciones. Monitor de red 3 muestra las conversaciones y sus marcos asociados en una estructura de árbol en la ventana de conversaciones de red.

    La Característica de conversaciones de Monitor de red 3 aumenta considerablemente el uso de memoria. Esto puede hacer que el equipo dejara de responder. De forma predeterminada, la característica de conversaciones está deshabilitada. Algunos filtros de protocolo de nivel superiores requieren las propiedades de la conversación. Para habilitar la característica de conversaciones, haga clic en la ficha Página de inicio y, a continuación, haga clic en para activar la casilla de verificación Habilitar conversaciones .
  • utilización del procesador

    La característica de conversaciones de Monitor de red 3 puede aumentar significativamente la utilización del procesador cuando se procesan muchos marcos. De forma predeterminada, la característica de conversaciones está deshabilitada.

Uso general

Información de uso general de Monitor de red 3 incluye lo siguiente.
  • capturar datos de red

    Si desea minimizar el efecto en los recursos del sistema cuando utiliza Monitor de red 3 para capturar datos, utilice el Nmcap.exe herramienta de línea de comandos para capturar datos.

    Red 3 Monitor permite recopilar datos de red y ver este datos en tiempo real como se captura. A continuación para iniciar una sesión de captura en el Monitor de red 3, haga clic en la Página de inicio , haga clic en crear una nueva captura y, haga clic en Iniciar captura o presione F5.
  • filtros

    Monitor de red 3 utiliza una sintaxis simple que es la expresión basada en marcos de filtro. El usuario se muestran todas las tramas que coincidan con la expresión seleccionada. Para obtener más información acerca de los filtros, realice una de las siguientes acciones:
    • Ver los temas en la sección "Utilizar filtros" del manual del usuario de 3 de Monitor de red. Para ello, haga clic en contenido en el menú Ayuda y, a continuación, haga doble clic en Utilizar filtros .
    • En el menú Ayuda , elija cómo y, a continuación, haga clic en Usar filtros .
    • Para ver los filtros estándar, haga clic en el Captura filtro la ficha de Filtro de presentación o.
  • conversaciones

    De forma predeterminada, la característica de conversación está habilitada. Esta configuración puede consumir mucha memoria, especialmente en escenarios donde capturar gran cantidad de datos o donde capturar datos durante largos períodos. Consulte la sección "NMCap" para obtener información acerca de cómo capturar datos durante largos períodos.

    Conversaciones habilitan el agrupamiento y presentación de marcos en la ventana de conversaciones de red en una estructura de árbol con las conversaciones a las que pertenecen. Por ejemplo, TCP los datos que utiliza el mismo puerto de origen y el mismo puerto de destino se organizan en un grupo. Cuando haga clic en un nodo en la ventana de conversaciones de red, el filtro de conversación correspondiente se aplica automáticamente a los marcos en la ventana Resumen de marco. Se muestran únicamente las tramas que pertenecen a esa conversación determinada.
  • herramienta de línea de comandos Nmcap.exe

    La herramienta de línea de comandos Nmcap.exe permite configurar el inicio y detención de horas para una sesión de captura. También puede utilizar esta herramienta de línea de comandos a capturas encadenadas creados. Capturas encadenadas le permiten crear varios archivos de captura mientras que mantener reducido el tamaño de cada archivo de captura.
  • lenguaje (NPL) de análisis de red

    Analizadores de 3 de Monitor de red se escriben en un idioma que está diseñado específicamente para simplificar el desarrollo de analizador más sencillo. Esto también proporciona un nivel de protección contra los posibles intentos de código malintencionado que puede producirse si se crearon los analizadores como archivos DLL. Puede ver o modificar los analizadores que se incluyen en Monitor de red 3. Documentación del lenguaje NPL puede obtenerse en la Ayuda de menú.
  • NMAPI

    NMAPI le permite obtener acceso mediante programación el motor de análisis y capturado de 3.2 de Monitor de red. Vea el menú Ayuda para un vínculo a la documentación de la API.

Problemas comunes

Problemas comunes de 3.2 de Monitor de red incluyen:
  • Protocolos no analizar correctamente. Este problema puede producirse si se cumple cualquiera de las condiciones siguientes:
    • La característica de conversaciones está deshabilitada.

      Ciertos protocolos dependen de las propiedades de conversación para almacenar valores de estado que sea necesario en marcos posterior. Por ejemplo, TCP requiere conversaciones para almacenar información sobre marcos retransmitidos. El filtro TCP retransmite no funcionará a menos que está habilitada la característica conversaciones.

      De forma similar, el protocolo bloque de mensajes de servidor (SMB) no puede traducir la respuesta a un comando Transact , porque la respuesta no contiene el comando original. El comando original se guarda en las propiedades de la conversación.
    • No tiene el Analizador completo establecer cargado. La configuración predeterminada analizador 3.2 de Monitor de red es un subconjunto del conjunto completo. Este comportamiento permite ejecutar más rápidamente 3.2 de Monitor de red. Si desea cargar el conjunto completo, vea el tema ? procedimientos I?Load completos analizadores ?? en el menú Ayuda .
  • Recibirá uno de los siguientes mensajes de error al ejecutar el Monitor de red 3 en un equipo basado en Windows Vista:
    Ninguno de los adaptadores de red enlazado a la Netmon controlador
    Este adaptador de red no está configurado para capturar con el Monitor de red
    Este problema se produce si se cumple alguna de las condiciones siguientes:
    • No está ejecutando Monitor de red 3 como administrador.
    • No es un miembro de los usuarios de Netmon grupo.
    Para obtener más información, vea el Monitor de red 3 libera notas, o vea el tema "Operativo en Windows Vista" en el Monitor de red 3 Ayuda menú.

Referencias

Para información de soporte técnico acerca de Monitor de red 3, visite los siguientes sitios Web de Microsoft:
http://connect.microsoft.com
http://blogs.technet.com/netmon

Propiedades

Id. de artículo: 955998 - Última revisión: miércoles, 24 de septiembre de 2008 - Versión: 2.3
La información de este artículo se refiere a:
  • Windows Vista Ultimate
  • Windows Vista Enterprise
  • Windows Vista Ultimate 64-bit edition
  • Windows Vista Enterprise 64-bit edition
Palabras clave: 
kbmt kbhowto kbinfo kbexpertiseinter KB955998 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 955998

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com