Informations sur cet outil 3.2 dans Windows Vista

Traductions disponibles Traductions disponibles
Numéro d'article: 955998 - Voir les produits auxquels s'applique cet article
Agrandir tout | Réduire tout

INTRODUCTION

Cet article contient des informations sur Microsoft Network Monitor 3.2. Le Moniteur réseau 3.2 est un analyseur de protocole permettant de capturer, afficher et analyser les données du réseau. Vous pouvez l'utiliser pour résoudre les problèmes avec les applications sur le réseau.

Cet article contient des télécharger et obtenir des informations sur le support technique, notes d'installation et utilisation générale informations 3.2 de Moniteur réseau.

Plus d'informations

3.2 Le Moniteur réseau est la dernière version de Network Monitor. La liste suivante contient des informations sur les nouvelles fonctionnalités de Network Monitor 3.2 :
  • Suivi de processus. Vous pouvez afficher le nom de processus et le PID de tous les processus qui génèrent du trafic réseau sur un ordinateur. En outre, vous pouvez utiliser l'arborescence de la conversation pour afficher les trames qui sont associés à chaque processus.
  • Trouver des conversations. Vous pouvez isoler rapidement les cadres dans la même conversation réseau. Cela inclut flux TCP, les flux HTTP et les autres types de trafic réseau.
  • Prise en charge des fichiers de capture PCAP.

    Remarque

    Réseau moniteur 3.2 comprend un logiciel qui a été développé par les entités suivantes :
    • L'université de Californie, Berkeley et ses collaborateurs
    • Kungliga Tekniska Hogskolan et ses collaborateurs
    • Yen Yen LIM et North Dakota State University
  • Le moteur de capture a été repensé pour améliorer la vitesse de capture de réseaux à grande vitesse. Moniteur réseau projections 3.2 beaucoup moins de cadres que Network Monitor 3.1.
    • Analyse complète ensemble. 3.2 Le Moniteur réseau prend désormais en charge analyseurs pour les protocoles plus de 300. Cela inclut les protocoles qui sont couverts par les spécifications de protocole ouvrir Windows. Pour plus d'informations, site Web Microsoft suivant :
      http://msdn.microsoft.com/en-us/library/cc216517.aspx
    • API du Moniteur réseau. Vous pouvez créer vos propres applications qui capturent, analyser et analysent le trafic réseau.
    • Gestion de l'analyseur améliorée. Par défaut, seul un sous-ensemble des analyseurs est chargé. Vous pouvez charger l'analyseur complet définir en modifiant l'ordre de recherche analyseur. Pour cela, sous l'élément Analyseur dans le menu Options .
    • Prise en charge de troncation de cadre. Vous pouvez limiter le nombre d'octets capturés par trame pour améliorer les performances. Pour cela, sous l'élément Options dans le menu Outils .
    • Documentation plus complète de la NPL. Cette documentation comprend la documentation sur le nouveau NMAPI. Vous pouvez accéder à cette documentation de l'élément NPL et la documentation API dans le menu aide .
    • Amélioration de filtrage d'éléments dans NPL lors de la boucle ou de tableaux. Vous pouvez spécifier un index dans le tableau ou dans le temps boucle que vous souhaitez filtrer.
    • Disponibilité d'une version IA-64.
    • ContainsBin plug-in. Vous pouvez rechercher des cadres des séquences d'octets arbitraires ou des chaînes. Par exemple, vous pouvez rechercher «msn» aide de la requête suivante :
      ContainsBin (FrameData, ASCII, ? msn respectez)
    • Indicateurs de l'interface utilisateur plus. Nouveaux indicateurs incluent état de conversation, trames ignorées et le nombre de trames dans le tampon de capture.

Téléchargement et informations de support technique

Pour télécharger 3.2 de Moniteur réseau, site Web Microsoft suivant :
https://connect.microsoft.com/site/sitehome.aspx?SiteID=216
Remarque Ce site inclut des téléchargements 3.2 de Moniteur réseau pour les versions Windows Vista x 86, pour Windows Vista x 64 - et pour les versions de Windows Vista IA - 64 - en fonction.

Pour la prise en charge d'informations sur Network Monitor 3.2, site Web Microsoft suivant :
http://connect.microsoft.com
Vous devez vous connecter à ce site Web en utilisant Windows Live ID. Après que vous vous connectez, vous pouvez appliquer à participer au programme. Pour ce faire, cliquez sur Appliquer à côté du Moniteur réseau 3 dans la colonne Options de la table. Une fois que vous inscrire dans le programme, vous avez accès à des groupes de discussion et vous pouvez envoyer des rapports de bogues.

Notes d'installation

3.2 Le Moniteur réseau peut coexister avec Moniteur réseau 2. x et les versions antérieures. Par défaut, 3.2 de Moniteur réseau est installé dans le dossier % programme Files%\Microsoft Network Monitor 3. Par conséquent, est en conflit ne se produire pas si une version antérieure est installée dans un dossier différent sur l'ordinateur. Lorsque vous installez 3.2 de Moniteur réseau, les versions antérieures de Moniteur réseau 3 sont désinstallées.

Réseau Moniteur 3.2 comprend un pilote pour les ordinateurs Windows Vista. Ce pilote prend en charge nouvelles fonctionnalités de la NDIS Network Driver Interface Specification () 6.0 pilote. Si vous utilisez des outils qui reposent sur Moniteur réseau 2. x NPPTools, ces outils ne fonctionneront plus. Pour capturer des données réseau dans Windows Vista, vous devez utiliser 3.2 de Moniteur réseau. Réseau moniteur 2. x ne capture pas les données réseau correctement dans Windows Vista.

Voici la configuration matérielle suggérée pour 3.2 de Moniteur réseau :
  • processeur 1 gigahertz (GHz) ou plus rapide
  • 1 gigaoctet (Go) ou plus de mémoire
  • 25 méga-octets (Mo) de l'espace libre sur le disque dur et l'espace disque supplémentaire pour stocker les fichiers de capture
3.2 Le Moniteur réseau est pris en charge sur les systèmes d'exploitation suivants :
  • Windows Vista
  • Windows Server 2008
  • Windows XP
  • Windows Server 2003
Avertissements et les avertissements

Actuellement, nous vous déconseillons d'exécuter 3 de Moniteur réseau sur des systèmes de production. Dans les scénarios où la charge est importante, utilisez la version de ligne de commande suivante de 3 de Moniteur réseau pour capturer des données du réseau :
nmcap.exe
Pour plus d'informations sur Nmcap.exe, consultez la section «Outil de ligne de commande Nmcap.exe».

3.2 Le Moniteur réseau peut consommer beaucoup de ressources système. Voici certaines considérations importantes.
  • espace disque

    Lorsque vous démarrez une session de capture, Moniteur réseau 3 stocke les cadres dans une séquence de fichiers de capture qui se trouvent dans le Temp dossier. Par défaut, la taille de chaque fichier de capture est 20 Mo. Si vous n'arrêtez pas la session de capture, Moniteur réseau 3 continue de stocker les fichiers de capture dans le dossier Temp jusqu'à ce que l'espace disque libre sur l'ordinateur devient inférieur à % 2. Ensuite, Moniteur réseau 3 arrête la session capture.

    Vous pouvez configurer la taille de fichier de capture, l'emplacement dans lequel la capture de fichiers sont stockés, la limite d'espace libre disque dur et d'autres options de capture. Pour ce faire, pointez sur Options dans le menu Outils et puis cliquez sur l'onglet capture .
  • la mémoire

    Parallèlement à la capture de données, Moniteur réseau 3 affecte des propriétés aux trames, puis utilise ces propriétés pour regrouper les cadres de conversations. Le Moniteur réseau 3 affiche les conversations et les cadres associés dans une arborescence dans la fenêtre de conversations de réseau.

    Les Conversations dans Network Monitor 3 considérablement optimisées utilisation de la mémoire. Cela peut provoquer le blocage de l'ordinateur. Par défaut, la fonctionnalité de conversations est désactivée. Certains filtres de protocole de niveau supérieur nécessitent des propriétés de conversation. Pour activer la fonctionnalité de conversations, cliquez sur l'onglet Page de démarrage , puis cliquez pour sélectionner la case à cocher Activer les conversations .
  • utilisation du processeur

    La fonctionnalité de conversations de 3 de Moniteur réseau peut augmenter considérablement l'utilisation du processeur lorsque beaucoup de trames est traitées. Par défaut, la fonctionnalité de conversations est désactivée.

Utilisation générale

Informations d'utilisation générale 3 de Moniteur réseau sont les suivantes.
  • capturer des données réseau

    Si vous souhaitez minimiser l'impact sur les ressources système lorsque vous utilisez 3 de Moniteur réseau pour capturer des données, utilisez le Nmcap.exe outil de ligne de commande pour capturer des données.

    Réseau vous permet de moniteur 3 vous collectez des données du réseau et afficher cette données en temps réel comme il est capturé. Pour démarrer une session de capture dans Moniteur réseau 3, cliquez sur Page d'accueil , cliquez sur créer une nouvelle capture , puis soit cliquez sur Démarrer la capture ou appuyez sur F5.
  • filtres

    3 Le Moniteur réseau utilise une syntaxe simple qui est basé à filtre cadres. Toutes les trames qui correspondent à l'expression sélectionnée sont affichent à l'utilisateur. Pour plus d'informations sur les filtres, effectuer les opérations suivantes :
    • Afficher les rubriques dans la section «Using Filters» du Guide de l'utilisateur de 3 de Moniteur réseau. Pour cela, cliquez sur contenu dans le menu aide , puis double-cliquez sur Utilisation des filtres .
    • Dans le menu aide , pointez sur comment et puis cliquez sur Utiliser les filtres .
    • Pour afficher les filtres standard, cliquez sur le capture filtre l'onglet Filtre d'affichage ou.
  • conversations

    Par défaut, la fonction de conversation est activée. Ce paramètre peut consommer beaucoup de mémoire, en particulier dans les scénarios où vous capturez beaucoup de données ou capturer des données sur longues périodes. Consultez la section «NMCap» pour savoir comment capturer des données sur longues périodes.

    Conversations activer le regroupement et affichage des cadres dans la fenêtre de conversations de réseau dans une arborescence en les conversations auquel ils appartiennent. Par exemple, TCP données qui utilise le même port source et le même port de destination sont organisées dans un groupe. Lorsque vous cliquez sur un n?ud dans la fenêtre de conversations de réseau, le filtre de conversation correspondant est automatiquement appliqué à cadres dans la fenêtre Résumé des trames. Uniquement les trames qui appartiennent à cette conversation particulier sont affichées.
  • outil de ligne de commande Nmcap.exe

    L'outil de ligne de commande Nmcap.exe vous permet de configurer le démarrage et arrêt heures pour une session de capture. Vous pouvez également utiliser cet outil de ligne de commande pour capture chaînée créé. Captures chaînées permettent de créer plusieurs fichiers de capture tout en conservant la taille de chaque fichier de capture petite.
  • réseau analyse Language (NPL)

    Analyseurs de 3 du Moniteur réseau sont écrites dans un langage qui est conçu spécifiquement pour faciliter le développement de l'analyseur plus simple. Cela offre également un niveau de protection contre l'exploitation potentielle du code malveillant peut se produire si parseurs ont été créés en tant que fichiers DLL. Vous pouvez afficher ou modifier les analyseurs qui sont inclus dans le Moniteur réseau 3. Documentation sur le langage NPL est accessibles dans l' aide de menu.
  • NMAPI

    NMAPI vous permet d'accéder par programme le moteur de capture et analyse de 3.2 de Moniteur réseau. Consulter le menu aide d'un lien à la documentation sur l'API.

Problèmes courants

Problèmes 3.2 de Moniteur réseau courants sont les suivants :
  • Protocoles n'analysent pas correctement. Ce problème peut se produire si une des conditions suivantes est remplie :
    • La fonctionnalité de conversations est désactivée.

      Certains protocoles dépendent des propriétés de conversation pour stocker les valeurs d'état qui peuvent être nécessaires dans les cadres ultérieure. Par exemple, TCP nécessite des conversations de stocker des informations de trames retransmis. Le filtre TCP retransmet ne fonctionnera pas, sauf si la fonctionnalité de conversations est activée.

      De même, le protocole SMB (Server Message Block) Impossible de convertir la réponse à une commande Transact , car la réponse ne contient pas la commande d'origine. La commande d'origine est enregistrée dans les propriétés de conversation.
    • Vous n'avez pas l'analyseur complet définir chargé. La configuration d'analyseur par défaut pour 3.2 de Moniteur réseau est un sous-ensemble de l'ensemble. Ce comportement vous permet de Network Monitor 3.2 exécution plus rapide. Si vous souhaitez charger l'ensemble, consultez la rubrique ? Comment analyseurs complets I?Load? respectez dans le menu aide .
  • Un des messages d'erreur suivants s'afficher lorsque vous exécutez le Moniteur réseau 3 sur un ordinateur Windows Vista :
    Aucune des cartes réseau sont liés à la Netmon pilote
    Cette carte réseau n'est pas configurée pour capturer à l'aide du Moniteur réseau
    Ce problème se produit si une des conditions suivantes est remplie :
    • Vous n'exécutez pas le Moniteur réseau 3 en tant qu'administrateur.
    • Vous n'êtes pas membre de l'utilisateur Netmon groupe.
    Pour plus d'informations, consultez le Moniteur réseau 3 libère notes, ou consultez la rubrique «Fonctionnement sur Windows Vista» sur le Moniteur réseau 3 aide menu.

Références

Pour la prise en charge d'informations 3 de Moniteur réseau, visitez les sites Web Microsoft suivant :
http://connect.microsoft.com
http://blogs.technet.com/netmon

Propriétés

Numéro d'article: 955998 - Dernière mise à jour: mercredi 24 septembre 2008 - Version: 2.3
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Windows Vista Édition Intégrale
  • Windows Vista Entreprise
  • Windows Vista Édition Intégrale 64 bits
  • Windows Vista Entreprise 64 bits
Mots-clés : 
kbmt kbhowto kbinfo kbexpertiseinter KB955998 KbMtfr
Traduction automatique
IMPORTANT : Cet article est issu du système de traduction automatique mis au point par Microsoft (http://support.microsoft.com/gp/mtdetails). Un certain nombre d?articles obtenus par traduction automatique sont en effet mis à votre disposition en complément des articles traduits en langue française par des traducteurs professionnels. Cela vous permet d?avoir accès, dans votre propre langue, à l?ensemble des articles de la base de connaissances rédigés originellement en langue anglaise. Les articles traduits automatiquement ne sont pas toujours parfaits et peuvent comporter des erreurs de vocabulaire, de syntaxe ou de grammaire (probablement semblables aux erreurs que ferait une personne étrangère s?exprimant dans votre langue !). Néanmoins, mis à part ces imperfections, ces articles devraient suffire à vous orienter et à vous aider à résoudre votre problème. Microsoft s?efforce aussi continuellement de faire évoluer son système de traduction automatique.
La version anglaise de cet article est la suivante: 955998
L'INFORMATION CONTENUE DANS CE DOCUMENT EST FOURNIE PAR MICROSOFT SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. L'UTILISATEUR ASSUME LE RISQUE DE L'UTILISATION DU CONTENU DE CE DOCUMENT. CE DOCUMENT NE PEUT ETRE REVENDU OU CEDE EN ECHANGE D'UN QUELCONQUE PROFIT.

Envoyer des commentaires

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com