Informazioni su Network Monitor 3.2 in Windows Vista

Traduzione articoli Traduzione articoli
Identificativo articolo: 955998 - Visualizza i prodotti a cui si riferisce l?articolo.
Espandi tutto | Chiudi tutto

INTRODUZIONE

Questo articolo contiene informazioni su Microsoft Network Monitor 3.2. Network Monitor 3.2 Ŕ un analizzatore di protocollo che consente di acquisire, visualizzare e analizzare i dati di rete. Consente di risolvere eventuali problemi con le applicazioni sulla rete.

In questo articolo contiene il download e informazioni di supporto, note sull'installazione e informazioni di utilizzo generale di Network Monitor 3.2.

Informazioni

╚ di Network Monitor 3.2 l'ultima versione di Network Monitor. L'elenco seguente contiene informazioni sulle funzionalitÓ nuova in Network Monitor 3.2:
  • Processo di rilevamento. ╚ possibile visualizzare il nome di processo e il PID di tutti i processi che generano traffico di rete in un computer. Inoltre, Ŕ possibile utilizzare la struttura di conversazione per visualizzare i frame che sono associati a ciascun processo.
  • Consente di trovare le conversazioni. ╚ possibile isolare rapidamente frame di rete stessa conversazione. Questo include flussi TCP, flussi HTTP e altri tipi di traffico di rete.
  • Supporto del file di acquisizione PCAP.

    Nota

    Rete Monitor 3.2 include software sviluppato da seguenti entitÓ:
    • University of California, Berkeley e dai suoi collaboratori
    • Kungliga Tekniska Hogskolan e relativi collaboratori
    • Yen yen LIM e Cleveland Dakota del Nord
  • Il motore di acquisizione Ŕ stato riorganizzato per migliorare la velocitÓ di acquisizione per reti ad alta velocitÓ. Network Monitor rilasci 3.2 frame in modo significativo un numero inferiore rispetto a Network Monitor 3.1.
    • Insieme di parser completo. Network Monitor 3.2 ora supporta il parser per i protocolli pi¨ di 300. Questo include i protocolli che sono trattati da specifiche Windows Open Protocol dei. Per ulteriori informazioni, visitare il sito di Web di Microsoft:
      http://msdn.microsoft.com/en-us/library/cc216517.aspx
    • API di Monitor di rete. ╚ possibile creare proprie applicazioni di acquisizione, analizzare e analizzare il traffico di rete.
    • Migliore gestione del parser. Per impostazione predefinita, viene caricato solo un sottoinsieme di parser. ╚ possibile caricare il parser completo impostato modificando l'ordine di ricerca parser. A tal fine sotto l'elemento parser dal menu Opzioni .
    • Supporto per il troncamento del frame. ╚ possibile limitare il numero di byte acquisiti per frame per migliorare le prestazioni. A tal fine la voce Opzioni dal menu Strumenti .
    • Documentazione pi¨ ampia del NPL. Questa documentazione include documentazione su NMAPI il nuovo. Puoi accedere a questa documentazione dall'elemento documentazione di API e NPL dal menu ? .
    • Migliorato filtro elementi all'interno di NPL mentre cicli o le matrici. ╚ possibile specificare un indice nella matrice o in while ciclo che si desidera filtrare.
    • DisponibilitÓ di una versione IA-64.
    • ContainsBin plug-in. ╚ possibile cercare i frame di sequenze di byte arbitrarie o di stringhe. Ad esempio, Ŕ possibile cercare "msn" utilizzando la seguente query:
      ContainsBin (FrameData, ASCII, ? msn ?)
    • Pi¨ indicatori di interfaccia utente. Nuovi indicatori includono lo stato della conversazione, fotogrammi non elaborati e il numero di frame nel buffer di acquisizione.

Download e informazioni di supporto

Per scaricare 3.2 di Monitor di rete, il seguente sito Microsoft Web:
https://connect.microsoft.com/site/sitehome.aspx?SiteID=216
Nota Questo sito include Network Monitor 3.2 Download per le versioni di Windows Vista x 86 - versioni, per Windows Vista x 64 - base e per le versioni di Windows Vista IA - 64 - base.

Per informazioni di supporto su Network Monitor 3.2, visitare il sito di Web di Microsoft:
http://connect.microsoft.com
╚ necessario accedere al sito Web utilizzando un Windows Live ID. Dopo avere effettuato, Ŕ possibile applicare a partecipare al programma. Per effettuare questa operazione, fare clic su Applica accanto a Monitor di rete 3 nella colonna Opzioni della tabella. Una volta registrare nel programma, Ŕ possibile accedere a newsgroup ed Ŕ possibile inviare report sui bug.

Note sull'installazione

Network Monitor 3.2 pu˛ coesistere con Network Monitor 2. x e versioni precedenti. Per impostazione predefinita, Network Monitor 3.2 viene installato nella cartella % Program Files%\Microsoft Monitor di rete 3. Di conseguenza, i conflitti non si verificano se Ŕ installata una versione precedente in una cartella diversa sul computer. Quando si installa 3.2 di Network Monitor, disinstallazione in versioni precedenti di Monitor di rete 3.

Rete 3.2 Monitor include un driver per computer basati su Windows Vista. Questo driver supporta nuove caratteristiche del NDIS Network Driver Interface Specification () 6.0 driver. Se si utilizzano strumenti che si basano su Network Monitor 2. x NPPTools, questi strumenti non funzioneranno pi¨. Per acquisire i dati di rete in Windows Vista, Ŕ necessario utilizzare Network Monitor 3.2. Network Monitor 2. x non acquisisce i dati di rete correttamente in Windows Vista.

I requisiti di hardware per Network Monitor 3.2 sono il:
  • processore 1 gigahertz (GHz) o superiore
  • 1 gigabyte (GB) o pi¨ di memoria
  • 25 megabyte (MB) di spazio libero sul disco rigido e lo spazio sul disco rigido memorizzare i file di acquisizione
3.2 Di Network Monitor Ŕ supportato sui seguenti sistemi operativi:
  • Windows Vista
  • Windows Server 2008
  • Windows XP
  • Windows Server 2003
Avvisi e avvisi

Attualmente, non Ŕ consigliabile eseguire Monitor di rete 3 nei sistemi di produzione. In scenari in cui il carico Ŕ importante, utilizzare la seguente versione della riga di comando di Monitor di rete 3 per l'acquisizione di dati di rete:
nmcap.exe
Per ulteriori informazioni su Nmcap.exe, vedere la sezione di "Nmcap.exe lo strumento della riga di comando".

Network Monitor 3.2 potrebbe utilizzare grandi quantitÓ di risorse di sistema. Di seguito sono alcune importanti considerazioni.
  • spazio su disco

    Quando si avvia una sessione di acquisizione, Network Monitor 3 memorizza frame in una sequenza di file di acquisizione che si trovano nel TEMP cartella. Per impostazione predefinita, la dimensione di ogni file di acquisizione Ŕ di 20 MB. Se non si interrompe la sessione di acquisizione, Network Monitor 3 continua a memorizzare i file di acquisizione nella cartella Temp, fino a quando non lo spazio libero sul disco rigido del computer Ŕ inferiore a % 2. Quindi, in Monitor di rete 3 si interrompe la sessione di acquisizione.

    ╚ possibile configurare le dimensioni del file di acquisizione, la posizione in cui l'acquisizione di file vengono memorizzati, il limite di spazio su spazio libero sul disco rigido e altre opzioni di acquisizione. Per effettuare questa operazione, scegliere Opzioni dal menu Strumenti e scegliere la scheda di acquisizione .
  • Utilizzo memoria

    Oltre a catturare i dati, Monitor di rete 3 assegna proprietÓ frame e quindi utilizza le proprietÓ per raggruppare i frame in conversazioni. Network Monitor 3 Visualizza le conversazioni e le cornici associate in una struttura nella finestra di sessioni di rete.

    La FunzionalitÓ di conversazioni in Monitor di rete 3 aumenta notevolmente utilizzo della memoria. Questo pu˛ causare il computer smettere di rispondere. Per impostazione predefinita, la funzionalitÓ di sessioni Ŕ disattivata. Alcuni filtri del protocollo di livello superiore richiedono proprietÓ di conversazione. Per attivare la funzionalitÓ di conversazioni, scegliere la scheda di Pagina iniziale , quindi selezionare la casella di controllo Abilita sessioni .
  • utilizzo del processore

    La funzionalitÓ di sessioni di Monitor di rete 3 potrebbe aumentare notevolmente l'utilizzo del processore quando vengono elaborate grandi quantitÓ di frame. Per impostazione predefinita, la funzionalitÓ di sessioni Ŕ disattivata.

Utilizzo generale

Informazioni sull'utilizzo generale di Monitor di rete 3 includono i seguenti.
  • acquisire i dati di rete

    Se si desidera che per ridurre al minimo l'effetto sulle risorse di sistema quando si utilizza Monitor di rete 3 per acquisire i dati, utilizzare il Nmcap.exe strumento della riga di comando per acquisire i dati.

    Network Monitor 3 consente Ŕ raccogliere i dati di rete e di visualizzare questo dati in tempo reale come viene acquisito. Per avviare una sessione di acquisizione in Monitor di rete 3, fare clic su Pagina iniziale , fare clic su Crea una nuova acquisizione , quindi fare clic su Avvia acquisizione o premere F5.
  • filtri

    Network Monitor 3 utilizza una sintassi semplice basato sull'espressione per il frame di filtro. L'utente vengono visualizzati tutti i frame che corrispondono all'espressione scelto. Per ulteriori informazioni sui filtri, eseguire una delle seguenti operazioni:
    • Visualizzare gli argomenti nella sezione "Utilizzo di filtri" del manuale dell'utente di Network Monitor 3. Per effettuare questa operazione, fare clic su Sommario dal menu ? e quindi fare doppio clic su Utilizzo di filtri .
    • Dal menu ? , per procedure , quindi Utilizzare filtri .
    • Per visualizzare i filtri standard, fare clic sul acquisizione filtro scheda Filtro di visualizzazione o.
  • conversazioni

    Per impostazione predefinita, la funzionalitÓ di conversazione Ŕ attivata. Questa impostazione pu˛ utilizzare grandi quantitÓ di memoria, soprattutto in scenari in cui l'acquisizione di grandi quantitÓ di dati o in cui acquisizione di dati su lunghi periodi. Vedere la sezione "NMCap" per informazioni sull'acquisizione dei dati su lunghi periodi.

    Le conversazioni di attivare il raggruppamento e la visualizzazione dei frame nella finestra di sessioni di rete di una struttura ad albero in base per le conversazioni a cui appartengono. TCP, ad esempio, i dati che utilizza la stessa porta di origine e la stessa porta di destinazione sono organizzati in un gruppo. Quando si sceglie un nodo nella finestra sessioni di rete, il corrispondente filtro conversazione viene applicato automaticamente a frame nella finestra Riepilogo Frame. Vengono visualizzati solo i frame che appartengono a quella particolare conversazione.
  • strumento della riga di comando Nmcap.exe

    Lo strumento della riga di comando Nmcap.exe consente di configurare l'inizio e di interrompere gli orari per una sessione di acquisizione. ╚ inoltre possibile utilizzare questo strumento della riga di comando per acquisizioni concatenate creati. Acquisizioni concatenate consentono di creare pi¨ file di acquisizione, mentre ridurre le dimensioni di ogni file di acquisizione.
  • analisi di rete (NPL) della lingua

    Parser 3 di Monitor di rete sono scritti in un linguaggio che Ŕ progettato specificamente per rendere pi¨ semplice lo sviluppo di parser. Questo fornisce anche di un livello di protezione contro potenziali attacchi da codice dannoso che potrebbe verificarsi se parser sono stati creati come file DLL. ╚ possibile visualizzare o modificare i parser presenti in Monitor di rete 3. La documentazione per il linguaggio NPL accessibili sulla Guida in linea dal menu.
  • NMAPI

    NMAPI consente di accedere a livello di codice il motore di analisi e acquisizione di Network Monitor 3.2. Vedere il menu della Guida per il collegamento alla documentazione dell'API.

Problemi comuni

Problemi comuni di Network Monitor 3.2 includono:
  • Protocolli non analizzano correttamente. Questo problema pu˛ verificarsi se si verifica una delle seguenti condizioni:
    • La funzionalitÓ di sessioni Ŕ disattivata.

      Alcuni protocolli dipendono dalla proprietÓ di conversazione per memorizzare valori di stato che potrebbero essere necessari in frame successivi. Ad esempio, TCP richiede le conversazioni per memorizzare informazioni sui frame ritrasmessi. Il filtro per TCP ritrasmetterÓ non funzionerÓ a meno che non la funzionalitÓ di sessioni sia attivata.

      Analogamente, il protocollo Server Message Block (SMB) Impossibile convertire la risposta a un comando di Transact-SQL , perchÚ la risposta non contiene il comando originale. Il comando originale viene salvato nella proprietÓ di conversazione.
    • Non Ŕ necessario che il parser completo impostare caricato. La configurazione di parser predefinita per Network Monitor 3.2 Ŕ un sottoinsieme dell'insieme completo. Questo comportamento consente di eseguire pi¨ rapidamente di Network Monitor 3.2. Se si desidera caricare l'insieme completo, vedere ? How Do i parser completi I?Load ?? dal menu ? .
  • Quando si esegue Monitor di rete 3 in un computer basato su Windows Vista, viene visualizzato uno dei seguenti messaggi di errore:
    Nessuna delle schede di rete sono associata a Netmon il driver
    Questo adattatore di rete non Ŕ configurato per acquisire con Network Monitor
    Questo problema si verifica se si verifica una delle seguenti condizioni:
    • Non si esegue Monitor di rete 3 come amministratore.
    • Non si Ŕ un membro degli utenti Netmon gruppo.
    Per ulteriori informazioni, vedere Monitor di rete 3 rilascia note oppure vedere l'argomento "Operative su Windows Vista" relativo a di Monitor di rete 3 della Guida dal menu.

Riferimenti

Per informazioni di supporto su Monitor di rete 3, visitare i seguenti siti Web Microsoft:
http://connect.microsoft.com
http://blogs.technet.com/netmon

ProprietÓ

Identificativo articolo: 955998 - Ultima modifica: mercoledý 24 settembre 2008 - Revisione: 2.3
Le informazioni in questo articolo si applicano a:
  • Windows Vista Ultimate
  • Windows Vista Enterprise
  • Windows Vista Ultimate 64-bit edition
  • Windows Vista Enterprise 64-bit edition
Chiavi:á
kbmt kbhowto kbinfo kbexpertiseinter KB955998 KbMtit
Traduzione automatica articoli
Il presente articolo Ŕ stato tradotto tramite il software di traduzione automatica di Microsoft e non da una persona. Microsoft offre sia articoli tradotti da persone fisiche sia articoli tradotti automaticamente da un software, in modo da rendere disponibili tutti gli articoli presenti nella nostra Knowledge Base nella lingua madre dell?utente. Tuttavia, un articolo tradotto in modo automatico non Ŕ sempre perfetto. Potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli, pi¨ o meno allo stesso modo di come una persona straniera potrebbe commettere degli errori parlando una lingua che non Ŕ la sua. Microsoft non Ŕ responsabile di alcuna imprecisione, errore o danno cagionato da qualsiasi traduzione non corretta dei contenuti o dell?utilizzo degli stessi fatto dai propri clienti. Microsoft, inoltre, aggiorna frequentemente il software di traduzione automatica.
Clicca qui per visualizzare la versione originale in inglese dell?articolo: 955998
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com