Informações sobre o Monitor de rede 3.2 no Windows Vista

Traduções deste artigo Traduções deste artigo
ID do artigo: 955998 - Exibir os produtos aos quais esse artigo se aplica.
Expandir tudo | Recolher tudo

INTRODUÇÃO

Este artigo contém informações sobre o Microsoft Network Monitor 3.2. O Monitor de rede 3.2 é um analisador de protocolo que permite capturar, exibir e analisar dados de rede. Você pode usá-lo para ajudar a solucionar problemas com aplicativos na rede.

Este artigo contém download e informações de suporte, notas de instalação e informações de uso geral sobre 3.2 do Monitor de rede.

Mais Informações

3.2 O Monitor de rede é a versão mais recente do Network Monitor. A lista a seguir contém informações sobre os novos recursos do 3.2 do Monitor de rede:
  • Controle de processos. Você pode exibir o nome do processo e a identificação de todos os processos que geram tráfego de rede em um computador. Além disso, você pode usar a árvore de conversação para exibir os quadros que estão associados com cada processo.
  • Encontre as conversações. Você pode rapidamente isolar os quadros na mesma rede conversa. Isso inclui fluxos de TCP, fluxos HTTP e outros tipos de tráfego de rede.
  • Suporte de arquivo de captura PCAP.

    Observação

    Rede Monitor 3.2 inclui software desenvolvido pelas seguintes entidades:
    • The University of California, Berkeley e seus colaboradores
    • Kungliga Tekniska Hogskolan e seus colaboradores
    • YEN iene LIM e State University Dakota do Norte
  • O mecanismo de captura foi redefinido para melhorar a taxa de captura para redes de alta velocidade. Monitor de rede posicionamentos 3.2 significativamente menos quadros que 3.1 do Monitor de rede.
    • Conjunto de analisador abrangentes. O Monitor de rede 3.2 agora oferece suporte a analisadores para protocolos mais de 300. Isso inclui os protocolos que são abordados pela especificações de protocolo abrir do Windows. Para obter mais informações, visite o seguinte site:
      http://msdn.microsoft.com/en-us/library/cc216517.aspx
    • API de Monitor de rede. Você pode criar seus próprios aplicativos que capturar, analisar e analisam o tráfego de rede.
    • Melhor gerenciamento de analisador. Por padrão, apenas um subconjunto de analisadores é carregado. Você pode carregar o analisador completo definir alterando a ordem de pesquisa do analisador. Você pode fazer isso no item Parser no menu Opções .
    • Suporte para truncamento de quadro. Você pode limitar o número de bytes capturados por quadro para melhorar o desempenho. Você pode fazer isso no item de Opções no menu Ferramentas .
    • Documentação mais abrangente do NPL. Esta documentação inclui documentação sobre o novo NMAPI. Você pode acessar esta documentação do item NPL e documentação da API no menu Ajuda .
    • Aprimorado filtrando itens em NPL ao loops ou matrizes. Você pode especificar um índice na matriz ou o tempo loop que você deseja filtrar.
    • Disponibilidade de uma versão IA-64.
    • ContainsBin plug-in. Você pode pesquisar quadros para seqüências de bytes arbitrário ou seqüências de caracteres. Por exemplo, você pode procurar por "msn" usando a seguinte consulta:
      ContainsBin (FrameData, ASCII, ? msn ?)
    • Indicadores de interface do usuário mais. Novos indicadores incluem o status de conversação, quadros ignorados e o número de quadros no buffer de captura.

Download e informações de suporte

Para baixar 3.2 do Monitor de rede, visite o seguinte site da Microsoft:
https://connect.microsoft.com/site/sitehome.aspx?SiteID=216
Observação Este site inclui downloads 3.2 do Monitor de rede para versões com base no Windows Vista x 86 - versões com base, para o Windows Vista x 64 - e para versões do Windows Vista IA - 64 - com base.

Para informações de suporte sobre 3.2 do Monitor de rede, visite o seguinte site:
http://connect.microsoft.com
Você deve entrar a este site usando um Windows Live ID. Depois de entrar, você pode aplicar a participar do programa. Para fazer isso, clique em Aplicar ao lado para o Monitor de rede 3 na coluna Opções da tabela. Depois que você se inscrever no programa, você tem acesso a grupos de notícias e você pode enviar relatórios de erro.

Notas de instalação

O Monitor de rede 3.2 pode coexistir com o Monitor de rede 2. x e versões anteriores. Por padrão, 3.2 do Monitor de rede é instalado na pasta % Program Files%\Microsoft Network Monitor 3. Portanto, está em conflito não ocorrem se uma versão anterior instalada em uma pasta diferente no computador. Quando você instala 3.2 do Monitor de rede, versões anteriores do Monitor de rede 3 são desinstaladas.

Rede Monitor 3.2 inclui um driver para computadores baseados no Windows Vista. Este driver aceita novos recursos da rede driver NDIS especificação da interface () 6.0 driver. Se você estiver usando ferramentas que dependem de Monitor de rede 2. x NPPTools, essas ferramentas não funcionará mais. Para capturar dados de rede no Windows Vista, você deve usar 3.2 do Monitor de rede. 2 De Monitor de rede. x não captura dados da rede corretamente no Windows Vista.

A seguir está os requisitos hardware sugerida para 3.2 do Monitor de rede:
  • processador de 1 gigahertz (GHz) ou mais rápido
  • 1 gigabyte (GB) ou mais de memória
  • 25 megabytes (MB) de espaço livre no disco rígido e espaço em disco rígido adicional para armazenar arquivos de captura
O Monitor de rede 3.2 é suportado nos seguintes sistemas operacionais:
  • Windows Vista
  • Windows Server 2008
  • Windows XP
  • Windows Server 2003
Avisos e cuidados

Atualmente, não recomendamos que você execute o Monitor de rede 3 em sistemas de produção. Em cenários onde a carga é importante, usar a versão seguinte linha de comando do Monitor de rede 3 para capturar dados de rede:
nmcap.exe
Para obter mais informações sobre Nmcap.exe, consulte a seção "Ferramenta de linha de comando Nmcap.exe".

O Monitor de rede 3.2 pode consumir muitos recursos do sistema. A seguir estão algumas considerações importantes.
  • espaço em disco

    Quando você iniciar uma sessão de captura, Monitor de rede 3 armazena quadros em uma seqüência de arquivos de captura que estão no Temp pasta. Por padrão, o tamanho de cada arquivo de captura é 20 MB. Se você não interromper a sessão de captura, Monitor de rede 3 continuará a armazenar arquivos de captura na pasta Temp até que o espaço livre no disco rígido no computador ficar abaixo de 2 por cento. Em seguida, o Monitor de rede 3 interrompe a sessão captura.

    Você pode configurar o tamanho de arquivo de captura, o local em que a captura de arquivos são armazenados, o limite de espaço livre no disco rígido e outros capturar opções. Para fazer isso, aponte para Opções no menu Ferramentas e, em seguida, clique na guia captura .
  • use memória

    Além capturar dados, Monitor de rede 3 atribui propriedades para quadros e usa essas propriedades para agrupar os quadros em conversações. O Monitor de rede 3 exibe as conversas e os quadros associados em uma estrutura de árvore na janela rede conversas.

    O Recurso de conversas no Monitor de rede 3 aumenta significativamente o uso de memória. Isso pode fazer com que o computador pare de responder. Por padrão, o recurso de conversas é desativado. Alguns filtros de protocolo de nível mais alto exigem propriedades de conversação. Para habilitar o recurso de conversas, clique na guia Página inicial e clique para selecionar a caixa de seleção Ativar conversas .
  • utilização do processador

    O recurso de conversas do Monitor de rede 3 pode aumentar significativamente a utilização do processador quando vários quadros são processados. Por padrão, o recurso de conversas é desativado.

Uso geral

Informações de uso geral de Monitor de rede 3 incluem o seguinte.
  • capturar dados de rede

    Se você desejar minimizar o efeito nos recursos do sistema ao usar o Monitor de rede 3 para capturar dados, use o Nmcap.exe ferramenta de linha de comando para capturar dados.

    Rede 3 Monitor permite que você coleta dados de rede e exibir esse dados em tempo real como ela é capturada. Para iniciar uma sessão de captura no Monitor de rede 3, clique em Página inicial , clique em criar uma nova captura e clique em Iniciar captura ou pressione F5.
  • filtros

    O Monitor de rede 3 usa uma sintaxe simples que é baseada em expressões para quadros de filtro. Todos os quadros que correspondem à expressão escolhida são exibidos para o usuário. Para obter mais informações sobre filtros, siga um destes procedimentos:
    • Exiba os tópicos na seção "Usando filtros" do guia do usuário do Network Monitor 3. Para fazer isso, clique em conteúdo no menu Ajuda e, em seguida, clique duas vezes Usando filtros .
    • No menu Ajuda , aponte para como fazer e, em seguida, clique em Usar filtros .
    • Para exibir filtros padrão, clique no captura filtro guia ou na guia Filtro de exibição .
  • conversações

    Por padrão, o recurso de conversação está ativado. Essa configuração pode consumir muita memória, especialmente em situações onde você capturar grandes quantidades de dados ou onde capturar dados por longos períodos. Consulte a seção "NMCap" para obter informações sobre como capturar dados por longos períodos.

    Conversações permitem o agrupamento e exibição de quadros na janela conversas de rede em uma estrutura de árvore de acordo com para as conversas às quais eles pertencem. Por exemplo, TCP os dados que usa a mesma porta de origem e a mesma porta de destino são organizados em um grupo. Quando você clica em um nó na janela conversas de rede, o filtro de conversação correspondente será automaticamente aplicado aos quadros na janela de resumo do quadro. São exibidos somente os quadros que pertencem a essa conversa em particular.
  • ferramenta de linha de comando Nmcap.exe

    A ferramenta de linha de comando Nmcap.exe permite que você configurar o início e parar tempos para uma sessão de captura. Você também pode usar essa ferramenta de linha de comando para capturas encadeadas criadas. Capturas encadeadas permitem que você criar vários arquivos de captura enquanto você manter pequeno o tamanho de cada arquivo de captura.
  • idioma (NPL) de análise de rede

    Analisadores de 3 de Monitor de rede são escritos em um idioma que foi criado especificamente para tornar o desenvolvimento de analisador mais simples. Isso também fornece um nível de proteção contra a exploração potencial de códigos mal-intencionados que podem ocorrer se os analisadores foram criados como arquivos DLL. Você pode exibir ou modificar os analisadores que estão incluídos no Monitor de rede 3. Documentação para o idioma NPL pode ser acessada na Ajuda do menu.
  • NMAPI

    NMAPI permite que você acessar programaticamente o mecanismo de análise e captura do Network Monitor 3.2. Ver o menu Ajuda para um link para a documentação da API.

Problemas comuns

Problemas de 3.2 do Monitor de rede comuns incluem o seguinte:
  • Protocolos não analisar corretamente. Esse problema pode ocorrer se qualquer uma das seguintes condições for verdadeira:
    • O recurso de conversas é desativado.

      Determinados protocolos dependem das propriedades de conversação para armazenar valores de estado que podem ser necessárias em quadros posteriores. Por exemplo, TCP exige as conversações para armazenar informações sobre quadros retransmitidas. O filtro para o TCP retransmite não funcionará a menos que o recurso de conversas esteja habilitado.

      Da mesma forma, o protocolo SMB (Server Message Block) não pode converter a resposta para um comando Transact , porque a resposta não contém o comando original. O comando original é salvo em Propriedades de conversação.
    • Você não tem o analisador completo definido carregado. A configuração padrão analisador 3.2 do Monitor de rede é um subconjunto do conjunto completo. Este comportamento permite 3.2 do Monitor de rede executar mais rapidamente. Se você deseja carregar o conjunto completo, consulte o tópico ? como? I?Load completos analisadores ? no menu Ajuda .
  • Você recebe uma das seguintes mensagens de erro ao executar o Monitor de rede 3 em um computador baseado no Windows Vista:
    Nenhum dos adaptadores de rede são vinculados ao Netmon driver
    Este adaptador de rede não está configurado para capturar com o Monitor de rede
    Esse problema ocorre se uma das seguintes condições for verdadeira:
    • Você não estiver executando o Monitor de rede 3 como um administrador.
    • Você não for um membro de usuários Netmon grupo.
    Para obter mais informações, consulte o Monitor de rede 3 libera anotações ou consulte o tópico "Operacional no Windows Vista" no Monitor de rede 3 Ajuda menu.

Referências

Para informações de suporte sobre o Monitor de rede 3, visite os seguintes sites:
http://connect.microsoft.com
http://blogs.technet.com/netmon

Propriedades

ID do artigo: 955998 - Última revisão: quarta-feira, 24 de setembro de 2008 - Revisão: 2.3
A informação contida neste artigo aplica-se a:
  • Windows Vista Ultimate
  • Windows Vista Enterprise
  • Windows Vista Ultimate 64-bit edition
  • Windows Vista Enterprise 64-bit edition
Palavras-chave: 
kbmt kbhowto kbinfo kbexpertiseinter KB955998 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 955998

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com