Artikel-ID: 956197 - Geändert am: Mittwoch, 18. März 2009 - Version: 4.2

Einige Websites werden in Windows Internet Explorer 8 möglicherweise nicht richtig angezeigt oder funktionieren nicht korrekt.

Interaktiver Begleiter zur Behandlung von Problemen mit Websites, die nicht richtig angezeigt werden oder nicht korrekt funktionieren
Dieser Knowledge Base-Artikel ist für fortgeschrittene Benutzer, Supportmitarbeiter, Netzwerkadministratoren, Entwickler von Webinhalten und Websiteadministratoren bestimmt.

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Hinweise zur Selbsthilfe für Einsteiger und leicht fortgeschrittene Computerbenutzer finden Sie auf der folgenden Microsoft-Website:
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Problembeschreibung

Einige Websites werden in Windows Internet Explorer 8 möglicherweise nicht richtig angezeigt oder funktionieren nicht korrekt. Das Problem tritt in früheren Versionen von Internet Explorer nicht auf, und die betroffenen Websites werden in Windows Internet Explorer 7 weiterhin richtig angezeigt und funktionieren fehlerfrei.

In Internet Explorer 8 treten möglicherweise die folgenden Symptome auf:
  • Menüs, Bilder oder Text werden auf einigen Websites an der falschen Stelle angezeigt.
  • Einige Websitefeatures funktionieren nicht.
  • Auf manchen Websites werden Skriptfehlermeldungen angezeigt.
  • Auf manchen Websites reagiert Internet Explorer nicht mehr oder stürzt ab.

Ursache

Einige Websites wurden für ältere Browser entwickelt. Solange diese Websites nicht für Internet Explorer 8 aktualisiert wurden, können Kompatibilitätsprobleme auftreten.

Abhilfe

Internet Explorer 8 enthält ein Kompatibilitätsansichtfeature, mit dem die Darstellung von Websites, die für ältere Browser entwickelt wurden, dem eigentlichen Design entspricht. Sie können die Kompatibilitätsansicht in Internet Explorer oder auf dem Webserver aktivieren.
  • Aktivieren der Kompatibilitätsansicht für einen einzelnen Computer. Dazu verwenden Sie Methode 1 für jede Website, die nicht richtig angezeigt wird oder nicht korrekt funktioniert. Tritt das Problem auf vielen Websites auf, die Sie häufig aufrufen, aktivieren Sie die Kompatibilitätsansicht für alle Websites mithilfe von Methode 2. Diese Methoden sind für Benutzer bestimmt, die Internet Explorer ausführen.
  • Aktivieren der Kompatibilitätsansicht in Internet Explorer für mehrere Computer in einer Unternehmensumgebung. Hierzu führen Sie Methode 3 aus. Diese Methode ist für Administratoren von Unternehmensnetzwerken bestimmt.

Aktivieren der Kompatibilitätsansicht in Internet Explorer

Methode 1: Aktivieren der Kompatibilitätsansicht für bestimmte Websites unter Verwendung von Internet Explorer

Um die Kompatibilitätsansicht für bestimmte Websites, die nicht richtig angezeigt werden oder die nicht korrekt funktionieren, zu aktivieren, führen Sie die folgenden Schritte aus:
  1. Öffnen Sie eine Website, die nicht richtig angezeigt wird oder nicht korrekt funktioniert, in Internet Explorer 8.
  2. Klicken Sie auf das Symbol Kompatibilitätsansicht, das sich direkt rechts neben der Adressleiste befindet.

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    Oder klicken Sie im Menü Extras auf Kompatibilitätsansicht.

    Hinweis Wenn das Symbol Kompatibilitätsansicht nicht rechts neben der Adressleiste angezeigt wird, oder wenn der Befehl nicht im Menü Extras verfügbar ist, können Sie diese Methode nicht verwenden. Möglicherweise liegt eine andere Ursache vor, oder der Netzwerkadministrator hat die Einstellungen der Kompatibilitätsansicht auf dem Computer unter Verwendung einer Gruppenrichtlinieneinstellung konfiguriert. Die Kompatibilitätsansicht ist nicht erforderlich, und die Befehle für die Kompatibilitätsansicht sind nicht verfügbar, wenn die Website für frühere Versionen von Internet Explorer entwickelt wurde.
Wenn diese Methode funktioniert hat, die Website jetzt richtig angezeigt wird und korrekt funktioniert, sind Sie fertig. Sie müssen die Methode jedoch möglicherweise für jede einzelne Website anwenden, bei der diese Probleme auftreten.

Hinweis Wenn Sie diese Methode zum Beheben von Problemen mit einer Website verwenden, speichert Internet Explorer die Einstellung der Kompatibilitätsansicht für die entsprechende Website. Jedes Mal, wenn Sie die Website aufrufen, wird diese in der Kompatibilitätsansicht angezeigt. Wenn Sie die Kompatibilitätsansicht für eine Website wieder deaktivieren möchten, führen Sie die Methode noch einmal aus, d. h., klicken Sie für die entsprechende Website erneut auf das Symbol Kompatibilitätsansicht. Sie können auch bestimmte Websites zu einer Kompatibilitätsansichtliste hinzufügen oder daraus löschen, ohne jede einzelne Website aufzurufen. Klicken Sie hierzu auf Extras und dann auf Einstellungen der Kompatibilitätsansicht.

Wenn diese Methode nicht erfolgreich war und die Website immer noch nicht richtig angezeigt wird oder immer noch nicht funktioniert, liegt ein anderes Problem vor. Im Abschnitt "Ähnliche Probleme und Lösungen oder den Support kontaktieren" finden Sie alternative Schritte.

Methode 2: Aktivieren der Kompatibilitätsansicht für alle Websites unter Verwendung von Internet Explorer

Die meisten Websites, die Sie häufig aufrufen, werden nicht richtig angezeigt oder funktionieren nicht korrekt. Sie haben Methode 1 auf einigen der Websites ausprobiert, und die Methode hat funktioniert. Vielleicht möchten Sie die Kompatibilitätsansicht für alle Websites aktivieren. Gehen Sie hierzu folgendermaßen vor:
  1. Starten Sie Internet Explorer 8.
  2. Klicken Sie im Menü Extras auf Einstellungen der Kompatibilitätsansicht.

    Wenn die Option Einstellungen der Kompatibilitätsansicht nicht angezeigt wird, hat der Netzwerkadministrator die Optionen möglicherweise mithilfe einer Gruppenrichtlinieneinstellung konfiguriert. Wenden Sie sich an Ihren Administrator oder das Helpdesk.
  3. Aktivieren Sie das Kontrollkästchen Alle Websites in Kompatibilitätsansicht anzeigen, und klicken Sie auf Schließen.
Rufen Sie verschiedene Websites auf, die zuvor nicht richtig angezeigt wurden oder nicht korrekt funktioniert haben, um zu prüfen, ob das Problem jetzt behoben ist.

Wenn diese Methode funktioniert hat, alle Websites jetzt richtig angezeigt werden und korrekt funktionieren, sind Sie fertig.

War die Methode nicht erfolgreich, d. h., werden einige oder alle Websites immer noch nicht richtig angezeigt oder funktionieren immer noch nicht korrekt, liegt ein anderes Problem vor. Im Abschnitt "Ähnliche Probleme und Lösungen oder den Support kontaktieren" finden Sie alternative Schritte.

Aktivieren der Kompatibilitätsansicht in Internet Explorer für mehrere Computer

Methode 3: Festlegen der Optionen für die Kompatibilitätsansicht für mehrere Computer in einer Unternehmensumgebung unter Verwendung von Gruppenrichtlinieneinstellungen

Um die Kompatibilitätsansicht für mehrere Computer in einer Unternehmensumgebung zu aktivieren, können Administratoren die folgenden neuen Kompatibilitätsansicht-Gruppenrichtlinieneinstellungen verwenden, die für Internet Explorer 8 verfügbar sind:
  • Internet Explorer 7-Standards-Modus aktivieren: Diese Einstellung aktiviert die Kompatibilitätsansicht für alle Websites und hindert Benutzer daran, die Kompatibilitätsansicht für einzelne Websites zu aktivieren oder zu deaktivieren.
  • Kompatibilitätsansicht deaktivieren: Diese Einstellung deaktiviert die Kompatibilitätsansicht für alle Websites und hindert Benutzer daran, die Kompatibilitätsansicht für einzelne Websites zu aktivieren oder zu deaktivieren.
  • Internet Explorer-Standards-Modus für lokales Intranet aktivieren: Diese Einstellung deaktiviert die Kompatibilitätsansicht (aktiviert den Standards-Modus) für alle Intranetwebsites.
  • Richtlinienliste von Internet Explorer 7-Sites verwenden: Mithilfe dieser Einstellung können Administratoren bestimmte Websites, die in der Kompatibilitätsansicht angezeigt werden müssen, zu einer Liste hinzufügen. Benutzer können weitere Websites zur Liste hinzufügen oder aus der Liste entfernen. Die vom Administrator festgelegten Websites können jedoch nicht entfernt werden.
  • Schaltfläche "Kompatibilitätsansicht" deaktivieren: Diese Einstellung verhindert, dass Benutzer die Schaltfläche Kompatibilitätsansicht zum Korrigieren von Websites verwenden. Diese Einstellung funktioniert in Windows Internet Explorer 8 Beta 2 nicht.
Diese Einstellungen sind sowohl für Benutzer als auch Computer an den folgenden Speicherorten für jede Website, Domäne und Organisationseinheit verfügbar:
Administrative Vorlagen/Windows-Komponenten//Internet Explorer/Kompatibilitätsansicht
Weitere Informationen zu diesen Gruppenrichtlinieneinstellungen finden Sie in den Erläuterungen in der Benutzeroberfläche des Snap-Ins "Gruppenrichtlinie".

Ähnliche Probleme und Lösungen oder den Support kontaktieren

Anweisungen für ähnliche Probleme und Lösungen für Einsteiger und leicht fortgeschrittene Computerbenutzer bietet der interaktive Begleiter.

Um sich an den Support für Internet Explorer 8 zu wenden, rufen Sie die folgende Website von Microsoft auf:
http://support.microsoft.com/oas/default.aspx?prid=12357 (http://support.microsoft.com/oas/default.aspx?prid=12357)
Weitere Informationen für fortgeschrittene Benutzer finden Sie in den folgenden Artikeln der Microsoft Knowledge Base:
949787  (http://support.microsoft.com/kb/949787/ ) Anmerkungen zu dieser Version und Supportoptionen für Internet Explorer 8 Beta 2 (englisch)
968499  (http://support.microsoft.com/kb/968499/ ) Erweiterte Lösungen: Einige Websites werden in Windows Internet Explorer 8 möglicherweise nicht richtig angezeigt oder funktionieren nicht korrekt. (englisch)

Die Informationen in diesem Artikel beziehen sich auf:
  • Windows Internet Explorer 8
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kbexpertisebeginner kbgraphxlink kbtshoot KB956197
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