ID do artigo: 956441 - Última revisão: quinta-feira, 4 de fevereiro de 2010 - Revisão: 2.0

CORRECÇÃO: O serviço de impressão do host pode exibir um status incorreto para sessões de impressão 3270 quando ele processa 3270 trabalhos de impressão para muitos 3270 sessões de impressão ao mesmo tempo

Download do hotfix está disponívelDownload do Hotfix Disponível
Visualizar e solicitar downloads de hotfix
Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.

Nesta página

Expandir tudo | Recolher tudo

Sintomas

O Microsoft Host Integration Server 2004 host imprimir Service (Snaprint.exe) pode exibir um status incorreto para 3270 sessões de impressão quando o serviço de impressão do host processa 3270 trabalhos de impressão para muitas sessões de impressão 3270 ao mesmo tempo. Isso provavelmente ocorre se o serviço host de impressão tenta imprimir em mais de 500 sessões de impressão ao mesmo tempo. O serviço de impressão do host também pode registrar a seguinte mensagem de erro no log de eventos do aplicativo:

IDENTIFICAÇÃO de evento: 12
Fonte: Servidor de impressão SNA
Tipo: erro
Descrição: O pool de buffer para mensagens tornam-se esgotou. Dados podem ser perdidos.

Observação:Esse problema também ocorre no Microsoft Host Integration Server 2006.

Causa

O serviço de impressão do host grava mensagens de status de sessão de impressão para uma fila interna. Essa fila interna pode armazenar até 4.000 mensagens de status. Se mais rápido do que as mensagens são processadas as mensagens de status da sessão de impressão são gravadas na fila, a fila pode alcançar o número máximo de entradas. Se isso ocorrer, o serviço de impressão do host irá descartar as mensagens de status adicionais e registrar um erro de evento ID 12.

Resolução

Informações sobre o Service pack para o Host Integration Server 2006

Para resolver esse problema, obtenha o service pack mais recente para o Host Integration Server 2006. Para obter mais informações, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
979497  (http://support.microsoft.com/kb/979497/ ) Como obter o service pack mais recente para o Host Integration Server 2006

Informações sobre hotfix

Um hotfix compatível foi disponibilizado pela Microsoft. No entanto, esse hotfix destina-se a corrigir o problema descrito neste artigo. Aplique-o somente aos sistemas que apresentarem esse problema específico. Este hotfix pode ser submetida a testes adicionais. Portanto, se esse problema não o prejudicar, recomendamos que você aguarde a próxima atualização de software que contém esse hotfix.

Se o hotfix está disponível para download, há uma seção "Download de Hotfix disponível" na parte superior deste artigo da Base de Conhecimento. Se esta seção não exibida, contate o suporte e atendimento ao cliente Microsoft para obter o hotfix.

Observação: Se ocorrem problemas adicionais ou se for necessária qualquer solução de problemas, talvez seja necessário criar uma solicitação de serviço separada. Os custos normais de suporte serão aplicados a questões de suporte adicionais e problemas que não se qualificam para esse hotfix específico. Para obter uma lista completa dos números de telefone de suporte e Atendimento Microsoft ou para criar uma solicitação de serviço separada, visite o seguinte site da Microsoft:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Observação: O formulário "Download de Hotfix disponível" exibe os idiomas para os quais o hotfix está disponível. Se você não vir seu idioma, é porque não há um hotfix disponível disponível para esse idioma.

Pré-requisitos

Você deve ter o Host Integration Server 2004 Service Pack 1 (SP1) instalado para aplicar esse hotfix.

Requisito de reinicialização

Não é necessário reiniciar o computador após aplicar esse hotfix.

Informações sobre a substituição do hotfix

Esse hotfix não substitui um hotfix lançado anteriormente.

Informações do arquivo

A versão em inglês deste hotfix apresenta os atributos de arquivo (ou atributos de arquivo posteriores) listados na tabela a seguir. As datas e horas desses arquivos são listadas em UTC (hora coordenada universal COORDENADO). Quando você exibe as informações do arquivo, ele é convertido em hora local. Para encontrar a diferença entre o UTC e a hora local, use a guia fuso horário no item Data e hora no painel de controle.
Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataforma
Snaprint.exe6.0.2429.070,65612 De agosto de 200802: 05x 86

Mais Informações

Após aplicar esse hotfix, o serviço de impressão do host pode fila até 10 mil mensagens de status para sessões ativas de impressão. A fila de mensagens de status de impressão sessão anteriormente foi aumentada de 1.000 a 4.000 entradas no Microsoft SNA Server 4.0 SP3. Para obter mais informações, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
225156  (http://support.microsoft.com/kb/225156/ ) O servidor de impressão mostra o status incorreto ao iniciar um grande número de impressoras simultaneamente

Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na seção "Aplica-se a".

A informação contida neste artigo aplica-se a:
  • Microsoft Host Integration Server 2006 Enterprise Edition
  • Microsoft Host Integration Server 2006
  • Microsoft Host Integration Server 2004 Service Pack 1 nas seguintes plataformas
    • Microsoft Host Integration Server 2004 Enterprise Edition
    • Microsoft Host Integration Server 2004 Standard Edition
Palavras-chave: 
kbmt kbautohotfix kbhotfixserver kbexpertiseadvanced kbqfe KB956441 KbMtpt
Tradução automáticaTradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 956441  (http://support.microsoft.com/kb/956441/en-us/ )