Codice errore 0x800B0100 quando si utilizza Windows Update o Microsoft Update per installare gli aggiornamenti

Traduzione articoli Traduzione articoli
Identificativo articolo: 956702 - Visualizza i prodotti a cui si riferisce l?articolo.
Espandi tutto | Chiudi tutto

In questa pagina

Sintomi

Quando si tenta di installare gli aggiornamenti dal sito Web Windows Update o Microsoft Update, è possibile che venga visualizzato il seguente messaggio di errore:
0x800B0100

Cause

Questo problema si verifica se i file .dll di sicurezza di Windows non sono registrati correttamente.

Risoluzione

Per risolvere il problema, utilizzare i seguenti metodi in base allo specifico sistema operativo Microsoft Windows
in uso.

Metodo per Windows 7, Windows Vista o Windows Server 2008

Per risolvere il problema, eseguire lo strumento System Update Readiness Tool (Checksur.exe). Per effettuare questa operazione, attenersi alla seguente procedura:
  1. Scaricare ed eseguire lo strumento System Update Readiness Tool. Questo strumento esegue una scansione singola per il rilevamento delle incoerenze che può prevenire future operazioni di manutenzione.
    Per ulteriori informazioni sul download e sull'esecuzione dello strumento Checksur.exe, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
    http://support.microsoft.com/kb/947821/it Descrizione dello strumento System Update Readiness Tool per Windows Vista
  2. Provare a installare nuovamente gli aggiornamenti.
Nota Dopo aver eseguito lo strumento, il file Checksur.log si trova nel seguente percorso: %systemroot%\Logs\CBS\

In un'installazione predefinita di Windows 7 e Windows Vista, questo file si trova nella seguente cartella:

C:\Windows\Logs\CBS

Metodo per Windows 2000, Windows XP o Windows Server 2003

Per consentire al supporto tecnico di risolvere il problema, andare alla sezione "Correzione automatica". Per risolvere il problema autonomamente, accedere alla sezione "Correzione manuale".

Correzione automatica



Per risolvere il problema automaticamente, fare clic sul pulsante o sul collegamento Fix it. Fare clic su Esegui nella finestra di dialogo Download file e attenersi alla procedura guidata Fix it.


Correggi problema
Microsoft Fix it 50652


Note
  • Questa procedura guidata potrebbe essere disponibile solo in lingua inglese. La correzione automatica, tuttavia, funziona anche per versioni di Windows in altre lingue.
  • Se non si sta utilizzando il computer che presenta il problema, è possibile salvare la soluzione Fix it su un'unità di memoria flash o su un CD ed eseguirla sul computer interessato dal problema.

Accedere, quindi, alla sezione "Il problema è stato risolto?".



Correzione manuale

Per risolvere il problema, registrare i file Softpub.dll, Wintrust.dll, Initpki.dll e Mssip32.dll. Per registrare questi file, attenersi alla seguente procedura:
  1. Fare clic sul pulsante Start, scegliere Esegui, digitare cmd, quindi scegliere OK.
  2. Al prompt dei comandi digitare regsvr32 Softpub.dll /s e premere INVIO.
  3. Al prompt dei comandi digitare regsvr32 Wintrust.dll /s e premere INVIO.
  4. Al prompt dei comandi digitare regsvr32 Initpki.dll /s e premere INVIO.
  5. Al prompt dei comandi digitare regsvr32 Mssip32.dll /s e premere INVIO.

Il problema è stato risolto?

  • Controllare se il problema è stato risolto. Se il problema è stato risolto, non è necessario continuare la lettura di questa sezione. Se il problema non è stato risolto, contattare il supporto tecnico.
  • I commenti degli utenti sono molto utili. Per fornire commenti o segnalare problemi relativi a questa soluzione, lasciare un commento nel blog "Correzione automatica" o inviare un messaggio di posta elettronica a Microsoft.

Proprietà

Identificativo articolo: 956702 - Ultima modifica: martedì 16 luglio 2013 - Revisione: 2.2
Le informazioni in questo articolo si applicano a:
  • Microsoft Windows Update
  • Microsoft Update
Chiavi: 
kbexpertiseinter kbtshoot kbprb kbfixme kbmsifixme KB956702
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com