Podczas instalowania aktualizacji przy użyciu witryny Windows Update lub Microsoft Update występuje kod błędu 0x800B0100

Tłumaczenia artykułów Tłumaczenia artykułów
Numer ID artykułu: 956702 - Zobacz jakich produktów dotyczą zawarte w tym artykule porady.
Rozwiń wszystko | Zwiń wszystko

Na tej stronie

Symptomy

Podczas instalowania aktualizacji z witryny Windows Update w sieci Web lub z witryny Microsoft Update w sieci Web może zostać wyświetlony następujący komunikat o błędzie:
0x800B0100

Przyczyna

Ten problem występuje, gdy pliki dll zabezpieczeń systemu Windows są nieprawidłowo zarejestrowane.

Rozwiązanie

Aby rozwiązać ten problem, użyj poniższych metod zgodnie z używanym systemem operacyjnym
Microsoft Windows.

Metoda dla systemów Windows 7, Windows Vista i Windows Server 2008

Aby rozwiązać ten problem, uruchom Narzędzie analizy gotowości aktualizacji systemu (Checksur.exe). W tym celu wykonaj następujące czynności:
  1. Pobierz i uruchom Narzędzie analizy gotowości aktualizacji systemu. To narzędzie służy do przeprowadzenia jednorazowego skanowania w poszukiwaniu niespójności, które mogą uniemożliwiać wykonywanie operacji serwisowych w przyszłości.
    Aby uzyskać więcej informacji na temat pobierania i uruchamiania narzędzia Checksur.exe, kliknij następujący numer artykułu w celu wyświetlenia tego artykułu z bazy wiedzy Microsoft Knowledge Base:
    http://support.microsoft.com/kb/947821/pl Opis Narzędzia analizy gotowości aktualizacji systemu dla systemu Windows Vista
  2. Spróbuj ponownie zainstalować aktualizacje.
Uwaga Po uruchomieniu tego narzędzia plik dziennika Checksur.log zostaje umieszczony w następującej lokalizacji: %systemroot%\Logs\CBS\

W przypadku domyślnej instalacji systemów Windows 7 i Windows Vista ten plik można znaleźć w następującym folderze:

C:\Windows\Logs\CBS

Metoda dla systemów Windows 2000, Windows XP i Windows Server 2003

Aby automatycznie rozwiązać ten problem, przejdź do sekcji Automatyczne rozwiązywanie problemu. Aby samodzielnie rozwiązać ten problem, przejdź do sekcji Samodzielne rozwiązywanie problemu.

Automatyczne rozwiązywanie problemu



Aby automatycznie rozwiązać problem, należy kliknąć przycisk lub łącze Fix it. W oknie dialogowym Pobieranie pliku należy kliknąć przycisk Uruchom i wykonać kroki kreatora rozwiązywania problemu.


Rozwiąż ten problem
Microsoft Fix it 50652


Uwagi
  • Ten kreator może być dostępny tylko w języku angielskim. Jednak ta poprawka automatyczna działa również w innych wersjach językowych systemu Windows.
  • Jeśli używany komputer nie jest tym, którego dotyczy problem, można zapisać to rozwiązanie w postaci poprawki automatycznej na dysku flash lub CD i uruchomić je na odpowiednim komputerze.

Teraz przejdź do sekcji Czy problem został rozwiązany?



Samodzielne rozwiązywanie problemu

Aby rozwiązać ten problem, zarejestruj pliki Softpub.dll, Wintrust.dll, Initpki.dll i Mssip32.dll. W tym celu wykonaj następujące czynności:
  1. Kliknij przycisk Start, kliknij polecenie Uruchom, wpisz polecenie cmd, a następnie kliknij przycisk OK.
  2. W wierszu polecenia wpisz regsvr32 Softpub.dll /s, a następnie naciśnij klawisz ENTER.
  3. W wierszu polecenia wpisz regsvr32 Wintrust.dll /s, a następnie naciśnij klawisz ENTER.
  4. W wierszu polecenia wpisz regsvr32 Initpki.dll /s, a następnie naciśnij klawisz ENTER.
  5. W wierszu polecenia wpisz regsvr32 Mssip32.dll /s, a następnie naciśnij klawisz ENTER.

Czy problem został rozwiązany?

  • Należy sprawdzić, czy problem został rozwiązany. Jeśli problem został rozwiązany, to koniec pracy z tą sekcją. Jeśli problem nie został rozwiązany, można skontaktować się z pomocą techniczną.
  • Prosimy o opinię. Aby przekazać opinię lub zgłosić jakiekolwiek problemy dotyczące tego rozwiązania, można zostawić komentarz w blogu Fix it for me (Automatyczne rozwiązywanie problemu) lub wysłać wiadomość e-mail.

Właściwości

Numer ID artykułu: 956702 - Ostatnia weryfikacja: 20 grudnia 2011 - Weryfikacja: 2.0
Informacje zawarte w tym artykule dotyczą:
  • Microsoft Windows Update
  • Microsoft Update
Słowa kluczowe: 
kbexpertiseinter kbtshoot kbprb kbfixme kbmsifixme KB956702

Przekaż opinię

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com