Codul de eroare 0x800B0100 când utilizați Windows Update sau Microsoft Update pentru a instala actualizări

Traduceri articole Traduceri articole
ID articol: 956702 - View products that this article applies to.
Măriți totul | Reduceți totul

În această pagină

SIMPTOME

Când încercați să instalați actualizări de la site-ul Web Windows Update sau site-ul Web Microsoft Update, este posibil să primiți următorul mesaj de eroare:
0x800B0100

CAUZĂ

Această problemă apare dacă fișiere .dll de securitate din Windows sunt înregistrate incorect.

REZOLUȚIE

Pentru a rezolva această problemă, utilizați următoarele metode în conformitate cu sistemul de operare Microsoft Windows pe care
îl utilizați.

Metoda pentru Windows 7, Windows Vista sau Windows Server 2008

Pentru a rezolva această problemă, executați System Update Readiness Tool (Checksur.exe). Pentru aceasta, urmați acești pași:
  1. Descărcați și executați System Update Readiness Tool. Acest instrument se execută o scanare unică pentru neconcordanțe care pot împiedica viitoare operațiuni de întreținere.
    Pentru informații suplimentare privind modul de descărcare și executare a instrumentului Checksur.exe, faceți clic pe următorul număr de articol pentru a vedea articolul în Baza de cunoștințe Microsoft:
    http://support.microsoft.com/kb/947821/ro Descrierea instrumentului System Update Readiness Tool pentru Windows Vista
  2. Încercați să instalați din nou actualizările.
Notă După ce executați instrumentul, fișierul Checksur.log se află în următoarea locație: %systemroot%\Logs\CBS\

Într-o instalare implicită Windows 7 și Windows Vista, acest fișier este în următorul folder:

C:\Windows\Logs\CBS

Metoda pentru Windows 2000, Windows XP sau Windows Server 2003

Dacă doriți să remediem problema pentru dvs., continuați cu secțiunea „Remediere automată”. Dacă preferați să remediați dvs. problema, continuați cu secțiunea „Remediere personală”.

Remediere automată



Pentru o remediere automată a acestei probleme, faceți clic pe linkul sau pe butonul Remediere. În caseta de dialog Descărcare fișier, faceți clic pe Executare, apoi urmați pașii din expertul Fix it.


Remediere problemă
Microsoft Fix it 50652


Note
  • Este posibil ca acest expert să fie numai în limba engleză. Însă, remedierea automată funcționează și pentru Windows în alte limbi.
  • Dacă nu vă aflați la computerul care manifestă problema, salvați soluția Fix it pe o unitate flash sau pe un CD, apoi executați-o pe computerul care manifestă problema.

Apoi continuați cu secțiunea „S-a remediat problema?”.



Remediere personală

Pentru a rezolva această problemă, înregistrați fișierele Softpub.dll, Wintrust.dll, Initpki.dll și Mssip32.dll. Pentru a înregistra aceste fișiere, urmați acești pași:
  1. Faceți clic pe Start, pe Executare, tastați cmd, apoi faceți clic pe OK.
  2. La promptul de comandă, tastați regsvr32 Softpub.dll /s, apoi apăsați ENTER.
  3. La promptul de comandă, tastați regsvr32 Wintrust.dll /s, apoi apăsați ENTER.
  4. La promptul de comandă, tastați regsvr32 Initpki.dll /s, apoi apăsați ENTER.
  5. La promptul de comandă, tastați regsvr32 Mssip32.dll /s, apoi apăsați ENTER.

S-a remediat problema?

  • Verificați dacă s-a remediat problema. Dacă s-a remediat problema, ați terminat cu această secțiune. Dacă problema nu s-a remediat, contactați asistența.
  • Apreciem părerea dvs. Pentru a vă spune părerea sau pentru a raporta orice problemă cu această soluție, lăsați un comentariu în blogul „Remediere automat㔠sau trimiteți-ne un mesaj de poștă electronică.

Proprietă?i

ID articol: 956702 - Ultima examinare: 20 decembrie 2011 - Revizie: 2.0
SE APLICĂ LA:
  • Microsoft Windows Update
  • Microsoft Update
Cuvinte cheie: 
kbexpertiseinter kbtshoot kbprb kbfixme kbmsifixme KB956702

Trimite?i feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com