Returning to the Last Editing Position When Opening Files

Article translations Article translations
Article ID: 95694 - View products that this article applies to.
This article was previously published under Q95694
This article has been archived. It is offered "as is" and will no longer be updated.
Expand all | Collapse all

On This Page

SYMPTOMS

Microsoft Word does not retain the location of your insertion point when you save and close a document.

CAUSE

This occurs by product design.

WORKAROUND

Word 7.0, 97

Press SHIFT+F5 after you open the document to move the cursor to its previous location.

Word 2.0, 6.0

The following AutoOpen macro can be used to return your insertion point to its last editing position when a document is opened:
   Sub MAIN
   If ExistingBookmark("\PrevSel1") Then EditGoTo "\PrevSel1"
   End Sub
				
To create the above macro:

  1. From the Tools menu, choose Macro.
  2. From the Show box, select the Global Macro option.
  3. Type AutoOpen for the macro name and choose the Edit button.
  4. Type the following macro line between the Sub MAIN and End Sub lines:
    If ExistingBookmark("\PrevSel1") Then EditGoTo "\PrevSel1"
    					
  5. From the File menu, choose Close. Choose the Yes button when prompted to save changes to Global:AutoOpen.
  6. From the File menu, choose Save All. When prompted, choose to save global glossary and command changes.

MORE INFORMATION

If you want to return to a specific location each time you open a document, insert a bookmark at that location and then record an AutoNew macro that goes to that bookmark.

REFERENCES

"Using WordBasic," by WexTech Systems and Microsoft, pages 88-89 and page 184.

Properties

Article ID: 95694 - Last Review: October 21, 2013 - Revision: 2.3
APPLIES TO
  • Microsoft Word 2.0 Standard Edition
  • Microsoft Word 2.0a
  • Microsoft Word for Windows 2.0b
  • Microsoft Word 2.0c
  • Microsoft Word 6.0 Standard Edition
  • Microsoft Word 6.0a
  • Microsoft Word 6.0c
  • Microsoft Word 95 Standard Edition
  • Microsoft Word 95a
  • Microsoft Word 97 Standard Edition
  • Microsoft Word 6.0 for Macintosh
  • Microsoft Word 6.01 for Macintosh
  • Microsoft Word 6.01 for Macintosh
Keywords: 
kbnosurvey kbarchive KB95694

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com