ID do artigo: 957003 - Última revisão: quinta-feira, 25 de setembro de 2008 - Revisão: 1.0

O método RenameUser não altera o atributo samAccountName na solução para Hosted Messaging and Collaboration 4.0

Download do hotfix está disponívelDownload do Hotfix Disponível
Visualizar e solicitar downloads de hotfix
Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.

Nesta página

Expandir tudo | Recolher tudo

Sintomas

Você usar o serviço host de Web do Active Directory para chamar o método RenameUser no Microsoft Solution for Hosted Messaging and Collaboration 4.0. Se você especificar um novo valor para o atributo samAccountName , a chamada para o método RenameUser retornará sem erro. No entanto, o atributo samAccountName não foi alterado.

Causa

Há um erro no esquema XSD para este parâmetro. Portanto, o atributo samAccountName não é passado para o provedor.

Observação Este problema existe somente se você usar o serviço de Web hospedado Active Directory para chamar o método RenameUser . Se você chamar o procedimento diretamente de um Microsoft configuração Server (MPS) cliente, que tenha êxito.

Resolução

Informações sobre o hotfix

Um hotfix suportado está disponível no Microsoft. No entanto, esse hotfix destina-se a corrigir o problema descrito neste artigo. Aplique-o somente aos sistemas que apresentarem esse problema específico.

Se o hotfix está disponível para download, há uma seção "Download de Hotfix disponível" na parte superior neste artigo da Base de dados de Conhecimento. Se esta seção não for exibido, envie uma solicitação para suporte e atendimento ao cliente Microsoft para obter o hotfix.

Observação Se ocorrerem problemas adicionais ou se qualquer solução de problemas é necessária, talvez você precise criar uma solicitação de serviço separada. Os custos normais de suporte serão aplicados a questões de suporte adicionais e problemas que não se qualificam para esse hotfix específico. Para obter uma lista completa de números de telefone de suporte e Atendimento Microsoft ou para criar uma solicitação de serviço separada, visite o seguinte site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Observação O formulário "Download de Hotfix disponível" exibe os idiomas para os quais o hotfix está disponível. Se você não vir seu idioma, é porque um hotfix não está disponível para esse idioma.

Guia de instalação do hotfix

Para aplicar esse hotfix, execute essas etapas:
  1. No servidor que esteja executando o MPS (Microsoft configuração Server), interrompa os serviços Web MPS para certificar-se que não mais solicitações podem ser executadas no servidor. Para fazer isso, execute as seguintes etapas:
    1. Clique em Iniciar , aponte para Todos os programas , aponte para Ferramentas administrativas e, em seguida, clique em Serviços de componentes .
    2. Expanda Serviços de componente , expanda computadores , expanda My Computer e, em seguida, expanda Aplicativos COM + .
    3. Clique com o botão direito Mecanismo de configuração , clique em Desativar e, em seguida, clique em Desligar .
  2. Inicie a ferramenta de implantação MPS.
  3. No painel de Status de requisitos , expanda Hospedados Active Directory , clique Hospedados Active Directory com o botão direito do mouse e, em seguida, clique em desinstalar .
  4. Expanda MPS Web Services , expanda Hospedados Active Directory Web Service , clique com o botão direito do mouse no nome do servidor e, em seguida, clique em desinstalar .
  5. Clique em Iniciar implantação e aguarde até que a caixa de diálogo Implantação completa para aparecer.
  6. Localize a pasta %SystemDrive%\MSIShare e em seguida, renomear ou fazer backup dos seguintes arquivos .msi:
    • HostedActiveDirectoryNS.msi
    • HostedActiveDirectoryWS.msi
  7. Substitua os arquivos .msi que estão incluídos no hotfix esses dois arquivos.
  8. Na ferramenta de implantação MPS, clique com o botão direito do mouse Hosted Active Directory e em seguida, clique em instalar .
  9. Em Hospedados Active Directory Web Service , clique com o botão direito do mouse no nome de servidor MPS e, em seguida, clique em instalar .
  10. Clique em Iniciar implantação e aguarde até que a caixa de diálogo Implantação completa para aparecer.
  11. Em cada servidor front-end de configuração, reinicie o Internet Information Services (IIS).
  12. No console de serviços de componente, clique Mecanismo de configuração com o botão direito do mouse e clique em Habilitar e iniciar para reiniciar o mecanismo de MPS.

Pré-requisitos

Você deve ter hotfix 952077 instalado antes de aplicar o hotfix. Para obter mais informações, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
952077  (http://support.microsoft.com/kb/952077/ ) Descrição do Update Rollup 4 para os serviços Hosted Exchange do Microsoft Solution para Hosted Messaging and Collaboration 4.0

Requisitos de reinicialização

Não é necessário reiniciar o computador após aplicar esse hotfix.

Informações sobre a substituição do hotfix

Esse hotfix substitui o hotfix 949708.Para obter mais informações, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
949708  (http://support.microsoft.com/kb/949708/ ) Mensagem de erro quando você chamar o procedimento RenameUser Hosted Messaging and Collaboration 4.0: "é objeto inexistente no servidor"

Informações sobre o arquivo

A versão em inglês deste hotfix tem atributos de arquivo (ou atributos de arquivo posteriores) listados na tabela a seguir. As datas e horas desses arquivos são listadas na hora universal coordenada (UTC). Quando você exibe as informações do arquivo, ele é convertido para a hora local. Para encontrar a diferença entre o UTC e a hora local, use a guia fuso horário no item Data e hora no painel de controle.
Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataforma
Hostedactivedirectoryns.msiNão aplicável257,02406-Agosto de 200815: 15Não aplicável
Hostedactivedirectoryws.msiNão aplicável473.60006-Agosto de 200815: 15Não aplicável

Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na seção "Aplica-se a".

Mais Informações

Para obter mais informações sobre terminologia de atualização de software, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
824684  (http://support.microsoft.com/kb/824684/LN/ ) Descrição da terminologia padrão que é usada para descrever as atualizações de software

A informação contida neste artigo aplica-se a:
  • Microsoft Solution for Hosted Messaging and Collaboration 4.0
Palavras-chave: 
kbmt kbautohotfix kbexpertiseinter kbfix kbhotfixserver kbqfe KB957003 KbMtpt
Tradução automáticaTradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 957003  (http://support.microsoft.com/kb/957003/en-us/ )