Makale numarası: 957003 - Son Gözden Geçirme: 25 Eylül 2008 Perşembe - Gözden geçirme: 1.0

RenameUser yöntemi barındırılan ileti ve işbirliği 4.0 Solution <a1>samAccountName</a1> özniteliği değiştirmez

Hotfix Download is availableHotfiks Yüklemesi Mevcut
Hotfiks taleplerini görüntüle ve indir
Sistem İpucuBu makale, kullandığınızdan farklı bir işletim sistemine yöneliktir. Sizinle ilgili olmayabilecek makale içeriği devre dışı bırakıldı.

Bu Sayfada

Hepsini aç | Hepsini kapa

Belirtiler

Ana bilgisayar Active Directory Web hizmeti, barındırılan ileti ve işbirliği 4.0 için Microsoft Solution RenameUser yöntemini çağırmak için kullanın. RenameUser yöntemine ça?r?, samAccountName özniteliği için yeni bir değer belirtirseniz, bir hata döndürecektir. Ancak, samAccountName özniteliği değişmedi.

Neden

Bu parametre için XSD Şemasındaki bir hata var. Bu nedenle, samAccountName özniteliği sağlayıcısına geçirilir değil.

NotYalnızca barındırılan Active Directory Web hizmeti RenameUser yöntemini kullanıyorsanız, bu sorun oluşur. Doğrudan bir Microsoft hazırlama Server (MPS karşı) yordamını çağırmak, istemci, başarılı.

Çözüm

Düzeltme bilgileri

Desteklenen bir düzeltme Microsoft'tan edinilebilir. Ancak bu düzeltmenin, yalnızca bu makalede anlatılan sorunu gidermesi amaçlanmıştır. Bu düzeltmeyi yalnızca bu sorunla karşılaşan sistemlere uygulayın.

Düzeltme karşıdan yüklenebilir ise bu Bilgi Bankası makalesinin başında "Düzeltme karşıdan yüklenebilir" bölümü bulunur. Bu bölüm görünmüyorsa, düzeltmeyi edinmek üzere Microsoft Müşteri Hizmetleri ve Destek ekibine bir istekte bulunun.

Not Ek sorunlar oluşursa veya tüm sorun giderme işlemi gerekmiyorsa, ayrı bir hizmet isteği oluşturmanız gerekebilir. Ek destek sorularına ve bu düzeltme için geçerli olmayan sorunlara normal destek ücretleri uygulanır. Microsoft Müşteri Hizmetleri ve Destek telefon numaralarının tam listesi veya ayrı bir hizmet isteği oluşturmak için, aşağıdaki Microsoft Web sitesini ziyaret edin:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Not "Düzeltme karşıdan yüklenebilir" formunda, düzeltmenin kullanılabilir olduğu diller görüntülenir. Kendi dilinizi görmüyorsanız, bunun nedeni bu düzeltme, seçtiğiniz dil için kullanılamaz.

Düzeltme Yükleme Kılavuzu

Bu düzeltmeyi uygulamak için <a0></a0>, aşağıdaki adımları izleyin:
  1. Microsoft hazırlama Server (MPS) çalıştıran sunucu üzerinde daha fazla hiçbir istekleri sunucuda gerçekleştirilebilir emin olmak için MPS Web hizmetlerini durdurun. Bunu yapmak için şu adımları izleyin:
    1. Başlat ' ı tıklatın, Programlar ' ın üzerine gelin, Yönetimsel Araçlar ' ın üzerine gelin ve sonra Bileşen Hizmetleri ' ni tıklatın.
    2. Component Services ' ı genişletin, bilgisayarlar ' ı genişletin, Bilgisayarım ' ı genişletin ve sonra COM + uygulamaları ' nı genişletin.
    3. Hazırlama altyapısı ' nı sağ tıklatın, devre dışı bırak ' ı tıklatın ve sonra da <a2>Kapat</a2>'ı tıklatın.
  2. MPS dağıtım Aracı'nı başlatın.
  3. Gereksinimleri durum bölmesinde Barındırılan Active Directory ' i genişletin, Barındırılan Active Directory ' i sağ tıklatın ve sonra Kaldır ' ı tıklatın.
  4. MPS Web Hizmetleri ' ni genişletin, Barındırılan Active Directory Web Service ' ı genişletin, sunucunun adını sağ tıklatın ve sonra Kaldır ' ı tıklatın.
  5. Dağıtım, Başlat'ı tıklatın ve sonra da Dağıtım tamamlandı iletişim kutusunun görünmesini için bekleyin.
  6. %SystemDrive%\MSIShare klasörünü bulun ve sonra yeniden adlandırmak veya aşağıdaki .msi dosyaları yedekleyin:
    • HostedActiveDirectoryNS.msi
    • HostedActiveDirectoryWS.msi
  7. Bu iki dosyayı düzeltmenin içerdiği .msi dosyaları değiştirin.
  8. MPS dağıtım Aracı'nı sağ tıklatın Hosted Active Directory ve sonra da <a2>Yükle</a2>'yi tıklatın.
  9. Barındırılan Active Directory Web hizmeti altında <a0>MPS</a0> sunucunun adını sağ tıklatın ve sonra da <a2>Yükle</a2>'yi tıklatın.
  10. Dağıtım, Başlat'ı tıklatın ve sonra da Dağıtım tamamlandı iletişim kutusunun görünmesini için bekleyin.
  11. Her hazırlama ön uç sunucuda yeniden başlatın, ınternet ınformation Services (IIS).
  12. Bileşen Hizmetleri konsolunda, Hazırlama altyapısı ' nı sağ tıklatın ve MPS Altyapısı'nı yeniden başlatmak için etkinleştirilir ve Başlat'ı tıklatın.

ÖNKOŞULLAR

<a1>Düzeltme</a1> 952077 düzeltmeyi uygulamadan önce yüklü olması gerekir. Daha fazla bilgi için, Microsoft Bilgi Bankası'ndaki makaleyi görüntülemek üzere aşağıdaki makale numarasını tıklatın:
952077  (http://support.microsoft.com/kb/952077/ ) Güncelleştirme paketi 4'ün için açıklama Microsoft Solution Exchange barındırılan hizmetlerinde barındırılan ileti ve işbirliği 4.0

Yeniden başlatma gereksinimi

Bu düzeltmeyi uyguladıktan sonra bilgisayarı yeniden başlatmanız gerekmez.

Düzeltme Değiştirme Bilgileri

Bu düzeltme, <a1>düzeltme</a1> 949708 yerini alır.Daha fazla bilgi için, Microsoft Bilgi Bankası'ndaki makaleyi görüntülemek üzere aşağıdaki makale numarasını tıklatın:
949708  (http://support.microsoft.com/kb/949708/ ) Barındırılan ileti ve işbirliği 4.0 RenameUser yordamını çağırdığınızda bir hata iletisi: "Yok böyle bir nesne sunucuda"

DOSYA BİLGİLERİ

Bu düzeltmenin İngilizce sürümü, aşağıdaki tabloda listelenen dosya özniteliklerine (veya daha yeni dosya özniteliklerine) sahiptir. Bu dosyaların tarihleri ve saatleri Koordinatlı Evrensel Saat'e (UTC) göre listelenir. Dosya bilgilerini görüntülediğinizde yerel saate dönüştürülür. UTC ve yerel saat arasındaki farkı bulmak için <a0></a0>, Denetim Masası'ndaki tarih ve saat öğesinde saat dilimi sekmesini kullanın.
Bu tabloyu kapaBu tabloyu aç
Dosya AdıDosya SürümüDosya BoyutuTARİHSAATPlatform
Hostedactivedirectoryns.msiUygulanamaz257,02406 Ağu 200815: 15Uygulanamaz
Hostedactivedirectoryws.msiUygulanamaz473.60006 Ağu 200815: 15Uygulanamaz

Durum

Microsoft, "Geçerli Olduğu Ürünler" bölümünde listelenen Microsoft ürünlerinde bu sorunun olduğunu onaylamıştır.

Daha fazla bilgi

Yazılım güncelleştirme terminolojisi hakkında daha fazla bilgi için, Microsoft Bilgi Bankası'ndaki makaleyi görüntülemek üzere aşağıdaki makale numarasını tıklatın:
824684  (http://support.microsoft.com/kb/824684/LN/ ) Microsoft yazılım güncelleştirmelerini açıklamak için kullanılan standart terminolojinin açıklaması

Bu makaledeki bilginin uygulandığı durum:
  • Microsoft Solution for Hosted Messaging and Collaboration 4.0
Anahtar Kelimeler: 
kbmt kbautohotfix kbexpertiseinter kbfix kbhotfixserver kbqfe KB957003 KbMttr
Otomatik TercümeOtomatik Tercüme
ÖNEMLİ: Bu makale, bir kişi tarafından çevrilmek yerine, Microsoft makine-çevirisi yazılımı ile çevrilmiştir. Microsoft size hem kişiler tarafından çevrilmiş, hem de makine-çevrisi ile çevrilmiş makaleler sunar. Böylelikle, bilgi bankamızdaki tüm makalelere, kendi dilinizde ulaşmış olursunuz. Bununla birlikte, makine tarafından çevrilmiş makaleler mükemmel değildir. Bir yabancının sizin dilinizde konuşurken yapabileceği hatalar gibi, makale; kelime dağarcığı, söz dizim kuralları veya dil bilgisi açısından yanlışlar içerebilir. Microsoft, içeriğin yanlış çevrimi veya onun müşteri tarafından kullanımından doğan; kusur, hata veya zarardan sorumlu değildir. Microsoft ayrıca makine çevirisi yazılımını sıkça güncellemektedir.
Makalenin İngilizcesi aşağıdaki gibidir:957003  (http://support.microsoft.com/kb/957003/en-us/ )