Article ID: 957051 - Last Review: October 8, 2011 - Revision: 2.0

Windows Deployment Services generates duplicate client computer names when the %MAC variable is used

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SYMPTOMS

In the Active Directory domain network, you try to use Windows Deployment Services (WDS) to deploy a version of the Windows NT operating system. To make the client computer name that is automatically generated unique in the network, you configure a new computer naming policy for WDS. When you configure the new policy, you use the variable %MAC to include the network adapter media access control (MAC) address of the client computer as part of the computer name.

However, when WDS deploys the client computers during the unattended phase, the computer names that are generated for the client computers show zeros instead of the MAC addresses of the client computers. Therefore, the process fails because of duplicate computer names in the network.

CAUSE

This problem occurs because of a bug in the Wdsclient.dll file.

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must use the Windows Vista Service Pack 1 (SP1) Boot.wim file.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
For all supported x86-based versions of Windows Server 2008 and Windows Vista
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Wdsclient.dll6.0.6001.22282255,48807-Oct-200809:57x86
For all supported x64-based versions of Windows Server 2008 and Windows Vista
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Wdsclient.dll6.0.6001.22282274,94407-Oct-200811:05x64
For all supported Itanium-based versions of Windows Server 2008
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Wdsclient.dll6.0.6001.22282563,71207-Oct-200810:56IA-64

Hotfix installation information

To apply the hotfix that is mentioned in this article, follow these steps:
  1. The hotfix that is mentioned in this article contains a .cab package. Extract the Wdsclient.dll file from the .cab package to a temporary folder. To do this, double-click the .cab package.
  2. Install the Windows Automated Installation Kit (Windows AIK) or the Windows OEM Preinstall Kit (Windows OPK).
  3. Disable the boot image on the WDS server to make the boot image unavailable for downloading. For example, at a command prompt, type the following command, and then press ENTER:
    wdsutil.exe /set-image /image: ImageName/imagetype:boot /architecture: Platform/enabled:no
    Note The ImageName placeholder represents the name of the boot image. Replace the Platform placeholder with x86, with x64, or with ia64, as appropriate for your situation.
  4. Export the boot image from the WDS server. For example, at a command prompt, type the following command, and then press ENTER:
    wdsutil.exe /export-image /image: ImageName /imagetype:boot /architecture: Platform /destinationimage /filepath: PathToBootWIM
    Note The ImageName placeholder represents the name of the boot image. Replace the Platform placeholder with x86, with x64, or with ia64, as appropriate for your situation. The PathToBootWIM placeholder represents the Windows Imaging Format (WIM) file where you want to export the boot image.
  5. Mount the boot image that you exported in step 4. When you do this, specify an index of 2, and specify read access and write access. For example, at a command prompt, type the following command, and then press ENTER:
    imagex.exe /mountrw PathToBootWIM 2 MountLocation
    Note The PathToBootWIM placeholder represents the location where you exported the boot image in step 4. The MountLocation placeholder represents the location to which you want to mount the boot image. For more information about this operation, see the documentation that is provided in the Windows OPK.
  6. Locate the Wdsclient.dll file that you extracted in step 1. Copy the Wdsclient.dll file to the Sources folder in the mount location that you specified in step 5, and then replace the existing file.
  7. Unmount the WIM file that you specified in step 5 by committing all changes. For example, at a command prompt, type the following command, and then press ENTER:
    imagex.exe /commit /unmount MountLocation
    Note The MountLocation placeholder represents the mount location that you specified in step 5.
  8. Add the WIM file back to the WDS server. For example, at a command prompt, type the following command, and then press ENTER:
    wdsutil.exe /replace-image /image: ImageName /imagetype:boot /architecture: Platform /replacementimage /imagefile: PathToBootWIM
    Note The ImageName placeholder represents the name of the boot image that you want to specify. Replace the Platform placeholder with x86, with x64, or with ia64, as appropriate for your situation. The PathToBootWIM placeholder represents the WIM file that you specified in step 5.
  9. Delete all temporary folders.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about WDS, visit the following Microsoft Web site:
http://technet.microsoft.com/en-us/library/cc771670.aspx (http://technet.microsoft.com/en-us/library/cc771670.aspx)
For more information about Windows Preinstallation Environment in Windows Vista, visit the following Microsoft Web site:
http://technet.microsoft.com/en-us/windows/aa905120.aspx (http://technet.microsoft.com/en-us/windows/aa905120.aspx)
For more information about the Windows Automated Installation Kit, visit the following Microsoft Web site:
http://www.microsoft.com/downloads/details.aspx?familyid=C7D4BC6D-15F3-4284-9123-679830D629F2&displaylang=en (http://www.microsoft.com/downloads/details.aspx?familyid=C7D4BC6D-15F3-4284-9123-679830D629F2&displaylang=en)
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
937333  (http://support.microsoft.com/kb/937333/ ) WDS cannot generate more than 255 client names when you use WDS to deploy Windows Vista

APPLIES TO
  • Windows Vista Business
  • Windows Vista Enterprise
  • Windows Vista Home Basic
  • Windows Vista Home Premium
  • Windows Vista Ultimate
  • Windows Vista Business 64-bit Edition
  • Windows Vista Enterprise 64-bit Edition
  • Windows Vista Home Basic 64-bit Edition
  • Windows Vista Home Premium 64-bit Edition
  • Windows Vista Ultimate 64-bit Edition
Keywords: 
kbautohotfix kbexpertiseinter kbfix kbbug kbqfe KB957051