You do not receive an NDR message even though your meeting request cannot be sent successfully to a recipient

Article translations Article translations
Article ID: 957124 - View products that this article applies to.
Expand all | Collapse all

SYMPTOMS

In a Microsoft Exchange Server 2007 environment, a mailbox user's legacyExchangeDN may be changed from /O=<Org>/OU=<Site>/CN=Recipients/CN=<Username> to /O=<Org>/OU=<Site>/CN=<Username>. When any other users try to send a meeting request to the mailbox user in Microsoft Office Outlook Web Access, the message is not delivered successfully. However, no Non-Delivery Report (NDR) is generated immediately. Instead, the message stays in the queue, and repeated attempts are made to send the message. If you open the Queue Viewer tool in Exchange Management Console, the message is queued there, and you see that the last error that occurs is as follows:
430 4.2.0 STOREDRV.Deliver.Exception:MapiExceptionCanNotComplete
Additionally, when this problem occurs, warning and error messages that resemble the following are logged in the Application log:
Event Type:     Warning
Event Source:   EXCDO
Event Category: General 
Event ID:       8230
Description:
An inconsistency was detected in <recipient's SMTP address>: /Calendar/<subject of meeting request>.EML.  The calendar is being repaired. If a problem persists, please recreate the calendar or the containing mailbox. 
Event Type:     Error
Event Source:   EXCDO
Event Category: General 
Event ID:       8206
Description:
Calendaring agent failed with error code 0x80040215 while saving appointment.
Event Type:     Error
Event Source:   EXCDO
Event Category: General 
Event ID:       8213
Description:
Calendaring agent failed to update the free/busy cache during an appointment save or delete operation.
Event Type:     Error
Event Source:   EXCDO
Event Category: General 
Event ID:       8199
Description:
Calendaring agent failed in message save notification with error 0x800703eb on <recipient's SMTP address>: /Calendar/<subject of meeting request>.EML

CAUSE

This problem occurs because Exchange Server 2007 does not return a permanent error when the Exchange server finds the incorrect legacyExchangeDN property.

RESOLUTION

To resolve this problem, install Update Rollup 7 for Exchange 2007 Service Pack 1. For more information about Update Rollup 7 for Exchange Server 2007 Service Pack 1, see the following Exchange Help topic:
Description of Update Rollup 7 for Exchange Server 2007 Service Pack 1
For more information about how to install the latest Exchange service pack or update rollup, see the following Exchange Help topic:
How to Obtain the Latest Service Pack or Update Rollup for Exchange 2007

Note After you install the hotfix, a NDR will be generated for the message immediately.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Properties

Article ID: 957124 - Last Review: March 18, 2009 - Revision: 1.1
APPLIES TO
  • Microsoft Exchange Server 2007 Service Pack 1, when used with:
    • Microsoft Exchange Server 2007 Enterprise Edition
    • Microsoft Exchange Server 2007 Standard Edition
Keywords: 
kbsurveynew kbhotfixrollup kbqfe kbexpertiseadvanced KB957124

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com