Un nombre de usuario que contiene caracteres Unicode no se controla correctamente en Windows XP Service Pack 3 durante la autenticación de EAP

Seleccione idioma Seleccione idioma
Id. de artículo: 957218 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

En esta página

Síntomas

Cuando se utiliza una cuenta de usuario que tiene un nombre de usuario contiene caracteres Unicode en Windows XP Service Pack 3 (SP3) - basado en equipo, el nombre de usuario no la autenticación de protocolo de autenticación extensible (EAP). Por lo tanto, puede no acceso a la local red.

Causa

Este problema se produce debido a la arquitectura de EAPHost en Windows XP SP3. Cuando intenta autenticar, EAPHost convierte el identificador de EAP del mensaje a Unicode. Sin embargo, el servidor intenta leer el mensaje EAP ID como ASCII. Por lo tanto, si la identidad del usuario tiene los caracteres ASCII 128 y 255, fallará la autenticación de EAP.

Solución

Información de revisiones

Hay una revisión compatible de Microsoft. Sin embargo, esta revisión se diseñó para corregir el problema descrito en este artículo. Aplíquela sólo a los sistemas que experimenten este problema específico.

Si la revisión está disponible para descarga, es hay una sección de "Descarga de revisión disponible" al principio de este artículo. Si no aparece en esta sección, enviar una solicitud al servicio de cliente de Microsoft y soporte para obtener la revisión.

Nota Si se producen problemas adicionales o si cualquier solución de problemas es necesario, quizás tenga que crear una solicitud de servicio independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no guarden relación con esta revisión específica. Para obtener una lista completa de números de teléfono de servicio de atención al cliente y soporte técnico o para crear una solicitud de servicio independiente, visite el siguiente sitio Web:
http://support.microsoft.com/contactus/?ws=support
Nota El formulario "Descarga de revisión disponibles" muestra los idiomas para que la revisión está disponible. Si no ve su idioma, es porque una revisión no está disponible para ese idioma.

Requisitos previos

Para aplicar este hotfix, debe tener instalado en el equipo de Windows XP Service Pack 3. Para obtener más información, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
322389Cómo obtener el service pack más reciente de Windows XP

Requisito de reinicio

Ou Y no tiene que reiniciar el equipo después de aplicar este hotfix.

Información acerca de la sustitución de la revisión

Este hotfix no sustituye a otros hotfix.

Información del registro

importante Esta sección, el método o la tarea contiene pasos que indican cómo modificar el registro. Sin embargo, pueden producirse problemas graves si modifica incorrectamente el registro. Por tanto, asegúrese de que siga estos pasos cuidadosamente. Realice una para agregar protección, copia de seguridad del registro antes de modificarlo. A continuación, puede restaurar el registro si se produce un problema. Para obtener más información acerca de cómo realizar una copia de seguridad y restaurar el registro, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
322756Cómo realizar una copia de seguridad y restaurar el registro de Windows

Para habilitar esta revisión, siga estos pasos:
  1. Haga clic en Inicio , haga clic en Ejecutar , escriba regedit y, a continuación, haga clic en Aceptar .
  2. Busque la siguiente subclave del Registro:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\EapHost\Configuration
  3. En el menú Edición , seleccione nuevo y, a continuación, haga clic en Valor DWORD .
  4. Escriba IdentityEncodingFormat y, a continuación, presione ENTRAR.
  5. En el menú Edición , haga clic en Modificar .
  6. Escriba 0 x 1 y, a continuación, haga clic en Aceptar .
  7. Editor de registro de salida.

Información de archivo

La versión en inglés de este hotfix tiene los atributos de archivo (o atributos de último archivo) mostrados en la siguiente tabla. Las fechas y las horas de estos archivos se muestran en hora universal coordinada (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para averiguar la diferencia entre hora UTC y la hora local, utilice la ficha zona horaria el elemento fecha y hora en el panel de control.
Windows XP con Service Pack 3, x 86
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño de archivoFechaTiempoPlataformaRequisito de SP
Eappgnui.dll5.1.2600.566394.20826 De agosto de 200813: 36x 86SP3
Eapphost.dll5.1.2600.5663180,73626 De agosto de 200813: 36x 86SP3

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "La información de este artículo se refiere a:".

Más información

Para obtener más información sobre la EAPHost arquitectura, visite el siguiente sitio Web:
http://msdn.microsoft.com/en-us/library/aa363523(VS.85).aspx
Para obtener más información acerca del servicio de autenticación de Internet (IAS), visite el siguiente sitio Web:
http://technet.microsoft.com/en-us/network/bb643123.aspx

Propiedades

Id. de artículo: 957218 - Última revisión: jueves, 4 de septiembre de 2008 - Versión: 1.0
La información de este artículo se refiere a:
  • Service Pack 3 para Microsoft Windows XP sobre las siguientes plataformas
    • Microsoft Windows XP Home Edition
    • Microsoft Windows XP Professional
Palabras clave: 
kbmt kbfix kbbug kbexpertiseinter kbautohotfix kbqfe kbhotfixserver KB957218 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 957218

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com