You cannot go online after you send an e-mail message to another user in Microsoft Dynamics CRM 4.0 client for Microsoft Office Outlook

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Article ID: 957960 - View products that this article applies to.
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SYMPTOMS

Consider the following scenario in Microsoft Dynamics CRM 4.0.
  • You configure Microsoft Dynamics CRM to create separate e-mail messages for every user.
  • You log on to Microsoft Dynamics CRM 4.0 client for Microsoft Office Outlook by using a user that has the Read permission at the User level for the Activity entity. Then, you go offline.
  • You send an e-mail message to another user.
  • You try to go online.
In this scenario, you receive the following error message:
Data Synchronization Error:
Name: Type: Error
Test Email: E-mail: You do not have enough privileges to access the Microsoft Dynamics CRM object or perform the requested operation. For more information, contact your Microsoft Dynamics CRM administrator.

Test Email: E-mail: The requested record was not found or you do not have sufficient permissions to view it. Test Email: E-mail: The requested record was not found or you do not have sufficient permissions to view it.

The following message is logged in the Microsoft CRM Server platform trace log SOAP Request failed:
Url:http://URL
MethodName:Execute
Response:
<?xml version="1.0" encoding="utf-8"?>
<soap:Envelope xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">
<soap:Body>
<soap:Fault>
<faultcode>soap:Server</faultcode>
<faultstring>Server was unable to process request. ---&gt; Exception has been thrown by the target of an invocation. ---&gt; email With Id = 2ce117e0-9785-dd11-81be-00155d41d218 Does Not Exist</faultstring> <detail />
</soap:Fault>
</soap:Body>
</soap:Envelope>
System.Web.Services.Protocols.SoapException: Server was unable to process request. ---> System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> Microsoft.Crm.BusinessEntities.CrmObjectNotFoundException: email With Id = 2ce117e0-9785-dd11-81be-00155d41d218 Does Not Exist
at Microsoft.Crm.BusinessEntities.BusinessProcessObject.Retrieve(BusinessEntityMoniker moniker, EntityExpression entityExpression, ExecutionContext context, Int32[] deletionCodes, Int32 languageCode)

CAUSE

When you try to go online, the e-mail message has already been created because the query is finished under the context of the SYSTEM user who has elevated permissions. However, you cannot go online because you do not have access to the e-mail message that has been created.

RESOLUTION

This problem is fixed in the latest cumulative update rollup for Microsoft Dynamics CRM 4.0. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
949256 Microsoft Dynamics CRM 4.0 updates and hotfixes

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates
For more information about Microsoft Business Solutions CRM software hotfix and update package terminology, click the following article number to view the article in the Microsoft Knowledge Base:
887283 Microsoft Business Solutions CRM software hotfix and update package naming standards

Properties

Article ID: 957960 - Last Review: January 20, 2012 - Revision: 2.2
APPLIES TO
  • Microsoft Dynamics CRM 4.0
  • Microsoft Dynamics CRM for Microsoft Office Outlook, when used with:
    • Microsoft Dynamics CRM 4.0
Keywords: 
kberrmsg kbexpertiseinter kbfix kbautohotfix kbsurveynew kbmbsmigrate kbqfe kbhotfixserver KB957960

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