Article ID: 958011 - Last Review: November 18, 2008 - Revision: 2.0

The System Preparation tool removes all collected WinSAT data in Windows Vista, and you cannot shorten the OOBE process by running WinSAT before the image is sealed

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SYMPTOMS

In Windows Vista, system assessment information is collected by the Windows System Assessment Tool (WinSAT) during the Out Of Box Experience (OOBE) process. This behavior leads to an increase in OOBE time.

To reduce the OOBE time in Windows Vista, you may want to run the WinSAT before the image is sealed. For example, you may want to run the WinSAT in the factory. However, if you run the WinSAT before the image is sealed, all the WinSAT data that is collected cannot be preserved when you reseal the image. Therefore, you cannot reduce the OOBE time by running WinSAT during the image preparation phase.

CAUSE

This problem occurs because all WinSAT data that is collected is removed as part of system cleanup when the System Preparation (SysPrep) tool is run.

RESOLUTION

A hotfix is available to resolve this issue. This hotfix includes a new flag that is called "PreserveWinSATData" in the unattend.xml file. This hotfix also contains an updated version of the SysPrep WinSAT (SPWinSAT.dll) plug-in. If this new flag is set, and the WinSAT plug-in runs, the corresponding WinSAT data can be preserved.

After you install hotfix 958011, follow these steps:
  1. Apply hotfix 958011 to a Windows Vista reference image.
  2. Run the Windows System Image Manager (Windows SIM) tool, and then select the reference image that was updated. Then, create a new answer file, or open an existing answer file for this reference image.
  3. In the Windows Image pane of the Windows SIM, right-click the Microsoft-Windows-Sysprep-SpWinSAT component.
  4. Select one of the following configuration passes to indicate which setting is to be applied.
    • Pass 3 - generalize
    • Pass 5 - auditSystem
    • Pass 7 - oobeSystem
    In the properties pane of the pass that you selected, set the PreserveWinSATData flag to true.

    Warning Do not set this flag to false. We recommended that you do not use this flag at all instead of setting it to false.
  5. Save the answer file, and then continue the image configuration.
  6. During the configuration pass that you selected in step 4, run the Windows System Assessment Tool (WinSAT.exe) by using the following command:
    winsat.exe moobe formal
    Important You must run WinSAT.exe by using this command. This command emulates how WinSAT runs during the OOBE process, and this command prevents WinSAT from fully running during the OOBE process. If you do not use this command, WinSAT fully runs as before.

    Note This command triggers WinSAT.exe to skip later runs by using the same command. Therefore, you can only run WinSAT.exe by using this command one time. Any later attempt to run WinSAT by using this command will do nothing.
  7. Seal or re-seal the image by using the Sysprep tool.
After you apply this hotfix, you see the following changes in behavior:
  • When you run the Sysprep to seal the image, the WinSAT data in the disk and in the registry is preserved and sealed into the image.
  • When a user experiences the OOBE process, WinSAT starts but then exits.

    Note During the OOBE process, the user momentarily sees the Windows Vista Setup screen that is titled Checking your System Performance. This screen is followed quickly by a black screen that appears when WinSAT exits. This brief screen flash is expected.

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Windows Vista or Windows Vista Service Pack 1 installed on the computer.

Restart requirement

You have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other previously released hotfixes.

Registry information

To use this hotfix, you do not have to make any changes to the registry.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

Windows Vista and Windows Server 2008 file information notes

  • The files that apply to a specific product, milestone (RTM, SPn) can be identified by examining the file version numbers as shown in the following table:
    Collapse this tableExpand this table
    VersionProductMilestoneService branch
    6.0.6000.20xxx Windows RTM LDR
    6.0.6001.22xxx Windows Vista SP1 and Windows Server 2008 SP1 SP1 LDR
  • Service Pack 1 is integrated into Windows Server 2008. Therefore, RTM milestone files apply only to Windows Vista. RTM milestone files have a 6.0.0000.xxxxxx version number.
  • The MANIFEST files (.manifest) and MUM files (.mum) installed for each environment are listed separately . MUM and MANIFEST files, and the associated security catalog (.cat) files, are critical to maintaining the state of the updated component. The security catalog files (attributes not listed) are signed with a Microsoft digital signature.
For all supported 32-bit versions of Windows Vista
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformService branch
Spwinsat.dll6.0.6000.2092211,77620-Sep-200803:51x86X86_MICROSOFT-WINDOWS-SYSPREP-SP
Spwinsat.dll6.0.6001.2227111,77620-Sep-200804:00x86X86_MICROSOFT-WINDOWS-SYSPREP-SP
For all supported 64-bit versions of Windows Vista
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformService branch
Spwinsat.dll6.0.6000.2092213,82420-Sep-200803:56x64AMD64_MICROSOFT-WINDOWS-SYSPREP-SP
Spwinsat.dll6.0.6001.2227114,33620-Sep-200804:19x64AMD64_MICROSOFT-WINDOWS-SYSPREP-SP
Spwinsat.dll6.0.6000.2092211,77620-Sep-200803:51x86X86_MICROSOFT-WINDOWS-SYSPREP-SP
Spwinsat.dll6.0.6001.2227111,77620-Sep-200804:00x86X86_MICROSOFT-WINDOWS-SYSPREP-SP

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

The WinSAT system assessment during OOBE affects the post-OOBE user experience in the following two ways:
  • During OOBE, WinSAT assesses the graphics hardware capabilities to determine whether the graphics hardware supports the Aero-glass feature. The results of this assessment determine whether the Aero-glass feature is automatically turned on at the desktop when OOBE is completed.
  • During OOBE, WinSAT calculates the Windows Experience Index scores for the new PC. The Windows Experience Index scores are viewable by the user and are also programmatically discoverable by applications that are running on the computer. Some applications and some features in Windows may change their behavior based on the value of the Windows Experience Index scores.
To make sure that running WinSAT in the factory will not affect the user's desktop experience, WinSAT should only be run on the exact target hardware for the image. In this manner, any data that is preserved in the PC image represents the PC accurately. Only then can the correct Aero-glass experience (on or off) and accurate Windows Experience Index scores be guaranteed on the new PC.

To view the Windows Experience Index score on your computer, Open Control Panel, click System And Maintenance, and then click Performance Information and Tools.

For more information about the Windows System Assessment Tool, visit the following Microsoft Web site:
http://msdn.microsoft.com/en-us/library/ms737395.aspx (http://msdn.microsoft.com/en-us/library/ms737395.aspx)
For more information about the Windows System Image Manager, visit the following Microsoft Web site:
http://technet.microsoft.com/en-us/library/cc722301.aspx (http://technet.microsoft.com/en-us/library/cc722301.aspx)
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/ ) Description of the standard terminology that is used to describe Microsoft software updates

Additional file information for Windows Vista

Additional files for all supported 32-bit versions of Windows Vista
Collapse this tableExpand this table
File namePackage_1_for_kb958011~31bf3856ad364e35~x86~~6.0.1.0.mum
File versionNot Applicable
File size1,772
Date (UTC)23-Sep-2008
Time (UTC)17:42
File namePackage_2_for_kb958011~31bf3856ad364e35~x86~~6.0.1.0.mum
File versionNot Applicable
File size1,772
Date (UTC)23-Sep-2008
Time (UTC)17:42
File namePackage_3_for_kb958011~31bf3856ad364e35~x86~~6.0.1.0.mum
File versionNot Applicable
File size1,772
Date (UTC)23-Sep-2008
Time (UTC)17:42
File namePackage_for_kb958011_client_0~31bf3856ad364e35~x86~~6.0.1.0.mum
File versionNot Applicable
File size1,408
Date (UTC)23-Sep-2008
Time (UTC)17:42
File namePackage_for_kb958011_client_1~31bf3856ad364e35~x86~~6.0.1.0.mum
File versionNot Applicable
File size1,352
Date (UTC)23-Sep-2008
Time (UTC)17:42
File namePackage_for_kb958011_client~31bf3856ad364e35~x86~~6.0.1.0.mum
File versionNot Applicable
File size1,711
Date (UTC)23-Sep-2008
Time (UTC)17:42
File namePackage_for_kb958011_server_0~31bf3856ad364e35~x86~~6.0.1.0.mum
File versionNot Applicable
File size1,408
Date (UTC)23-Sep-2008
Time (UTC)17:42
File namePackage_for_kb958011_server~31bf3856ad364e35~x86~~6.0.1.0.mum
File versionNot Applicable
File size1,430
Date (UTC)23-Sep-2008
Time (UTC)17:42
File nameX86_68f3f65d49aede8df69cc023f63b43be_31bf3856ad364e35_6.0.6000.20922_none_8283aa101ac8f0d5.manifest
File versionNot Applicable
File size704
Date (UTC)23-Sep-2008
Time (UTC)17:42
File nameX86_cc6354a0c60360771b2937f253c6afc1_31bf3856ad364e35_6.0.6001.22271_none_61772ef0b75db941.manifest
File versionNot Applicable
File size704
Date (UTC)23-Sep-2008
Time (UTC)17:42
File nameX86_microsoft-windows-sysprep-spwinsat_31bf3856ad364e35_6.0.6000.20922_none_51c443ae99882a1b.manifest
File versionNot Applicable
File size4,549
Date (UTC)20-Sep-2008
Time (UTC)04:18
File nameX86_microsoft-windows-sysprep-spwinsat_31bf3856ad364e35_6.0.6001.22271_none_5373708896d83043.manifest
File versionNot Applicable
File size4,865
Date (UTC)20-Sep-2008
Time (UTC)04:38
Additional files for all supported 64-bit versions of Windows Vista
Collapse this tableExpand this table
File nameAmd64_0fea0945abe6db4d165a3ed6a0448db3_31bf3856ad364e35_6.0.6001.22271_none_5a79abe7e9f2038d.manifest
File versionNot Applicable
File size1,056
Date (UTC)23-Sep-2008
Time (UTC)17:43
File nameAmd64_b3a57ef8a8b503cbda4a35afb034aa48_31bf3856ad364e35_6.0.6000.20922_none_1a70d2980ada8cdd.manifest
File versionNot Applicable
File size1,056
Date (UTC)23-Sep-2008
Time (UTC)17:43
File nameAmd64_microsoft-windows-sysprep-spwinsat_31bf3856ad364e35_6.0.6000.20922_none_ade2df3251e59b51.manifest
File versionNot Applicable
File size4,565
Date (UTC)20-Sep-2008
Time (UTC)04:29
File nameAmd64_microsoft-windows-sysprep-spwinsat_31bf3856ad364e35_6.0.6001.22271_none_af920c0c4f35a179.manifest
File versionNot Applicable
File size4,883
Date (UTC)20-Sep-2008
Time (UTC)04:52
File namePackage_1_for_kb958011~31bf3856ad364e35~amd64~~6.0.1.0.mum
File versionNot Applicable
File size2,004
Date (UTC)23-Sep-2008
Time (UTC)17:43
File namePackage_2_for_kb958011~31bf3856ad364e35~amd64~~6.0.1.0.mum
File versionNot Applicable
File size2,004
Date (UTC)23-Sep-2008
Time (UTC)17:43
File namePackage_3_for_kb958011~31bf3856ad364e35~amd64~~6.0.1.0.mum
File versionNot Applicable
File size2,004
Date (UTC)23-Sep-2008
Time (UTC)17:43
File namePackage_for_kb958011_client_0~31bf3856ad364e35~amd64~~6.0.1.0.mum
File versionNot Applicable
File size1,416
Date (UTC)23-Sep-2008
Time (UTC)17:43
File namePackage_for_kb958011_client_1~31bf3856ad364e35~amd64~~6.0.1.0.mum
File versionNot Applicable
File size1,360
Date (UTC)23-Sep-2008
Time (UTC)17:43
File namePackage_for_kb958011_client~31bf3856ad364e35~amd64~~6.0.1.0.mum
File versionNot Applicable
File size1,721
Date (UTC)23-Sep-2008
Time (UTC)17:43
File namePackage_for_kb958011_server_0~31bf3856ad364e35~amd64~~6.0.1.0.mum
File versionNot Applicable
File size1,416
Date (UTC)23-Sep-2008
Time (UTC)17:43
File namePackage_for_kb958011_server~31bf3856ad364e35~amd64~~6.0.1.0.mum
File versionNot Applicable
File size1,438
Date (UTC)23-Sep-2008
Time (UTC)17:43
File nameX86_microsoft-windows-sysprep-spwinsat_31bf3856ad364e35_6.0.6000.20922_none_51c443ae99882a1b.manifest
File versionNot Applicable
File size4,549
Date (UTC)20-Sep-2008
Time (UTC)04:18
File nameX86_microsoft-windows-sysprep-spwinsat_31bf3856ad364e35_6.0.6001.22271_none_5373708896d83043.manifest
File versionNot Applicable
File size4,865
Date (UTC)20-Sep-2008
Time (UTC)04:38

APPLIES TO
  • Windows Vista Enterprise 64-bit Edition
  • Windows Vista Home Basic 64-bit Edition
  • Windows Vista Home Premium 64-bit Edition
  • Windows Vista Ultimate 64-bit Edition
  • Windows Vista Business
  • Windows Vista Business 64-bit Edition
  • Windows Vista Enterprise
  • Windows Vista Home Premium
  • Windows Vista Ultimate
  • Windows Vista Home Basic
  • Windows Vista Service Pack 1
Keywords: 
kbautohotfix kbhotfixserver kbexpertiseadvanced kbfix kbqfe KB958011
 

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