O processo de fluxo de trabalho de actualização demora muito tempo quando actualiza o Microsoft Dynamics CRM 3.0 para Microsoft Dynamics CRM 4.0

Traduções de Artigos Traduções de Artigos
Artigo: 958039 - Ver produtos para os quais este artigo se aplica.
Expandir tudo | Reduzir tudo

Sintomas

Quando actualiza o Microsoft Dynamics CRM 3.0 para Microsoft Dynamics CRM 4.0, o processo de actualização demora muito tempo a concluir.

Causa

Este problema ocorre quando a tabela WFProcessInstance contém várias instâncias de fluxo de trabalho.

Resolução

Está disponível na Microsoft uma actualização de configuração. Quando instala o Microsoft Dynamics CRM 4.0, ou quando actualiza para o Microsoft Dynamics CRM 4.0, pode procurar actualizações do programa de configuração. Se seleccionar a opção para verificar a existência de actualizações do programa de configuração, a aplicação transfere novas actualizações o programa de configuração e aplica as actualizações do programa de configuração à instalação durante a execução do processo de configuração.

Informações de instalação

Para obter esta correcção, utilize a opção de ficheiros de instalação da actualização durante a configuração do Microsoft Dynamics CRM 4.0. Para obter mais informações sobre como utilizar a opção de actualização de ficheiros de instalação ou sobre como transferir manualmente a actualização do programa de configuração, clique no número de artigo que se segue para visualizar o artigo na base de dados de conhecimento da Microsoft:
948917Como obter as actualizações do programa de configuração para Microsoft Dynamics CRM 4.0

Pré-requisitos

Não existem pré-requisitos são necessários.

Informações de remoção

Não é possível remover a actualização de configuração.

Como contornar

Para contornar este problema, actualize a instalação do Microsoft Dynamics CRM 4.0 utilizando a funcionalidade de configuração do self-healing. Antes de executar a aplicação actualizar, alterar as teclas de registo seguinte no registo do servidor Microsoft Dynamics CRM 3.0.

Aviso Podem ocorrer problemas graves se modificar o registo incorrectamente utilizando o Editor de registo ou utilizando outro método. Estes problemas poderão forçar a reinstalação o sistema operativo. Microsoft não garante que estes problemas podem ser resolvidos. Modificar o registo por sua própria conta e risco.
  • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSCRM\WorkflowUpgradeThreadCount


    Defina o valor de REG_DWORD como 1.

    Notas
    • Pode introduzir qualquer número decimal maior ou igual a 1 deste movimento de registo.
    • O número máximo de threads sugerido deve ser calculado com base no número de processadores no servidor do Microsoft Dynamics CRM 3.0 vezes 2. Por exemplo, se o servidor do Microsoft Dynamics CRM tem dois processadores, o número máximo de threads deve ser 4.
  • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSCRM\WorkflowUpgradeTimeout


    Defina o valor REG_DWORD a 15.

    Notas
    • O valor desta entrada de registo representa o intervalo de tempo em minutos que um thread aguardará antes de actualizar o fluxo de trabalho.
    • Se o fluxo de trabalho demora mais tempo a actualizar que o valor especificado nesta entrada de registo, o fluxo de trabalho falhará e será processado o fluxo de trabalho seguinte.
    • Se o intervalo de tempo que definiu nesta entrada de registo é demasiado curto, muitos fluxos de trabalho não podem ser actualizados.
    • Se o valor no campo WorkflowUpgradeTimeout é demasiado longo, tempos limite ocorrerão mais frequentemente. O número de limites de tempo pode variar de acordo com os recursos que estão disponíveis no servidor do Microsoft Dynamics CRM. Estes recursos podem ser ciclos de RAM ou ciclos da CPU.

Ponto Da Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na secção "Aplica-se a".

Mais Informação

Para obter mais informações sobre a terminologia de actualizações de software, clique no número de artigo que se segue para visualizar o artigo na base de dados de conhecimento da Microsoft:
824684Descrição da terminologia padrão utilizada para descrever actualizações de software da Microsoft
Para obter mais informações sobre a terminologia de pacote de Microsoft Business Solutions CRM software correcção e actualização, clique no número de artigo que se segue para visualizar o artigo na base de dados de conhecimento da Microsoft:
887283Padrões de nomenclatura do pacote de correcção de software Microsoft Business Solutions CRM e actualização

Propriedades

Artigo: 958039 - Última revisão: 21 de janeiro de 2010 - Revisão: 1.0
A informação contida neste artigo aplica-se a:
  • Microsoft Dynamics CRM 4.0
  • Microsoft Dynamics CRM 3.0
Palavras-chave: 
kbmt kbmbsupgrade kbfix kbexpertiseinter kbautohotfix kbsurveynew kbmbsmigrate kbqfe kbhotfixserver KB958039 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática? erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 958039

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com