工作流程升级过程需要很长的时间时 Microsoft 动态 CRM 3.0 升级到动态 CRM 4.0

文章翻译 文章翻译
文章编号: 958039 - 查看本文应用于的产品
展开全部 | 关闭全部

症状

Microsoft 动态 CRM 3.0 升级到动态 CRM 4.0 时, 升级过程将花费很长时间才能完成。

原因

当 WFProcessInstance 表包含很多的工作流实例时,会出现此问题。

解决方案

Microsoft 提供了一个安装程序更新。当您安装 Microsoft 动态 CRM 4.0,或升级到动态 CRM 4.0 时,您可以检查安装程序更新。如果选择了检查安装程序更新选项,应用程序下载任何新的安装程序更新并安装更新应用到安装,而在安装过程正在运行。

安装信息

若要获取此修复程序,使用 $ 动态 CRM 4.0 安装过程中的更新安装文件选项。有关如何使用更新安装文件选项或如何手动下载安装程序更新,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:
948917如何为动态 CRM 4.0 获得安装更新

系统必备组件

需要任何先决条件不。

删除信息

安装程序更新不能将其删除。

替代方法

要变通解决此问题,请使用自我修复的安装功能来更新动态 CRM 4.0 安装。运行升级的应用程序之前更改 Microsoft 动态 CRM 3.0 服务器的注册表中以下注册表项。

警告如果您修改注册表错误地使用注册表编辑器或使用另一种方法,则可能会出现严重问题。这些问题可能需要重新安装操作系统。Microsoft 不能保证可以解决这些问题。修改注册表的风险由您自己承担。
  • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSCRM\WorkflowUpgradeThreadCount


    将 REG_DWORD 值设置为 1。

    备注
    • 此注册表项,您可以输入任何十进制的数大于或等于 1。
    • 建议的最大线程数应该基于时间 2 Microsoft 动态 CRM 3.0 服务器上的处理器数量进行计算。例如对于如果 Microsoft 动态 CRM 服务器中有两个处理器最大线程数应该是 4。
  • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSCRM\WorkflowUpgradeTimeout


    将 REG_DWORD 值设置为 15。

    备注
    • 此注册表项值表示一个线程将等待升级工作流之前,以分钟为单位的时间间隔。
    • 如果工作流所用的时间要比在该注册表项中指定的值升级,工作流就会失败,并且在下一个工作流将被处理。
    • 是否太短时间间隔在此注册表项中设置的许多工作流可能不能升级。
    • 太长 WorkflowUpgradeTimeout 字段中的值是否将更频繁地发生超时。超时的数量可能会随 Microsoft 动态 CRM 服务器上可用的资源。这些资源可以是 RAM 或 CPU 周期。

状态

Microsoft 已经确认这是在"适用于"一节中列出的 Microsoft 产品中的问题。

更多信息

有关软件更新术语的详细信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:
824684用于描述 Microsoft 软件更新的标准术语的说明
Microsoft 企业解决方案 CRM 软件修补程序和更新包术语有关的详细信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:
887283Microsoft 企业解决方案 CRM 软件修补程序和更新包的命名标准

属性

文章编号: 958039 - 最后修改: 2010年1月21日 - 修订: 1.0
这篇文章中的信息适用于:
  • Microsoft Dynamics CRM 4.0
  • Microsoft Dynamics CRM 3.0
关键字:?
kbmt kbmbsupgrade kbfix kbexpertiseinter kbautohotfix kbsurveynew kbmbsmigrate kbqfe kbhotfixserver KB958039 KbMtzh
机器翻译
注意:这篇文章是由无人工介入的微软自动的机器翻译软件翻译完成。微软很高兴能同时提供给您由人工翻译的和由机器翻译的文章, 以使您能使用您的语言访问所有的知识库文章。然而由机器翻译的文章并不总是完美的。它可能存在词汇,语法或文法的问题,就像是一个外国人在说中文时总是可能犯这样的错误。虽然我们经常升级机器翻译软件以提高翻译质量,但是我们不保证机器翻译的正确度,也不对由于内容的误译或者客户对它的错误使用所引起的任何直接的, 或间接的可能的问题负责。
点击这里察看该文章的英文版: 958039
Microsoft和/或其各供应商对于为任何目的而在本服务器上发布的文件及有关图形所含信息的适用性,不作任何声明。 所有该等文件及有关图形均"依样"提供,而不带任何性质的保证。Microsoft和/或其各供应商特此声明,对所有与该等信息有关的保证和条件不负任何责任,该等保证和条件包括关于适销性、符合特定用途、所有权和非侵权的所有默示保证和条件。在任何情况下,在由于使用或运行本服务器上的信息所引起的或与该等使用或运行有关的诉讼中,Microsoft和/或其各供应商就因丧失使用、数据或利润所导致的任何特别的、间接的、衍生性的损害或任何因使用而丧失所导致的之损害、数据或利润不负任何责任。

提供反馈

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com