Artikel-id: 958045 - Få vist de produkter, som denne artikel refererer til.
Udvid alle | Skjul alle

På denne side

Symptomer

Når du forsøger at installere opdateringer fra webstederne Windows Update eller Microsoft Update, modtager du følgende fejlkode:
0x800B0001

Årsag

Dette problem opstår, hvis Windows Update eller Microsoft Update fastslår, at den kryptografiske serviceudbyder er ukendt.

Løsning

Du kan løse dette problem ved at følge de trin, der er relevante for dit bestemte operativsystem.

Hvis du vil have os til at registrere dll-filerne for dig, skal du gå til afsnittet "Løs det for mig". Hvis du hellere vil løse problemet selv, skal du gå til afsnittet "Jeg vil selv løse problemet".

Løs det for mig



Du kan løse problemet automatisk ved at klikke på knappen eller linket Fix it. Klik på Kør i dialogboksen Filoverførsel, og følg derefter fremgangsmåden i guiden Løs det.


Løs dette problem
Microsoft Fix it 50691

Bemærk!
  • I Windows Vista og Windows Server 2008 udfører Fix it-løsningen kun Metode 2 for dig, så du skal stadig udføre Metode 1 manuelt.
  • Denne guide findes muligvis kun på engelsk. Den automatiske løsning fungerer dog også for andre sprogversioner af Windows.
  • Hvis du ikke arbejder på den computer, hvor problemet er opstået, kan du gemme løsningen på et flashdrev eller på en cd og derefter køre løsningen på den computer, der har problemet.

Gå derefter til afsnittet "Fik du løst problemet?".



Jeg vil selv løse problemet

I Windows XP, Windows Server 2003 og Windows 2000

Hvis du vil løse problemet, skal du registrere filerne Softpub.dll, Wintrust.dll, Initpki.dll og Mssip32.dll. Det kan du gøre ved at benytte følgende fremgangsmåde:
  1. Start Notesblok. Det gør du ved at klikke på Start og derefter klikke på Kør.
  2. Kopiér og indsæt derefter (eller skriv) følgende kommando i feltet Åbn, og tryk derefter på ENTER:
    Notesblok
  3. Kopiér og Indsæt derefter (eller skriv) følgende kommandolinjer i Notesblok:
    regsvr32 Softpub.dll /s
    regsvr32 Wintrust.dll /s
    regsvr32 Initpki.dll /s
    regsvr32 Mssip32.dll /s
  4. I menuen Filer skal du klikke på Gem som og derefter skrive Register.bat.
  5. Klik på Gem som type, og klik derefter på Alle filer.
  6. Gem filen Register.bat på skrivebordet.
  7. Dobbeltklik på filen Register.bat for at registrere Windows Update-filerne.
  8. Prøv at installere opdateringerne igen.
  9. Hvis problemet er løst, skal du slette filen Register.bat, som du oprettede i forrige trin.

I Windows Vista og Windows Server 2008

Metode 1: Kør værktøjet System Update Readiness (Checksur.exe)

  1. Hent og kør værktøjet System Update Readiness (Checksur.exe). Når du har hentet værktøjet, kører det en enkelt scanning for inkonsistens, der kan forhindre fremtidige servicehandlinger.

    Du kan finde flere oplysninger om, hvordan du henter og kører værktøjet System Update Readiness ved at klikke på nedenstående artikelnummer for at få vist artiklen i Microsoft Knowledge Base:
    947821 Beskrivelse af værktøjet System Update Readiness til Windows Vista og Windows Server 2008
    Bemærk!
    • Rul ned til afsnittet "Microsoft Download Center" i artikel 947821, og klik derefter på det tilknyttede link for at hente værktøjet System Update Readiness til dit operativsystem.
    • Når du har kørt værktøjet, gemmes filen Checksur.log på følgende placering:
      %systemroot%\Logs\CBS
      I en standardversion af Windows Vista er dette mappen C:\Windows\Logs\CBS.
  2. Når du har kørt værktøjet System Update Readiness, skal du prøve at installere opdateringerne igen.
Hvis disse trin ikke løser problemet, skal du gå til metode 2.

Metode 2: Registrer Wintrust.dll

  1. Klik på Start
    Skjul billedetUdvid billedet
    Knappen Start
    , og skriv derefter cmd i feltet Start søgning.
  2. Højreklik på cmd på resultatlisten, og klik derefter på Kør som administrator.
    Skjul billedetUdvid billedet
    Tilladelsen Brugerkontokontrol
    Hvis du bliver bedt om at angive en administratoradgangskode eller en bekræftelse, skal du skrive adgangskoden eller klikke på Fortsæt.
  3. I kommandoprompten skal du kopiere og derefter indsætte (eller skrive) følgende kommando.
    regsvr32 Wintrust.dll /s
  4. Luk vinduet Kommandoprompt.
  5. Prøv at installere opdateringerne igen.

Fik du løst problemet?

  • Undersøg, om problemet er blevet løst. Hvis problemet er løst, er du færdig med dette afsnit. Hvis problemet ikke er løst, kan du kontakte support.
  • Vi sætter pris på din feedback. Du kan give os feedback eller rapportere om problemer med denne løsning ved at oprette en kommentar på bloggen Løs det for mig eller sende os en e-mail.
Bemærk! Dette er en artikel til hurtig udgivelse, som er oprettet direkte i Microsofts supportafdeling. Oplysningerne i artiklen præsenteres som de og behandler aktuelle problemer. Fordi artiklen er blevet udgivet hurtigt, kan der forekomme slåfejl, og artiklen kan blive redigeret uden varsel. Se andre forbehold under Vilkår for anvendelse.

Egenskaber

Artikel-id: 958045 - Seneste redigering: 20. december 2011 - Redigering: 1.0
Oplysningerne i denne artikel gælder:
  • Microsoft Windows Update
  • Microsoft Update
Nøgleord: 
kbregistry kbupdateissue kberrmsg kbexpertisebeginner kbtshoot kbprb kbfixme kbmsifixme KB958045

Send feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com