Código de error al intentar utilizar Windows Update o Microsoft Update para instalar las actualizaciones: "0x800B0001"

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Síntomas

Al intentar instalar actualizaciones desde el sitio web de Windows Update o de Microsoft Update, aparece el siguiente código de error:
0x800B0001

Causa

Este problema se produce si Windows Update o Microsoft Update determina que el proveedor de servicios criptográficos es desconocido.

Solución

Para resolver este problema, siga los pasos que sean apropiados para su sistema operativo.

Para que podamos registrar los archivos dll en su lugar, vaya a la sección "Solucionarlo en mi lugar". Si prefiere solucionar este problema usted mismo, vaya a la sección "Solucionarlo por mí mismo".

Solucionarlo en mi lugar



Para solucionar el problema de forma automática, haga clic en el vínculo o en el botón Fix it. Haga clic en Ejecutar en el cuadro de diálogo Descarga de archivos y, a continuación, siga los pasos del Asistente de Fix it.


Solucionar este problema
Microsoft Fix it 50691

Notas
  • En Windows Vista y Windows Server 2008, la solución Fix it solo ejecuta el método 2 automáticamente, el método 1 deberá ejecutarlo manualmente.
  • Este asistente podría estar sólo en inglés. Sin embargo, la solución automática también funciona con otras versiones de idioma de Windows. 
  • Si no está utilizando el equipo que tiene el problema, puede guardar la solución Fix it en una unidad flash o en un CD para posteriormente ejecutarla en el equipo con el problema.

A continuación, vaya a la sección "¿Esta información le ha ayudado a resolver su problema?".



Solucionarlo por mí mismo

En Windows XP, Windows Server 2003 y Windows 2000

Para resolver este problema, debe registrar los archivos Softpub.dll, Wintrust.dll, Initpki.dll y Mssip32.dll. Para ello, siga estos pasos: 
  1. Inicie el Bloc de notas. Para ello, haga clic en Inicio y, a continuación, en Ejecutar.
  2. Copie y pegue (o escriba) el comando siguiente en el cuadro Abrir y presione Entrar:
    bloc de notas
  3. Copie y pegue (o escriba) las siguientes líneas de comandos en la ventana del Bloc de notas:
    regsvr32 Softpub.dll /s
    regsvr32 Wintrust.dll /s
    regsvr32 Initpki.dll /s
    regsvr32 Mssip32.dll /s
  4. En el menú Archivo, haga clic en Guardar como y, a continuación, escriba Register.bat.
  5. Haga clic en Guardar como tipo y, a continuación, en Todos los archivos.
  6. Guarde el archivo Register.bat en el escritorio.
  7. Haga doble clic en el archivo Register.bat para registrar los archivos de Windows Update.
  8. Intente instalar de nuevo las actualizaciones.
  9. Si el problema se resuelve, elimine el archivo Register.bat que creó en los pasos anteriores.

En Windows Vista y Windows Server 2008

Método 1: Ejecutar la herramienta System Update Readiness (Checksur.exe)

  1. Descargue y ejecute la herramienta System Update Readiness ((Checksur.exe). Después de descargar esta herramienta, se ejecuta un análisis único en busca de incoherencias que puedan impedir futuras operaciones de mantenimiento.

    Para obtener más información acerca de cómo descargar y ejecutar la herramienta System Update Readiness, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
    947821 Descripción de la herramienta System Update Readiness para Windows Vista y Windows Server 2008
    Notas
    • En el artículo 947821, desplácese a la sección "Centro de descarga de Microsoft" y, a continuación, haga clic en el vínculo asociado para descargar la herramienta System Update Readiness para su sistema operativo.
    • Después de ejecutar esta herramienta, el archivo Checksur.log se guardará en la siguiente ubicación:
      %systemroot%\Logs\CBS
      En una instalación predeterminada de Windows Vista, ésta es la carpeta C:\Windows\Logs\CBS.
  2. Después de que se ejecute la herramienta System Update Readiness, intente instalar las actualizaciones de nuevo.
Si estos pasos no resuelven el problema, vaya al método 2.

Método 2: Registrar el archivo Wintrust.dll

  1. Haga clic en Inicio
    Contraer esta imagenAmpliar esta imagen
    botón Inicio
    y escriba cmd en el cuadro Iniciar búsqueda.
  2. En la lista de resultados, haga clic con el botón secundario en cmd y, a continuación, haga clic en Ejecutar como administrador.
    Contraer esta imagenAmpliar esta imagen
    Permiso de Control de cuentas de usuario
    Si se le pide la contraseña del administrador o que confirme la acción, escriba la contraseña o haga clic en Continuar.
  3. En el símbolo del sistema, copie y pegue (o escriba) el siguiente comando.
    regsvr32 Wintrust.dll /s
  4. Cierre la ventana Símbolo del sistema.
  5. Intente instalar de nuevo las actualizaciones.

¿Esta información le ha ayudado a solucionar su problema?

  • Compruebe si se ha solucionado el problema. Si se ha solucionado, ya ha terminado con esta sección. En caso contrario, puede ponerse en contacto con el soporte técnico.
  • Valoramos sus comentarios. Para realizar algún comentario o informar de cualquier problema con esta solución, deje su comentario en el blog "Solucionarlo en mi lugar" o envíenos un correo electrónico.

Propiedades

Id. de artículo: 958045 - Última revisión: martes, 20 de diciembre de 2011 - Versión: 2.0
La información de este artículo se refiere a:
  • Microsoft Windows Update
  • Microsoft Update
Palabras clave: 
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