รหัสข้อผิดพลาดเมื่อคุณพยายามใช้ Windows Update หรือ Microsoft Update เพื่อติดตั้งโปรแกรมปรับปรุง: "0x800B0001"

การแปลบทความ การแปลบทความ
หมายเลขบทความ (Article ID): 958045 - ผลิตภัณฑ์ที่เกี่ยวข้องในบทความนี้
ขยายทั้งหมด | ยุบทั้งหมด

เนื้อหาบนหน้านี้

อาการ

เมื่อคุณพยายามติดตั้งโปรแกรมปรับปรุงจาก Windows Update หรือเว็บไซต์ Microsoft Update คุณได้รับรหัสข้อผิดพลาดต่อไปนี้:
0x800B0001

สาเหตุ

ปัญหานี้เกิดขึ้นหาก Windows Update หรือ Microsoft Update กำหนดว่าไม่รู้จักผู้ให้บริการการเข้ารหัสลับ

การแก้ไข

เมื่อต้องแก้ไขปัญหานี้ ให้ทำตามขั้นตอนที่เหมาะสมสำหรับระบบปฏิบัติการเฉพาะของคุณ

เมื่อต้องการให้เราลงทะเบียนแฟ้ม dll ให้คุณ ไปที่ส่วน "แก้ไขปัญหาให้ฉัน" ถ้าคุณต้องการแก้ไขปัญหานี้ด้วยตนเอง โปรดไปที่ส่วน "ให้ฉันแก้ไขปัญหาด้วยตนเอง"

แก้ไขปัญหาให้ฉัน



เมื่อต้องการแก้ไขปัญหานี้โดยอัตโนมัติ ให้คลิกที่ปุ่มหรือการเชื่อมโยง Fix it ในกล่องโต้ตอบ ดาวน์โหลดแฟ้ม คลิก เรียกใช้แล้วทำตามขั้นตอนต่างๆ ในตัวช่วยสร้าง Fix it


แก้ไขปัญหานี้
Microsoft Fix it 50691

หมายเหตุ
  • สำหรับ Windows Vista และ Windows Server 2008 โซลูชัน Fix it จะดำเนินการตามวิธีที่ 2 ให้คุณ คุณจึงยังคงต้องดำเนินการตามวิธีที่ 1 ด้วยตนเอง
  • ตัวช่วยสร้างนี้อาจมีเฉพาะภาษาอังกฤษ อย่างไรก็ตาม การแก้ไขอัตโนมัติจะทำงานกับ Windows รุ่นภาษาอื่นด้วย
  • ถ้าคุณไม่ได้ใช้งานคอมพิวเตอร์เครื่องที่มีปัญหา ให้บันทึกโซลูชัน Fix it ลงในแฟลชไดรฟ์หรือซีดี แล้วเรียกใช้บนคอมพิวเตอร์ที่มีปัญหา

จากนั้นไปที่ส่วน "วิธีนี้แก้ไขปัญหาได้หรือไม่"



ให้ฉันแก้ไขปัญหาด้วยตนเอง

ใน Windows XP ใน Windows Server 2003 และใน Windows 2000

เมื่อต้องการแก้ปัญหานี้ คุณต้องลงทะเบียนแฟ้ม Softpub.dll, Wintrust.dll, Initpki.dll และ Mssip32.dl โดยให้ทำตามขั้นตอนเหล่านี้:
  1. เริ่มต้น Notepad โดยคลิก เริ่ม จากนั้นคลิก เรียกใช้
  2. คัดลอกและวาง (หรือพิมพ์) คำสั่งต่อไปนี้ในกล่อง เปิด จากนั้นกด ENTER:
    แผ่นจดบันทึก
  3. คัดลอกและวาง (หรือพิมพ์) บรรทัดคำสั่งต่อไปนี้ลงในหน้าต่างแผ่นจดบันทึก:
    regsvr32 Softpub.dll /s
    regsvr32 Wintrust.dll /s
    regsvr32 Initpki.dll /s
    regsvr32 Mssip32.dll /s
  4. ในเมนู แฟ้ม คลิก บันทึกเป็น แล้วพิมพ์ Register.bat
  5. คลิก บันทึกเป็นชนิด แล้วคลิก แฟ้มทั้งหมด
  6. บันทึกแฟ้ม Register.bat ไว้ในเดสก์ท็อปของคุณ
  7. คลิกสองครั้งที่แฟ้ม Register.bat เพื่อลงทะเบียนแฟ้ม Windows Update
  8. ลองติดตั้งโปรแกรมปรับปรุงอีกครั้ง
  9. ถ้าแก้ปัญหาได้แล้ว ให้ลบแฟ้ม Register.bat ที่คุณสร้างในขั้นตอนก่อนหน้านี้

ใน Windows Vista และใน Windows Server 2008

วิธีที่ 1: เรียกใช้เครื่องมือการตรวจหาความพร้อมในการปรับปรุงระบบ (Checksur.exe)

  1. ดาวน์โหลดและเรียกใช้เครื่องมือการตรวจหาความพร้อมในการปรับปรุงระบบ (Checksur.exe) หลังจากที่คุณดาวน์โหลดเครื่องมือนี้ จะมีการเรียกใช้การสแกนแบบครั้งเดียวเพื่อหาความไม่สอดคล้องกันซึ่งอาจป้องกันการให้บริการในอนาคต

    หากต้องการข้อมูลเพิ่มเติมเกี่ยวกับวิธีการดาวน์โหลดและเรียกใช้เครื่องมือการตรวจหาความพร้อมในการปรับปรุงระบบ ให้คลิกที่หมายเลขบทความต่อไปนี้เพื่อดูบทความใน Microsoft Knowledge Base:
    947821 รายละเอียดของเครื่องมือการตรวจหาความพร้อมในการปรับปรุงระบบสำหรับ Windows Vista และ Windows Server 2008
    หมายเหตุ
    • ในบทความ 947821 เลื่อนลงไปที่ส่วน "ศูนย์ดาวน์โหลด Microsoft" จากนั้น คลิกการเชื่อมโยงที่เกี่ยวข้องเพื่อดาวน์โหลดเครื่องมือการตรวจหาความพร้อมในการปรับปรุงระบบสำหรับระบบปฏิบัติการของคุณ
    • หลังจากที่คุณเรียกใช้เครื่องมือนี้ จะมีการบันทึกแฟ้ม Checksur.log ลงในตำแหน่งต่อไปนี้:
      %systemroot%\Logs\CBS
      ในการติดตั้งเริ่มต้นของ Windows Vista, จะเป็นโฟลเดอร์ C:\Windows\Logs\CBS
  2. หลังจากเครื่องมือการตรวจหาความพร้อมในการปรับปรุงระบบเรียกใช้ ให้พยายามติดตั้งโปรแกรมปรับปรุงอีกครั้ง
ถ้าขั้นตอนเหล่านี้แก้ปัญหาไม่ได้ ไปที่วิธีที่ 2

วิธีที่ 2: ลงทะเบียน Wintrust.dll

  1. คลิกปุ่ม เริ่ม
    ยุบรูปภาพนี้ขยายรูปภาพนี้
     ปุ่มเริ่ม
    แล้วพิมพ์ cmd ในกล่อง เริ่มค้นหา
  2. ในรายการผลลัพธ์ คลิกขวาที่ cmd แล้วคลิก เรียกใช้ในฐานะผู้ดูแล
    ยุบรูปภาพนี้ขยายรูปภาพนี้
    สิทธิการควบคุมบัญชีผู้ใช้
    ถ้าคุณได้รับพร้อมท์ให้ระบุรหัสผ่านของผู้ดูแลระบบหรือให้ยืนยัน ให้พิมพ์รหัสผ่าน หรือคลิก ดำเนินการต่อ
  3. ที่พร้อมท์คำสั่ง ให้คัดลอกและวาง (หรือพิมพ์) คำสั่งต่อไปนี้
    regsvr32 Wintrust.dll /s
  4. ปิดหน้าต่าง พร้อมท์คำสั่ง
  5. ลองติดตั้งโปรแกรมปรับปรุงอีกครั้ง

วิธีนี้แก้ไขปัญหาได้หรือไม่

  • ตรวจสอบว่าปัญหาได้รับการแก้ไขแล้วหรือไม่ หากปัญหาได้รับการแก้ไข แสดงว่าคุณสิ้นสุดขั้นตอนในส่วนนี้แล้ว ถ้าปัญหาไม่ได้รับการแก้ไข คุณสามารถ ติดต่อฝ่ายสนับสนุน
  • เรายินดีรับคำติชมของคุณ หากต้องการส่งคำติชมหรือรายงานปัญหาใดๆ เกี่ยวกับการแก้ไขนี้ คุณสามารถฝากความคิดเห็นไว้ในบล็อก "แก้ไขปัญหาให้ฉัน" หรือส่ง อีเมล ถึงเรา

คุณสมบัติ

หมายเลขบทความ (Article ID): 958045 - รีวิวครั้งสุดท้าย: 20 ธันวาคม 2554 - Revision: 6.0
ใช้กับ
  • Microsoft Windows Update
  • Microsoft Update
Keywords: 
kbregistry kbupdateissue kberrmsg kbexpertisebeginner kbtshoot kbprb kbfixme kbmsifixme KB958045

ให้ข้อเสนอแนะ

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com