Kód chyby pri používaní lokality Windows Update alebo Microsoft Update Web na inštaláciu aktualizácií: "0x8007066A"

Preklady článku Preklady článku
ID článku: 958049 - Zobraziť produkty, ktorých sa tento článok týka.
Rozbaliť všetko | Zbaliť všetko

Na tejto stránke

PRIZNAKY

Pri pokuse o inštaláciu aktualizácií z lokality Windows Update alebo Microsoft Update Web, dostanete nasledujúcim kódom chyby:
0x8007066A

Dôle ité:
ak sa pri inštalácii zobrazí chyba 0x8007066A.Čistý rámec aktualizácie vyskúšajte kroky uvedené v nasledujúcom článku KB pred nasledujúcich krokov vyriešiť váš problém:
2507641 Chybový kód "0x8007066A" pri použití lokality Windows Update alebo Microsoft Update Web na inštaláciu.NET Framework aktualizácie

PRICINA

Tento problém sa vyskytuje, ak služba Windows Update alebo Microsoft Update určí, že sú otázky, ktoré zahŕňajú inštaláciu predpoklady.

RIESENIE

Ak chcete vyriešiť tento problém, použite nasledujúce metódy. Spustiť pomocou metódy 1. Ak metóda 1 problém nevyriešil, prejdite na metódu 2.

Metóda 1: Stiahnite a nainštalujte aktualizácie manuálne

Ak chcete manuálne prevziať a nainštalovať aktualizácie, postupujte nasledovne:
  1. Navštívte nasledujúce webovú lokalitu Microsoft Update:
    http://Update.Microsoft.com
  2. Kliknite na tlačidlo Preskúmanie históriu aktualizované Ak chcete zobraziť históriu aktualizácií a preskúmať chybové hlásenie na určenie na aktualizáciu, ktorú chcete nainštalovať.
  3. Navštívte nasledovnú webovú lokalitu spoločnosti Microsoft:
    http://www.Microsoft.com/windows/downloads/default.aspx
  4. Zadajte číslo článku databázy Knowledge Base (KB) v okne Prehľadať Na stiahnutie stránku a potom kliknite na tlačidlo PREJSŤ.

    Napríklad, ak je číslo článku KB, ktorá je v zozname pre aktualizáciu KB123456, zadajte 123456 do vyhľadávacieho poľa a potom kliknite na tlačidlo PREJSŤ.
  5. V Výsledky vyhľadávania zoznam, vyhľadajte KB článok, ktorý ste hľadali a potom prejdite na tomto článku.
  6. Vyhľadávať pomocou článku databázy KB a potom kliknúť na prepojenie, ktoré sa podobá nasledujúcemu hláseniu:
    Prevziať balík
    Poznámka Ak sa zobrazí výzva na "potvrdiť Windows", postupujte podľa pokynov na overovanie systému Windows a potom pokračovať v preberaní.
  7. Kliknite na tlačidlo Stiahnuť, a potom kliknite na tlačidlo Uložiť v Prevzatie súboru dialógové okno.
  8. V Uložiť do kliknite na položku Zoznam Pracovná plocha, a potom kliknite na tlačidlo Uložiť.
  9. Na pracovnej ploche, vyhľadajte súbor, ktorý ste prevzali, a potom dvakrát kliknite na súbor, ktorý chcete nainštalovať aktualizáciu.

    Poznámka Ak je aktualizácia nevhodné pre váš počítač, inštalácia aktualizácie stále môže zlyhať.

Metóda 2: Zapnúť zapisovanie do denníka programu Microsoft Installer, a potom kontaktovať technickej podpory spoločnosti Microsoft

Ak metóda 1 nepodarí vyriešiť problém, by mal kontaktovať technickej podpory spoločnosti Microsoft pre pomoc. Chcete ušetriť čas pri riešení problému, môžete zapnúť a generovať denník Inštalátora Microsoft predtým, ako budete kontaktovať technickú podporu spoločnosti Microsoft. Povoliť zapisovanie do denníka programu Microsoft Installer a vytvoriť súbor denníka, postupujte nasledovne:

Pre počítače so systémom Windows 2000, Windows XP alebo Windows Server 2003

  1. Kliknite na tlačidlo Štart, kliknite na tlačidlo Spustiť, typu Poznámkový blok, a potom kliknite na tlačidlo ok.
  2. Zadajte príkazové riadky do okno programu Poznámkový blok:
    Windows Registry Editor Version 5.00
    
    [HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\Installer]
    "Logging"=dword:voicewarmupx
    "Debug"=dword:00000007
    
  3. Na Súbor v ponuke kliknite na položku Uložiť ako.
  4. Vyberte Pracovná plocha možnosť od Uložiť do kvapka-down list.
  5. Typ LoggingOn.reg v Názov súboru Začiarknite Všetky súbory možnosť od Typ súboru kvapka-down list, a potom kliknite na tlačidlo Uložiť.
  6. Na pracovnej ploche dvakrát kliknite na ikonu LoggingOn.reg súbor na pridanie registračných kľúčov do databázy registry systému Windows
  7. Kliknite na tlačidlo ok v dialógovom okne Úspešná inštalácia.
  8. Skúste nainštalovať aktualizáciu opäť zachytiť ďalšie informácie o chybách v súbore .log Microsoft Installer.
Poznámka Zber tieto denníky môže trvať niekoľko minút a proces aktualizácie môže zdať nemuseli fungovať správne, prosím vezmite potrebný čas na dokončenie procesu.

Dôležité Ako skoro ako Windows Update alebo Microsoft Update dokončil, by ste mali vypnúť Microsoft Installer zapisovania do denníka, opúšťa zapnuté zapisovanie môže vyžadovať príliš veľa času zakaždým že Inštalovať aktualizácie, môže spomaliť prácu počítača a vytvoriť veľkú log súbory, ktoré vyžadujú veľké množstvo miesta na disku.

Ak chcete vypnúť zapisovanie Microsoft Installer, postupujte nasledovne:
  1. Kliknite na tlačidlo Štart, kliknite na tlačidlo Spustiť, typu Poznámkový blok, a potom kliknite na tlačidlo ok.
  2. Zadajte príkazové riadky do otvoril okno programu Poznámkový blok:
    Windows Registry Editor Version 5.00
    
    [HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\Installer]
    "Logging"=-
    "Debug"=-
  3. Na Súbor v ponuke kliknite na položku Uložiť ako.
  4. V Uložiť do kliknite na položku Zoznam Pracovná plocha.
  5. V Názov súboru zadajte LoggingOn.reg, kliknite na tlačidlo Všetky súbory v Typ súboru zoznam a potom kliknite na tlačidlo Uložiť.
  6. Na pracovnej ploche dvakrát kliknite na ikonu LoggingOn.reg súbor odstrániť hodnoty databázy registry z databázy registry systému Windows.
  7. Keď sa zobrazí výzva s informáciami, ktoré úspešnom vykonaní operácie, kliknite na tlačidlo ok.
  8. Odstrániť súbory LoggingOn.reg a LoggingOff.reg z skúsenosti s prácou s počítačom.
Kontaktovať technickú podporu spoločnosti Microsoft pomoc a odkaz tento článok KB, keď rozprávate podporné činidlo. Ďalšie informácie o možnostiach kontaktovania technickej podpory spoločnosti Microsoft, navštívte nasledovnú webovú lokalitu spoločnosti Microsoft:
http://support.Microsoft.com/contactus/?ws=support

Pre počítače so systémom Windows Vista a Windows Server 2008

  1. Kliknite na tlačidlo Štart
    Zbaliť tento obrázokRozbaliť tento obrázok
    tlačidlo Štart
    , a potom zadajte Poznámkový blok v Začať vyhľadávanie pole.
  2. V Programy kliknite na položku Zoznam Poznámkový blok.
  3. Zadajte príkazové riadky do okno programu Poznámkový blok:
    Windows Registry Editor Version 5.00
    
    [HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\Installer]
    "Logging"=dword:voicewarmupx
    "Debug"=dword:00000007
  4. Na Súbor v ponuke kliknite na položku Uložiť ako.
  5. V Uložiť do kliknite na položku Zoznam Pracovná plocha.
  6. V Názov súboru zadajte LoggingOn.reg, kliknite na tlačidlo Všetky súbory v Typ súboru zoznam a potom kliknite na tlačidlo Uložiť.
  7. Na pracovnej ploche dvakrát kliknite na súbor LoggingOn.reg na pridanie hodnoty databázy registry do databázy registry systému Windows.

    Zbaliť tento obrázokRozbaliť tento obrázok
    Užívateľ Access Control povolenie
    Ak sa zobrazí výzva na zadanie hesla správcu alebo na potvrdenie, zadajte svoje heslo alebo kliknite na Pokračovať v.
  8. V dialógovom okne potvrdenie kliknite na tlačidlo áno, a potom kliknite na tlačidlo ok.
  9. Skúste nainštalovať aktualizáciu opäť zachytiť ďalšie informácie o chybách v súbore .log Microsoft Installer.
Poznámka Zber tieto denníky môže trvať niekoľko minút a proces aktualizácie môže zdať nemuseli fungovať správne. Venujte prosím čas nevyhnutný na proces dokončiť.

Dôležité Čo najskôr po ukončení služby Windows Update alebo Microsoft Update proces vypnúť zapisovanie Microsoft Installer. Ak ponecháte zapnuté zapisovanie, to spomaliť počítač a vytvoriť veľké súborov denníka, ktoré vyžadujú veľké množstvo miesta na disku vždy Inštalovať aktualizácie.

Ak chcete vypnúť zapisovanie Microsoft Installer, postupujte nasledovne:
  1. Kliknite na tlačidlo Štart
    Zbaliť tento obrázokRozbaliť tento obrázok
    tlačidlo Štart
    , a potom zadajte Poznámkový blok v Začať vyhľadávanie pole.
  2. V Programy kliknite na položku Zoznam Poznámkový blok.
  3. Zadajte príkazové riadky do okno programu Poznámkový blok:
    Windows Registry Editor Version 5.00
    
    [HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\Installer]
    "Logging"=-
    "Debug"=-
  4. Na Súbor v ponuke kliknite na položku Uložiť ako.
  5. V Uložiť do kliknite na položku Zoznam Pracovná plocha.
  6. V Názov súboru zadajte LoggingOff.reg, kliknite na tlačidlo Všetky súbory v Typ súboru zoznam a potom kliknite na tlačidlo Uložiť.
  7. Na pracovnej ploche dvakrát kliknite na súbor LoggingOff.reg na odstránenie hodnoty databázy registry z databázy registry systému Windows.

    Zbaliť tento obrázokRozbaliť tento obrázok
    Užívateľ Access Control povolenie
    Ak sa zobrazí výzva na zadanie hesla správcu alebo na potvrdenie, zadajte svoje heslo alebo kliknite na Pokračovať v.
  8. V dialógovom okne potvrdenie kliknite na tlačidlo áno, a potom kliknite na tlačidlo ok.
  9. Odstrániť súbory LoggingOn.reg a LoggingOff.reg z skúsenosti s prácou s počítačom.
Kontaktovať technickú podporu spoločnosti Microsoft pomoc a odkaz tento článok KB, keď rozprávate podporné činidlo. Ďalšie informácie o možnostiach kontaktovania technickej podpory spoločnosti Microsoft, navštívte nasledovnú webovú lokalitu spoločnosti Microsoft:
http://support.Microsoft.com/contactus/?ws=support

DALSIE INFORMACIE

Microsoft Installer súbor denníka začína "msi," zvyčajne končí príponou ".log" a má skupina znakov medzi. Napríklad program Microsoft Installer denník má názov súboru, ktorý sa podobá nasledujúcemu hláseniu:
msib3a6g.log
Tento súbor možno nájsť v nasledujúcich umiestneniach.

Na počítačoch so systémom Windows 2000, Windows XP alebo Windows Server 2003

Denník Inštalátora je umiestnený v adresári nasledovné:
C:\Documents and Settings\ {UserName} \Local Settings\Temp
Ak chcete otvoriť adresár, kliknite na tlačidlo Štart, kliknite na tlačidlo Spustiť, typu reťazec % temp %, a potom kliknite na tlačidlo ok.

Poznámka Táto informácia sa predpokladá nainštalovaný systém Windows v predvolenom priečinku jednotky C. Ak to tak nie je, revidovať písmeno jednotky priradiť písmeno jednotky jednotke inštalácie.

Na počítačoch so systémom Windows Vista alebo Windows Server 2008

Denník Inštalátora je umiestnený v adresári nasledovné:
C:\Users\{UserName\AppData\Local\Temp
Ak chcete otvoriť adresár, kliknite na tlačidlo Štart
Zbaliť tento obrázokRozbaliť tento obrázok
tlačidlo Štart
, typu reťazec % temp % v Začať vyhľadávanie políčko a potom stlačte kláves ENTER.

Poznámka Táto informácia sa predpokladá nainštalovaný systém Windows v predvolenom priečinku jednotky C. Ak to tak nie je, revidovať písmeno jednotky priradiť písmeno jednotky jednotke inštalácie.

ODKAZY

Ďalšie informácie o povolení zapisovania do denníka programu Microsoft Installer nájdete po kliknutí na nasledovné číslo článku databázy Microsoft Knowledge Base:
314852Na zapnutie zapisovania do denníka v systéme Windows XP služba Inštalátor systému Windows

Vlastnosti

ID článku: 958049 - Posledná kontrola: 17. apríla 2012 - Revízia: 1.0
Informácie v tomto článku sa týkajú nasledujúcich produktov:
  • Microsoft Update
  • Microsoft Windows Update
Kľúčové slová: 
kbpubtypekc kbtshoot kbprb kbmt KB958049 KbMtsk
Strojovo preložené
DÔLEŽITÉ: Tento článok bol preložený pomocou softvéru na strojový preklad od spoločnosti Microsoft, nie prekladateľom. Spoločnosť Microsoft ponúka články preložené prekladateľmi aj strojovo preložené články, vďaka čomu máte možnosť prístupu ku všetkým článkom databázy Knowledge Base vo svojom jazyku. Strojovo preložený článok však nie je vždy perfektný. Môže obsahovať chyby týkajúce sa slovnej zásoby, syntaxe alebo gramatiky, podobne ako cudzinec môže robiť chyby, keď rozpráva vašim jazykom. Spoločnosť Microsoft nenesie zodpovednosť za akékoľvek nepresnosti, chyby alebo škody spôsobené akýmkoľvek nepresným prekladom obsahu alebo jeho použitím zo strany zákazníkov. Spoločnosť Microsoft softvér na strojový preklad pravidelne aktualizuje.
Pokiaľ chcete vidieť anglickú verziu článku, kliknite sem:958049

Odošlite odozvu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com