Windows Update Web サイトまたは Microsoft Update Web サイトから更新プログラムをインストールしようとすると、"0x8007F0F4"エラー コードが表示されます可能性があります。

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文書番号: 958051 - 対象製品
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現象

Windows Update Web サイトまたは Microsoft Update Web サイトから更新プログラムをインストールしようとすると、次のエラー コードが表示されます。
0x8007F0F4

原因

この問題は、次のいずれかのコンピューター上に存在する場合に発生します。
  • ラップトップがバッテリ電源で実行されている場合を更新しようとしています。
  • 更新プログラムのインストール プログラムは、更新プログラムがコンピューターに正しくないことを検出します。
  • 前提条件となる更新プログラムがコンピューターにインストールされていません。

解決方法

この問題を解決するには、次の方法を使用して、自分のシナリオに適用。

メモセキュリティ更新プログラム 2686509 をインストールしようとすると 0x8007F0F4 のエラー メッセージが表示されます。この問題をトラブルシューティングする方法の詳細については、マイクロソフト サポート技術資料を参照する次の資料番号をクリックします。
2686509 MS12-034: 説明 CVE-2012年-0181 Windows XP および Windows Server 2003 用セキュリティ更新プログラム: 2012 8

方法 1: ラップトップを AC 電源に接続します。

現在ポータブル コンピューターのバッテリ電源で実行中の更新しようとしている場合は、一時的にポータブル コンピューターを AC 電源装置には、接続して、更新プログラムを再インストールしてください。

方法 2: 不適切な更新プログラムを非表示に

更新プログラムのインストールのアプリケーション、更新プログラムがコンピューターに正しくないことを検出する場合は、次の条件のいずれかのあります。
  • この更新プログラムは既にインストールされている場合があります。
  • この更新プログラムは、現在インストールされている更新プログラムよりも古いです。
  • コンピューターに互換性のある更新プログラムです。
この更新プログラムを無視か、Windows Update または Microsoft Update のインターフェイスで非表示にします。

再度に提供されていないために、更新プログラムを非表示にするには、次の手順を実行します。
  1. 次の Microsoft Update Web サイトを参照します。
    http://update.microsoft.com
  2. 更新のスキャンが完了するとすぐをクリックします。 ユーザー設定 で、 Microsoft Update へようこそ ページします。
  3. ナビゲーション ウィンドウをクリックします。 (ハードウェア).利用可能な更新の一覧に表示されます、 ハードウェアの更新オプションを選択します。 ページします。
  4. エラーに関連付けられているハードウェアのドライバーを検索、更新プログラムの詳細を展開するには、更新プログラムの名前をクリックしを有効にする] をクリックして、 この更新プログラムを表示しません。 チェック ボックス。
  5. クリックしてください。 確認し、更新プログラムをインストールします。.
  6. 非表示の更新、ハードウェアがないことを確認し、クリックしてください 更新プログラムをインストールします。.

方法 3: をダウンロードして更新プログラムを手動でインストールします。

ダウンロードして更新プログラムを手動でインストールするには、次の手順を実行します。
  1. 次の Microsoft Update Web サイトを参照します。
    http://update.microsoft.com
  2. クリックしてください。 更新履歴を確認します。 更新の履歴を表示または、手動でインストールする更新プログラムを確認するエラー メッセージを確認します。
  3. 次の Windows のダウンロード Web サイトを参照してください。
    http://www.microsoft.com/windows/downloads/default.aspx
  4. 技術情報の記事番号検索ウィンドウでを入力、 ダウンロード ページをクリックし. 移動.

    用の更新プログラムが表示されている文書番号が KB123456 の場合をたとえば、入力します。 123456 検索ボックス、およびクリックで 移動.
  5. 返されるコンテンツのリストをブラウズし、ダウンロードへのリンクを持つ、サポート情報記事を検索します。
  6. サポート情報記事を検索し、次のようなリンクをクリックします。
    パッケージを今すぐダウンロードします。
    メモWindows を検証する場合は、Windows の検証には、指示に従ってし、更新プログラムのダウンロードを続行します。
  7. クリックしてください。 ダウンロードプロパティ 保存 続いて [ ダイアログ ボックス。
  8. から、 保存先します。 リストの選択、 デスクトップ オプションをクリックし. 保存.
  9. デスクトップにダウンロードしたファイルを検索し、更新プログラムのインストール ファイルをダブルクリックします。
メモ更新プログラムがコンピューターに正しくない場合は、更新プログラムのインストールが失敗します。

方法 4: 既存のログ ファイルは、失敗した更新プログラムの確認します。

1、2、または 3 の方法でこの問題が解決しない場合は、ログ ファイルを使用して詳細情報を収集する必要があります。Microsoft インストーラーのログ ファイルをいくつかの更新プログラムを作成し、そのログ ファイルは Windows ディレクトリになります。このファイルが存在する場合は、マイクロソフトのサポート担当者が問題の原因を特定するには、そのファイルを表示できます。.Log ファイルが存在しない場合は、方法 5 サポート エージェントの .log ファイルを作成する手順を示します。

失敗した更新の中に作成された .log ファイルを確認するには、次の手順を実行します。
  1. クリックしてください。 スタート, すべてのプログラムプロパティ Windows Update または Microsoft Update.
  2. Windows Update または Microsoft Update Web サイトをクリックします。 更新履歴を表示します。.
  3. で、 ステータス 列で、失敗した更新プログラムを検索して更新プログラムに関連付けられているサポート技術情報文書番号に注意してください。

    メモ関連付けられているサポート情報の記事がない場合は、失敗した更新、方法 5 を試してください。
  4. Windows Update または Microsoft Update のウィンドウを閉じます。
  5. クリックしてください。 スタート[ Exchange Server 2010 SP1 をインストールした後 Outlook クライアント アプリケーションがパブリック フォルダーに接続できない] されます。プロパティ ].
  6. 技術は、手順 3 でメモした、失敗した更新後という名前の .log ファイルを見つけます。たとえば、KB123456 に関連付けられている、失敗した更新を 123456.log という名前の .log ファイルを探します。
  7. .Log ファイルが存在する場合は、マイクロソフト サポートにお問い合わせください、サポート エージェントに話すとき、サポート技術情報の文書番号を参照します。マイクロソフトのサポートへの問い合わせ方法の詳細については、次のマイクロソフト Web サイトを参照してください。
    http://support.microsoft.com/contactus/?ws=support
  8. .Log ファイルが存在しない場合は、方法 5 を試してください。

方法 5: Microsoft インストーラーのログを有効にして、サポートにお問い合わせください。

重要このセクション、方法、またはタスクには、レジストリの変更方法が記載されています。レジストリを誤って変更すると、深刻な問題が発生することがあります。そのため、この手順を慎重に実行するようにしてください。万一に備えて、編集の前にレジストリをバックアップしてください。問題が発生した場合でも、レジストリを復元できます。レジストリをバックアップおよび復元する方法の詳細については、以下のサポート技術情報番号をクリックしてください。
322756 Windows でレジストリをバックアップおよび復元する方法
前の方法で問題が解決しない場合は、マイクロソフト サポートに連絡する必要があります。時間を節約するには、有効にして、マイクロソフト サポートに問い合わせる前に、Microsoft インストーラーのログを生成できます。Microsoft インストーラーのログを有効にしてログ ファイルを生成するには、次の手順を実行します。
  1. クリックしてください。 スタート[ Exchange Server 2010 SP1 をインストールした後 Outlook クライアント アプリケーションがパブリック フォルダーに接続できない] メモ帳プロパティ ].
  2. メモ帳で次のコマンドを入力します。
    Windows Registry Editor Version 5.00
    
    [HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\Installer]
    "Logging"=dword:voicewarmupx
    "Debug"=dword:00000007
    
  3. で、 ファイル メモ帳で、メニューをクリックします。 として保存します。.
  4. 詳細 デスクトップ オプションを 保存先します。 リスト。
  5. で、 ファイル名 ボックス型 LoggingOn.regを選択、 すべてのファイル オプションの ファイルの種類します。 リストをクリックし. 保存.
  6. デスクトップをダブルクリック、 LoggingOn.reg ファイルを Windows レジストリにレジストリ キーを追加します。
  7. インストールが成功したことを示すダイアログ ボックスが表示されたらをクリックします。 ].
  8. Microsoft インストーラーの .log ファイルでのエラー情報を取得するのには、更新プログラムを再インストールしようとしてください。
メモログの情報を収集するまでに数分かかることがあり、更新処理が正しく機能しないこともあります。プロセスが終了するまで待機することを確認してください。

重要Windows Update または Microsoft Update が終了すると、Microsoft インストーラーのログを無効にします。有効のままを記録する場合、更新プログラムのインストールに長い時間がかかることがあります、コンピューター可能性があります低下しログ ・ ファイル、大量のディスク領域を作成することがあります必要とします。

Microsoft インストーラーのログを無効にするには、次の手順を実行します。
  1. クリックしてください。 スタート[ Exchange Server 2010 SP1 をインストールした後 Outlook クライアント アプリケーションがパブリック フォルダーに接続できない] メモ帳プロパティ ].
  2. メモ帳で次のコマンドを入力します。
    Windows Registry Editor Version 5.00
    
    [HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\Installer]
    "Logging"=-
    "Debug"=-
    
  3. で、 ファイル メモ帳で、メニューをクリックします。 として保存します。.
  4. で、 保存先します。 リストの選択、 デスクトップ オプションです。
  5. 種類 LoggingOff.reg 続いて ファイル名 ボックスを選択、 すべてのファイル オプションを ファイルの種類します。 リストをクリックし. 保存.
  6. デスクトップをダブルクリック、 LoggingOff.reg ファイルが Windows レジストリにレジストリ値を削除します。
  7. インストールが成功したことを示すダイアログ ボックスが表示されたらをクリックします。 ].
  8. LoggingOn.reg と LoggingOff.reg ファイルをデスクトップから削除します。
ヘルプについては、お問い合わせ、サポート エージェントに話したとき、この資料を参照します。

詳細

Microsoft インストーラーのログは、通常"msi"で始まり、".log"の拡張子を。たとえば、Microsoft インストーラーのログ ファイルは次のような名前があります。
msib3a6g.log
このファイルは、次のディレクトリにあります。
C:\Documents および Settings\ユーザー名\Local Settings\Temp\
このディレクトリを開きます. スタート[ Exchange Server 2010 SP1 をインストールした後 Outlook クライアント アプリケーションがパブリック フォルダーに接続できない] %temp%プロパティ ].

メモ情報はこの Windows が C ドライブにインストールされていることを想定しています。Windows が C ドライブにインストールされていない場合はインストール ドライブに一致するフォルダーのパスのドライブ文字を調整します。

関連情報

Microsoft インストーラーのログを有効にする方法の詳細については、マイクロソフト サポート技術資料を参照する次の資料番号をクリックします。
314852Windows インストーラーが Windows XP でのログ記録を有効にする方法

プロパティ

文書番号: 958051 - 最終更新日: 2012年11月29日 - リビジョン: 5.0
この資料は以下の製品について記述したものです。
  • Microsoft Update
  • Microsoft Windows Update
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Server 2003, Datacenter Edition for Itanium-Based Systems
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows 2000 Professional
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Server
キーワード:?
kbtshoot kbPubTypeKC kberrmsg kbprb kbmt KB958051 KbMtja
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英語版 KB:958051
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