Vous recevez un 0x80246002 code d'erreur lorsque vous utilisez les sites Windows Update ou Web Microsoft Update pour installer les mises à jour

Traductions disponibles Traductions disponibles
Numéro d'article: 958056 - Voir les produits auxquels s'applique cet article
Agrandir tout | Réduire tout

Sommaire

Symptômes

Lorsque vous essayez d'utiliser le site Web Windows Update ou le site Web Microsoft Update pour rechercher des mises à jour disponibles, vous recevez le code d'erreur suivant :
0x80246002

Cause

Ce problème peut se produire si Windows Update ou Microsoft Update détermine qu'il est une incompatibilité de hachage de fichier lorsque vous essayez de rechercher des mises à jour disponibles à partir du site Web Windows Update ou à partir le site Web de mise à jour Microsoft.

Résolution

Pour résoudre ce problème, suivez les étapes répertoriées dans cette section. Démarrez avec la méthode 1. Si la méthode 1 ne résout pas le problème, passez à la méthode 2.

Méthode 1: renommer le dossier de téléchargement de Windows Update

Pour renommer le dossier de téléchargement temporaire de Windows Update, suivez les étapes appropriées à votre version de Windows.

important Mises à jour qui sont actuellement téléchargés mais qui n'ont pas encore été installés doivent être téléchargés à nouveau à partir du site Web Windows Update ou à partir le site Web de mise à jour Microsoft.

Windows Vista et Windows Server 2008

  1. Cliquez sur Démarrer
    Réduire cette imageAgrandir cette image
     Start button
    , tapez bloc-notes dans la zone Rechercher et appuyez sur ENTRÉE.
  2. Copiez et collez ensuite les commandes suivantes dans le nouveau document Bloc-notes :
    net stop wuauserv

    CD %systemroot%\SoftwareDistribution

    ren Download.old télécharger

    net start wuauserv
  3. Dans le menu Fichier , cliquez sur Enregistrer sous .
  4. Dans la zone Enregistrer dans , cliquez sur Bureau .
  5. Dans la boîte de type de fichier , cliquez sur tous les fichiers .
  6. Dans la zone Nom de fichier , tapez Rename.bat .
  7. Cliquez sur Enregistrer .
  8. Dans le menu Fichier , cliquez sur Quitter pour quitter le bloc-notes.
  9. Sur votre Bureau, cliquez avec le bouton droit sur Rename.bat , puis cliquez sur Exécuter en tant qu'administrateur .

    Réduire cette imageAgrandir cette image
    User Account Control permission
    Si vous êtes invité à entrer un mot de passe administrateur ou à confirmer une opération, tapez le mot de passe, ou cliquez sur Continuer .
  10. Essayez d'installer la mise à jour en utilisant le site Web Windows Update ou le site Web Microsoft Update.
  11. Si la mise à jour est installé correctement, supprimez le fichier Rename.bat que vous avez enregistré aux étapes 1 à 7.

Windows 2000, Windows XP et Windows Server 2003

  1. Cliquez sur Démarrer , cliquez sur Exécuter , tapez bloc-notes dans la zone Ouvrir et puis cliquez sur OK .
  2. Copiez et collez ensuite les commandes suivantes dans le nouveau document Bloc-notes :
    net stop wuauserv

    CD %systemroot%\SoftwareDistribution

    ren Download.old télécharger

    net start wuauserv
  3. Dans le menu Fichier , cliquez sur Enregistrer sous .
  4. Dans la zone Enregistrer dans , cliquez sur Bureau .
  5. Dans la boîte de type de fichier , cliquez sur tous les fichiers .
  6. Dans la zone Nom de fichier , tapez Rename.bat .
  7. Cliquez sur Enregistrer .
  8. Dans le menu Fichier , cliquez sur Quitter pour quitter le bloc-notes.
  9. Sur votre Bureau, double-cliquez sur Rename.bat .
  10. Essayez d'installer la mise à jour en utilisant le site Web Windows Update ou le site Web Microsoft Update.
  11. Si la mise à jour est installé correctement, supprimez le fichier Rename.bat que vous avez enregistré aux étapes 1 à 7.
notes
  • Si le problème n'est pas résolu, passez à la méthode 2.
  • Si le problème est résolu et si vous pouvez correctement télécharger et installer les mises à jour, vous pouvez en toute sécurité supprimer le dossier Download.old pour récupérer de l'espace disque.

Méthode 2: télécharger et installer manuellement la mise à jour

  1. Déterminer le nombre article de base de connaissances de la mise à jour a échoué. Pour ce faire, effectuez l'une des opérations suivantes :
    • Afficher le message de code d'erreur.
    • Consultez l'historique des mises à jour sur le site Web Windows Update ou le site Web Microsoft Update. Pour ce faire, procédez comme suit :
      1. Reportez-vous au site Web Microsoft Update À le suivant adresse :
        http://update.microsoft.com
      2. Sous Options , cliquez sur l'historique des mises à jour de révision .
      3. Dans la colonne mise à jour , déterminer le nombre d'article Base de connaissances de la mise à jour a échoué.
  2. Reportez-vous au site Web de téléchargement Windows le suivant adresse :
    http://www.microsoft.com/windows/downloads/default.aspx
  3. Dans la zone Rechercher sur la page Web Téléchargements , tapez le numéro article que vous avez localisée à étape 1 et puis cliquez sur OK .

    note Si le numéro article répertorié pour la mise à jour est KB123456 , tapez 123456 dans la zone Rechercher dans la page Web Téléchargements et puis cliquez sur OK .
  4. Parcourir la liste de contenu renvoyé, puis recherchez l'article de base de connaissances qui possède un lien vers le téléchargement.

    note Vous pouvez être invité à valider Windows. Si vous êtes invité, suivez les instructions pour valider Windows et continuer à télécharger la mise à jour.
  5. Cliquez sur Télécharger , puis cliquez sur Enregistrer lorsque vous êtes invité à enregistrer le téléchargement. Enregistrez le téléchargement sur votre Bureau.
  6. Une fois que le téléchargement a terminé, cliquez sur Ouvrir pour installer la mise à jour.
note L'installation de la mise à jour peut échouer si la mise à jour est incorrect pour votre version de Windows.

Propriétés

Numéro d'article: 958056 - Dernière mise à jour: vendredi 26 septembre 2008 - Version: 1.0
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Windows Update
  • Microsoft Update
Mots-clés : 
kbmt kberrmsg kbtshoot kbexpertisebeginner kbprb KB958056 KbMtfr
Traduction automatique
IMPORTANT : Cet article est issu du système de traduction automatique mis au point par Microsoft (http://support.microsoft.com/gp/mtdetails). Un certain nombre d?articles obtenus par traduction automatique sont en effet mis à votre disposition en complément des articles traduits en langue française par des traducteurs professionnels. Cela vous permet d?avoir accès, dans votre propre langue, à l?ensemble des articles de la base de connaissances rédigés originellement en langue anglaise. Les articles traduits automatiquement ne sont pas toujours parfaits et peuvent comporter des erreurs de vocabulaire, de syntaxe ou de grammaire (probablement semblables aux erreurs que ferait une personne étrangère s?exprimant dans votre langue !). Néanmoins, mis à part ces imperfections, ces articles devraient suffire à vous orienter et à vous aider à résoudre votre problème. Microsoft s?efforce aussi continuellement de faire évoluer son système de traduction automatique.
La version anglaise de cet article est la suivante: 958056
L'INFORMATION CONTENUE DANS CE DOCUMENT EST FOURNIE PAR MICROSOFT SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. L'UTILISATEUR ASSUME LE RISQUE DE L'UTILISATION DU CONTENU DE CE DOCUMENT. CE DOCUMENT NE PEUT ETRE REVENDU OU CEDE EN ECHANGE D'UN QUELCONQUE PROFIT.

Envoyer des commentaires

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com