The system may stop responding when you restart a Windows XP-based multicore computer

Article ID: 958244 - View products that this article applies to.
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SYMPTOMS

You have a Windows XP-based computer that has multiple cores. When you restart the computer, the system may stop responding. In this situation, the screen turns black. However, the computer never resets.

This problem may occur on a computer that has more than 8 logical processors. For example, you have a computer that has two quad-core processors and for which hyper-threading is enabled. In this example, you have 16 logical processors because hyperthreading makes each core seem like two logical processors to the operating system.

Note This problem does not occur on computers that are running the 64-bit or x64 Editions of Windows XP Professional.

CAUSE

This problem occurs because the system incorrectly sends certain nonmaskable interrupts. When there are more than 8 logical processors that are available, some logical processors do not receive the nonmaskable interrupt that instructs the computer to restart.

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Windows XP Service Pack 2 or Windows XP Service Pack 3 installed on the computer. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
322389 How to obtain the latest Windows XP service pack

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows XP with Service Pack 2, x86-based versions
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File nameFile versionFile sizeDateTimePlatformSP requirement
Halmacpi.dll5.1.2600.3454134,52830-Sep-200811:25x86SP2
Halmps.dll5.1.2600.3454152,70430-Sep-200811:25x86SP2
Windows XP with Service Pack 3, x86-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirement
Halmacpi.dll5.1.2600.5687134,52830-Sep-200811:34x86SP3
Halmps.dll5.1.2600.5687152,70430-Sep-200811:35x86SP3

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Properties

Article ID: 958244 - Last Review: October 8, 2011 - Revision: 2.0
APPLIES TO
  • Microsoft Windows XP Professional
Keywords: 
kbautohotfix kbexpertisebeginner kbbug kbfix kbqfe KB958244

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