Mensaje de error Stop cuando una aplicación llama a la función NtGdiRectInRegion en un equipo basado en Windows XP: "Stop 0 x 00000050 (PAGE_FAULT_IN_NONPAGED_AREA) del código de error"

Seleccione idioma Seleccione idioma
Id. de artículo: 958282 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

En esta página

Síntomas

Un equipo que ejecuta Windows XP reinicia inesperadamente cuando una aplicación llama a la NtGdiRectInRegion función. Además, recibirá el siguiente mensaje de error Stop:

Stop 0 x 00000050)parámetro1, 00000000, parámetro300000000)
PAGE_FAULT_IN_NONPAGED_AREA
Por ejemplo, este error puede producirse cuando intenta iniciar una aplicación de Microsoft Office en una sesión de servicios de Terminal Server. El escritorio remoto basado en Windows XP se reinicia inesperadamente. Nota
  • Los parámetros de este mensaje de error Stop varían, dependiendo de la configuración del equipo.
  • No todos los mensajes de error de detención "0 x 00000050" son causados por este problema.

Causa

Este problema se produce porque el NtGdiRectInRegion función comprueba la pared más allá del límite.

Solución

Información de la revisión

Hay una revisión compatible de Microsoft. Sin embargo, esta revisión se diseñó para corregir sólo el problemP1 que P2 descrito en este artículo. Aplíquela sólo en sistemas que experimenten el problemP1 descrito en este artículo. Esta revisión podría ser sometida a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere a la próxima actualización de software que contenga esta revisión.

Si la revisión está disponible para descargar, hay una sección de "Descarga de revisión disponible" en la parte superior de este artículo de Knowledge Base. Si no aparece en esta sección, póngase en contacto con el servicio al cliente de Microsoft y soporte técnico para obtener la revisión.

Nota Si se producen problemas adicionales o cualquier solución de problemas es necesario, es posible que deba crear una solicitud de servicio independiente. Se aplicarán los costos de soporte técnico usuales a las cuestiones y problemas que no reúnan los requisitos para esta revisión en cuestión. Para obtener una lista completa de los números de teléfono de servicio al cliente de Microsoft y soporte técnico o para crear una solicitud de servicio independiente, visite el siguiente sitio Web de Microsoft:
http://support.Microsoft.com/contactus/?ws=support
Nota El formulario de "Descarga de revisión disponible" muestra los idiomas para que la revisión está disponible. Si no ve su idioma, es porque una revisión no está disponible para ese idioma.

Requisitos previos

Para aplicar esta revisión, debe tener Windows XP Service Pack 2 o un service pack posterior instalado en el equipo.

Para obtener más información, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
322389Cómo obtener el service pack más reciente para Windows XP

Requisito de reinicio

Tendrá que reiniciar el equipo después de aplicar esta revisión.

Información de reemplazo de hotfix

Esta revisión no sustituye a ninguna revisión publicada previamente.

Información de archivo

La versión en inglés de esta revisión tiene los atributos de archivo (u otros posteriores) que se enumeran en la tabla siguiente. Las fechas y horas de estos archivos se muestran en hora Universal coordinada (UTC). Al ver la información del archivo, se convierte en hora local. Para ver la diferencia entre la hora UTC y la hora local, utilice el Zona horaria ficha en la Fecha y hora elemento de Panel de Control.
Windows XP con Service Pack 2, x 86-versiones
Contraer esta tablaAmpliar esta tabla
Nombre de archivoVersión del archivoTamaño de archivoFechaTiempoPlataforma
Win32k.sys5.1.2600.34701,846,91231-Oct-200810: 52x 86
Windows XP con Service Pack 3, x 86-versiones
Contraer esta tablaAmpliar esta tabla
Nombre de archivoVersión del archivoTamaño de archivoFechaTiempoPlataforma
Win32k.sys5.1.2600.57031,846,91231-Oct-200814: 52x 86

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft que se enumeran en la sección "Se refiere a:".

Más información

Para obtener más información, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
951880Error de detención al servidor basado en Windows Server 2003 se reinicia inesperadamente: "Stop 0 x 00000050"

Propiedades

Id. de artículo: 958282 - Última revisión: jueves, 19 de enero de 2012 - Versión: 1.0
La información de este artículo se refiere a:
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
Palabras clave: 
kbautohotfix kbexpertiseinter kbfix kbbug kbqfe kbmt KB958282 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 958282

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com