Un equipo pierde su dirección IP de DHCP, si un servidor DHCP no está disponible en Windows 7 o Windows Vista

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Soporte técnico para Windows Vista Service Pack 1 (SP1) se finalizó el 12 de julio de 2011. Para seguir recibiendo actualizaciones de seguridad para Windows Vista, asegúrese de que está ejecutando Windows Vista con Service Pack 2 (SP2). Para obtener más información, consulte este sitio Web de Microsoft: Soporte técnico está terminando por algunas versiones de Windows.
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Síntomas

Importante Este artículo contiene información acerca de cómo modificar el registro. Asegúrese de hacer copia de seguridad del registro antes de modificarlo. Asegúrese de que sabe cómo restaurarlo si surge algún problema. Para obtener más información acerca de cómo hacer copia de seguridad, restaurar y modificar el registro, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
322756 Cómo hacer copia de seguridad y restaurar el registro en Windows

Tenga en cuenta la situación siguiente:
  • Tiene un equipo de cliente de protocolo de configuración dinámica de Host (DHCP) que se ejecuta en Windows Vista o un sistema operativo posterior.
  • El servicio servidor DHCP no está disponible.
  • Se reinicia el equipo cliente.
En este escenario, el cliente no mantiene una concesión válida. Por lo tanto, no se puede tener acceso a algunos recursos de red.

Causa

En este escenario, el equipo pierde la dirección IP que se ha asignado por el servidor DHCP. Esto ocurre incluso si la puerta de enlace predeterminada está disponible. En su lugar, se asigna una dirección de direccionamiento IP privado automático (APIPA, Automatic Private IP ADDRESSING), tales como 169.254.0.1, en el equipo cliente. O bien, si el adaptador se ha asignado una dirección IP mediante el uso de la Configuración alternativa ficha para el adaptador, el adaptador utilizará esa dirección.

Solución

Advertencia Pueden producirse problemas graves si modifica incorrectamente el registro mediante el Editor del registro o con cualquier otro método. Estos problemas pueden requerir que reinstale el sistema operativo. Microsoft no puede garantizar que estos problemas puedan resolverse. Modifique el registro bajo su responsabilidad.

Para resolver este problema, agregue un valor de registro para obligar al cliente para mantener su dirección IP de DHCP, incluso si un servidor DHCP no está disponible. Para agregar este valor, siga estos pasos:
  1. Inicie el Editor del registro. Para ello, haga clic en Inicio, tipo Regedit en el Iniciar búsqueda cuadro y, a continuación, presione ENTRAR.
  2. Para activar la configuración para todos los adaptadores, busque la siguiente subclave del registro:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters
    (Sólo en Windows Vista) Para activar esta configuración de un adaptador específico, busque la clave del registro específicas del adaptador:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\<Adapter>
  3. En el Editar menú, elija Nuevoy, a continuación, haga clic en Valor DWORD.
  4. Tipo DontPingGateway, y, a continuación, presione ENTRAR.
  5. En el Editar menú, haga clic en Modificar.
  6. En el Valor cuadro de datos, escriba 1y, a continuación, haga clic en ACEPTAR.
  7. Salga del Editor del registro.
  8. Reinicie el equipo.
Este procedimiento obliga al cliente para mantener su dirección IP de DHCP, incluso si un servidor DHCP no está disponible. Si usas el Configuración alternativa ficha para modificar la dirección IP para un adaptador, esta dirección IP se asigna al adaptador.

Nota En Windows 7, es que el nuevo valor del registro no se sigue si se intenta establecer para un adaptador específico en la siguiente subclave:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\<Adapter>

Propiedades

Id. de artículo: 958336 - Última revisión: martes, 26 de febrero de 2013 - Versión: 1.0
La información de este artículo se refiere a:
  • Windows Vista Business
  • Windows Vista Enterprise
  • Windows Vista Ultimate
  • Windows 7 Enterprise
  • Windows 7 Professional
  • Windows 7 Ultimate
  • Windows Server 2008 Enterprise
  • Windows Server 2008 Foundation
  • Windows Server 2008 R2 Enterprise
  • Windows Server 2008 R2 Foundation
  • Windows Server 2008 R2 Standard
  • Windows Server 2008 Standard
Palabras clave: 
kbexpertiseadvanced kbtshoot kbprb kbmt KB958336 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 958336

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