Error message when you try to add a user from a trusted domain to Microsoft Dynamics CRM 4.0: "An error has occurred"

Article translations Article translations
Article ID: 958791 - View products that this article applies to.
Expand all | Collapse all

SYMPTOMS

When you try to add a user from a trusted domain to Microsoft Dynamics CRM 4.0, you receive the following error message:
An error has occurred.
Try this action again. If the problem continues, check the Microsoft Dynamics Community for solutions or contact your organization's Microsoft Dynamics CRM Administrator. Finally, you can contact Microsoft Support.
Additionally, if the DevErrors value in the Web.config file is set to On, you receive the an error message that resembles the following:
Error: Exception has been thrown by the target of an invocation.
Error Message: Exception has been thrown by the target of an invocation.
Source File: Not available
Line Number: Not available
Request URL: http://MYCRMURL/MYORG/biz/users/edit.aspx?_CreateFromType=10&_CreateFromId={5BE7F527-076E-DC11-9739-02BF0FFF781B}

CAUSE

This problem occurs because Microsoft Dynamics CRM 4.0 performs a lookup process to find a user by searching the global catalog list. If the process tries to connect to a nonfunctioning global catalog or to an offline global catalog, you receive the error message that is mentioned in the "Symptoms" section.

RESOLUTION

This problem is fixed in the latest cumulative update rollup for Microsoft Dynamics CRM 4.0. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
949256 Microsoft Dynamics CRM 4.0 updates and hotfixes

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

When this problem occurs , an error message that resembles the following is logged in the platform log:
Error: Exception has been thrown by the target of an invocation.
Error Message: Exception has been thrown by the target of an invocation.
Source File: Not available
Line Number: Not available
Request URL: http://MYCRMURL/MYORG/biz/users/edit.aspx?_CreateFromType=10&_CreateFromId={5BE7F527-076E-DC11-9739-02BF0FFF781B}
Stack Trace Info: [COMException: The server is not operational. ]
at System.DirectoryServices.DirectoryEntry.Bind(Boolean throwIfFail)
at System.DirectoryServices.DirectoryEntry.Bind()
at System.DirectoryServices.DirectoryEntry.get_AdsObject()
at System.DirectoryServices.DirectorySearcher.FindAll(Boolean findMoreThanOne)
at System.DirectoryServices.DirectorySearcher.FindAll()
at Microsoft.Crm.BusinessEntities.SecurityUtils.GetGuidFromSid(String domain, Byte[] sid)
at Microsoft.Crm.BusinessEntities.SecurityUtils.GetUserId(String domainName)
at Microsoft.Crm.BusinessEntities.SecurityLibrary.GetUserId(String NTName)
at Microsoft.Crm.ObjectModel.SystemUserServiceInternal`1.CreateInternal(Guid organizationId, IBusinessEntity systemuser, ExecutionContext context)
at Microsoft.Crm.ObjectModel.SystemUserServiceInternal`1.Create(IBusinessEntity systemuser, ExecutionContext context)
For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates
For more information about Microsoft Business Solutions CRM software hotfix and update package terminology, click the following article number to view the article in the Microsoft Knowledge Base:
887283 Microsoft Business Solutions CRM software hotfix and update package naming standards

Properties

Article ID: 958791 - Last Review: January 20, 2012 - Revision: 2.2
APPLIES TO
  • Microsoft Dynamics CRM 4.0
Keywords: 
kberrmsg kbfix kbautohotfix kbexpertiseinter kbsurveynew kbmbsmigrate kbqfe kbhotfixserver KB958791

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com