Mensagem de erro ao tentar adicionar um usuário de um domínio confiável para o Microsoft Dynamics CRM 4.0: "erro"

Traduções deste artigo Traduções deste artigo
ID do artigo: 958791 - Exibir os produtos aos quais esse artigo se aplica.
Expandir tudo | Recolher tudo

Sintomas

Quando você tenta adicionar um usuário de um domínio confiável para o Microsoft Dynamics CRM 4.0, você recebe a seguinte mensagem de erro:
Ocorreu um erro.
Tente esta ação novamente. Se o problema persistir, verifique a comunidade do Microsoft Dynamics para soluções ou entre em contato com o administrador de do sua organização Microsoft Dynamics CRM. Finalmente, você pode contatar o Microsoft Support.
Além disso, se o valor DevErrors no arquivo Web. config está definido como On, você recebe a mensagem de erro semelhante à seguinte:
Erro: Exceção foi acionada pelo destino de uma chamada.
Mensagem de erro: Exceção foi acionada pelo destino de uma chamada.
Arquivo de origem: Não disponível
Número da linha: Não disponível
URL da solicitação: http://MYCRMURL/MYORG/biz/users/edit.aspx?_CreateFromType=10&_CreateFromId= {5BE7F527-076E-DC11-9739-02BF0FFF781B}

Causa

Esse problema ocorre porque o Microsoft Dynamics CRM 4.0 executa um processo de pesquisa para localizar um usuário pesquisando a lista do catálogo global. Se o processo de tentar se conectar a um catálogo global nonfunctioning ou para um catálogo global off-line, você receberá a mensagem de erro mencionada na seção "Sintomas".

Resolução

Esse problema é corrigido no acúmulo de atualização cumulativa mais recente para o Microsoft Dynamics CRM 4.0. Para obter mais informações, clique no número abaixo para ler o artigo na Base de dados de Conhecimento Microsoft:
949256 Hotfixes e atualizações do Microsoft Dynamics CRM 4.0

Situação

A Microsoft confirmou que este é um problema nos produtos Microsoft que estão listados na seção "Aplica-se a".

Mais Informações

Quando esse problema ocorre, uma mensagem de erro semelhante à seguinte é registrada no log de plataforma:
Erro: Exceção foi acionada pelo destino de uma chamada.
Mensagem de erro: Exceção foi acionada pelo destino de uma chamada.
Arquivo de origem: Não disponível
Número da linha: Não disponível
URL da solicitação: http://MYCRMURL/MYORG/biz/users/edit.aspx?_CreateFromType=10&_CreateFromId= {5BE7F527-076E-DC11-9739-02BF0FFF781B}
Informações de rastreamento de pilha: [COMException: O servidor não está operacional.]
no System.DirectoryServices.DirectoryEntry.Bind (Boolean throwIfFail)
em System.DirectoryServices.DirectoryEntry.Bind()
em System.DirectoryServices.DirectoryEntry.get_AdsObject()
no System.DirectoryServices.DirectorySearcher.FindAll (Boolean findMoreThanOne)
em System.DirectoryServices.DirectorySearcher.FindAll()
no Microsoft.Crm.BusinessEntities.SecurityUtils.GetGuidFromSid (domínio de cadeia de caracteres, Byte [] sid)
a Microsoft.Crm.BusinessEntities.SecurityUtils.GetUserId (cadeia de caracteres domainName)
a Microsoft.Crm.BusinessEntities.SecurityLibrary.GetUserId (cadeia de caracteres NTName)
no Microsoft.Crm.ObjectModel.SystemUserServiceInternal'1.CreateInternal (Guid organizationId, IBusinessEntity systemuser ExecutionContext contexto.)
no Microsoft.Crm.ObjectModel.SystemUserServiceInternal'1.Create (systemuser IBusinessEntity, contexto de ExecutionContext)
Para obter mais informações sobre a terminologia de atualização de software, clique no número abaixo para ler o artigo na Base de dados de Conhecimento Microsoft:
824684 Descrição da terminologia padrão usada para descrever as atualizações de software
Para obter mais informações sobre a terminologia de pacote Microsoft Business Solutions CRM software hotfix e atualização, clique no número abaixo para ler o artigo na Base de dados de Conhecimento Microsoft:
887283 Padrões de nomenclatura do pacote de hotfix do Microsoft Business Solutions CRM software e atualização

Propriedades

ID do artigo: 958791 - Última revisão: domingo, 9 de fevereiro de 2014 - Revisão: 3.0
A informação contida neste artigo aplica-se a:
  • Microsoft Dynamics CRM 4.0
Palavras-chave: 
kberrmsg kbfix kbautohotfix kbexpertiseinter kbsurveynew kbmbsmigrate kbqfe kbhotfixserver kbmt KB958791 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido pelo software de tradução automática da Microsoft e eventualmente pode ter sido editado pela Microsoft Community através da tecnologia Community Translation Framework (CTF) ou por um tradutor profissional. A Microsoft oferece artigos traduzidos automaticamente por software, por tradutores profissionais e editados pela comunidade para que você tenha acesso a todos os artigos de nossa Base de Conhecimento em diversos idiomas. No entanto, um artigo traduzido pode conter erros de vocabulário, sintaxe e/ou gramática. A Microsoft não é responsável por qualquer inexatidão, erro ou dano causado por qualquer tradução imprecisa do conteúdo ou por seu uso pelos nossos clientes.
Clique aqui para ver a versão em Inglês deste artigo: 958791

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com