The Automatic Update window may stop responding when you use a WSUS server to deploy Windows Internet Explorer 7 and cumulative security update 944533 on a Windows XP-based client computer

Article translations Article translations
Article ID: 958817 - View products that this article applies to.
Expand all | Collapse all

On This Page

SYMPTOMS

In the network environment, you use a Microsoft Windows Server Update Services (WSUS) server to deploy Windows Internet Explorer 7 and the cumulative security update for Internet Explorer 944533. However, on a Windows XP-based client computer, after the Internet Explorer 7 update is installed, the Automatic Update window may stop responding (hang) during the installation of the cumulative security update.

CAUSE

This problem occurs because of a deadlock in the Msvcrt.dll component.

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Windows XP Service Pack 2 or a later service pack installed on the computer. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
322389 How to obtain the latest Windows XP service pack

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows XP with Service Pack 2, x86-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirement
Msvcirt.dll7.0.2600.346857,34425-Oct-200812:11x86SP2
Msvcrt.dll7.0.2600.3468343,04029-Oct-200809:37x86SP2
Msvcirt.dll7.0.2600.346857,34429-Oct-200809:37x86None
Msvcrt.dll7.0.2600.3468343,04029-Oct-200809:37x86None
Mswincrt.manNot Applicable50030-Oct-200808:19Not ApplicableNone
Mswincrt.manNot Applicable62330-Oct-200808:19Not ApplicableNone
Windows XP with Service Pack 3, x86-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirement
Msvcirt.dll7.0.2600.570157,34425-Oct-200812:48x86SP3
Msvcrt.dll7.0.2600.5701343,04029-Oct-200809:48x86SP3
Msvcirt.dll7.0.2600.570157,34429-Oct-200809:48x86None
Msvcrt.dll7.0.2600.5701343,04029-Oct-200809:48x86None
Mswincrt.manNot Applicable50030-Oct-200808:16Not ApplicableNone
Mswincrt.manNot Applicable62330-Oct-200808:16Not ApplicableNone

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about Microsoft Windows Server Update Services, visit the following Web site:
http://technet.microsoft.com/en-us/wsus/default.aspx

Properties

Article ID: 958817 - Last Review: October 8, 2011 - Revision: 2.0
APPLIES TO
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
Keywords: 
kbautohotfix kbexpertiseinter kbfix kbbug kbqfe KB958817

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com