FIX: The server performance decreases when you run the SNA Manager to manage a remote SNA server in Microsoft Host Integration Server 2006

Article translations Article translations
Article ID: 958822 - View products that this article applies to.
Expand all | Collapse all

On This Page

SYMPTOMS

In Microsoft Host Integration Server 2006, you use SNA Manager to manage a remote SNA server. After some time, the local server's performance decreases.

If you monitor the SNA buffer pool, you see that the number of headers and elements in the SNA buffer pool keeps increasing. The number increases each time that you delete and then add a remote SNA Server, or update the remote SNA server in SNA Manager. Therefore, the Host Integration Server system will run out of trusted headers and elements after it has run for some time.

CAUSE

The issue occurs because of a memory leak in the Mngcli.exe process. This memory leak occurs because some messages sent to the SNA server are not freed. Therefore, some memory pointers are stored for future reference.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Host Integration Server 2006. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
979497 How to obtain the latest Host Integration Server 2006 service pack

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

You must have Host Integration Server 2006 installed to apply this hotfix.

Restart information

You do not have to restart the computer after you apply this hotfix.

Registry information

You do not have to change the registry.

Hotfix Replacement information

This hotfix does not replace any other hotfixes.

Hotfix file information

This hotfix contains only those files that are required to correct the issues that this article lists. This hotfix may not contain of all the files that you must have to fully update a product to the latest build. The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
32-bit (x86) version
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Adloc.dll7.0.2928.028,49622-Jul-200913:31x86
Hisservicelib.dll7.0.2928.032,59222-Jul-200913:31x86
Mmcsna.dll7.0.2928.0324,92822-Jul-200913:31x86
Mngagent.exe7.0.2928.0129,35222-Jul-200913:31x86
Mngbase.dll7.0.2928.0126,78422-Jul-200913:31x86
Mngcli.exe7.0.2928.0128,83222-Jul-200913:31x86
Snaadmin.dll7.0.2928.0392,52022-Jul-200913:31x86
Snabase.exe7.0.2928.0230,20822-Jul-200913:31x86
Snacfg.dll7.0.2928.0284,49622-Jul-200913:31x86
Snacfg.exe7.0.2928.0231,74422-Jul-200913:31x86
Snadmod.dll7.0.2928.0819,53622-Jul-200913:31x86
Snaevent.dll7.0.2928.0518,98422-Jul-200913:31x86
Snaip.dll7.0.2928.0107,34422-Jul-200913:31x86
Snalm.dll7.0.2928.059,20022-Jul-200913:31x86
Snamanag.dll7.0.2928.0127,81622-Jul-200913:31x86
Snaole.dll7.0.2928.0646,99222-Jul-200913:31x86
Snaolewmi.dll7.0.2928.0637,25622-Jul-200913:31x86
Wmisna.dll7.0.2928.0321,34422-Jul-200913:31x86
64-bit (x64) version
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Adloc.dll7.0.2928.035,13622-Jul-200913:32x64
Hisservicelib.dll7.0.2928.046,92822-Jul-200913:32x64
Mmcsna.dll7.0.2928.0441,66422-Jul-200913:32x64
Mngagent.exe7.0.2928.0175,44022-Jul-200913:32x64
Mngbase.dll7.0.2928.0163,13622-Jul-200913:32x64
Mngcli.exe7.0.2928.0174,91222-Jul-200913:32x64
Snaadmin.dll7.0.2928.0512,32822-Jul-200913:32x64
Snabase.exe7.0.2928.0290,62422-Jul-200913:32x64
Snacfg.dll7.0.2928.0390,46422-Jul-200913:32x64
Snacfg.exe7.0.2928.0293,20022-Jul-200913:32x64
Snadmod.dll7.0.2928.01,027,90422-Jul-200913:32x64
Snaevent.dll7.0.2928.0524,11222-Jul-200913:32x64
Snaip.dll7.0.2928.0129,34422-Jul-200913:32x64
Snalm.dll7.0.2928.071,48822-Jul-200913:32x64
Snamanag.dll7.0.2928.0191,81622-Jul-200913:32x64
Snaole.dll7.0.2928.0870,72022-Jul-200913:32x64
Snaolewmi.dll7.0.2928.0855,36822-Jul-200913:32x64
Wmisna.dll7.0.2928.0601,92022-Jul-200913:32x64

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Properties

Article ID: 958822 - Last Review: October 8, 2011 - Revision: 3.0
APPLIES TO
  • Microsoft Host Integration Server 2006 Enterprise Edition
  • Microsoft Host Integration Server 2006
Keywords: 
kbautohotfix kbexpertiseadvanced kbfix kbsurveynew kbqfe KB958822

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com