FIX: A Stop error or a crash occurs on the operating system when you profile an application by using Visual Studio 2005 Service Pack 1

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Article ID: 958840 - View products that this article applies to.
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SYMPTOMS

You may experience a Stop error or a crash on the operating system when you profile an application by using Microsoft Visual Studio 2005 Service Pack 1 (SP1). The problem may occur when the following conditions are true:
  • You use the sampling profiling method.
  • The computer is running on the Intel Nehalem processor.

CAUSE

This problem occurs because the sampling profiler uses drivers in operating system. However, the Intel Nehalem processor was created after the 2005 version of the profiler.

RESOLUTION

A supported hotfix is now available from Microsoft. However, it is intended to correct only the problem that is described in this article. Apply it only to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Customer Support Services to obtain the hotfix. For a complete list of Microsoft Customer Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

You must have Visual Studio 2005 SP1 installed to apply this hotfix.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
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File nameFile versionFile sizeDateTime
Vsinstr.exe8.0.50727.30791,723,20825-Oct-200803:11:36 AM
VSPerfDrv.sys8.0.50727.307948,12824-Oct-200811:21:52 PM

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

If the same problem occurs when you use Microsoft Visual Studio 2008 Service Pack 1, apply hotfix 958842. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
958842 FIX: A Stop error or a crash occurs on the operating system when you profile an application by using Visual Studio 2008 Service Pack 1
For more information about Nehalem, visit the following Web site:
http://en.wikipedia.org/wiki/Intel_Nehalem
For more information about how to analyze application performance by using profiling tools, visit the following Microsoft Web site:
http://msdn.microsoft.com/en-us/library/z9z62c29.aspx

Properties

Article ID: 958840 - Last Review: December 15, 2008 - Revision: 1.1
APPLIES TO
  • Microsoft Visual Studio 2005 Service Pack 1
Keywords: 
kbsurveynew kbhotfixserver kbexpertiseadvanced kbqfe KB958840

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