FIX: A Windows CE 5.0-based target device that has a network adapter that uses the RealTek RTL8139 device driver may be unresponsive

Article translations Article translations
Article ID: 958927 - View products that this article applies to.
Expand all | Collapse all

On This Page

SYMPTOMS

Consider the following scenario.
  • You have a Windows CE 5.0-based target device that has two network adapters.
  • One network adapter uses the RealTek RTL8139 device driver.
  • You enable IP routing on the target device.
  • The driver for the second network adapter has insufficient resources to process packets and returns NDIS_STATUS_RESOURCES to the Network Driver Interface Specification (NDIS). For example, the driver is a Wireless LAN (WLAN) driver that loses the connection to an access point.
In this scenario, the target device may be unresponsive.

CAUSE

This problem occurs because the RealTek RTL8139 device driver keeps reading the empty receive queue in the interrupt service thread (IST).

RESOLUTION

Software update information

A supported software update is now available from Microsoft as Windows CE 5.0 Platform Builder Monthly Update (December 2008). You can confirm this by scrolling to the "File information" section of this article. The package file name contains the product version, date, Knowledge Base article number, and processor type. The package file name format is:
Product version-yymmdd-kbnnnnnn-processor type
For example: Wincepb50-060503-kb917590-armv4i.msi is the ARMV4i Windows CE 5.0 Platform Builder fix that is documented in KB article 917590 and that is contained in the May 2006 monthly update. To resolve this problem immediately, click the following article number for information about obtaining Windows CE Platform Builder and core operating system software updates:
837392 How to locate core operating system fixes for Microsoft Windows CE Platform Builder products

Prerequisites

This update is supported only if all previously issued updates for this product have also been installed.

Restart requirement

After you apply this software update, you must perform a clean build of the whole platform. To do this, use one of the following methods:
  • On the Build OS menu, make sure that the following options are selected, and then click Sysgen:
    • Clean Before Building
    • Copy Files to Release Directory After Build
    • Make Run-Time Image After Build
  • On the Build OS menu, click Open Release Directory. Then, in a Command Prompt window, type blddemo clean -q, and then press ENTER.
You do not have to restart the computer after you apply this software update.

Update replacement information

This update does not replace any other updates.

File information

The English version of this software update package has the file attributes or the later file attributes that are listed in the following table.

Collapse this tableExpand this table
File nameFile sizeDateTime
Wincepb50-081205-kb958927-armv4i.msi522,24003-Dec-200820:56
Wincepb50-081205-kb958927-mipsii.msi529,92003-Dec-200820:56
Wincepb50-081205-kb958927-mipsii_fp.msi530,43203-Dec-200820:56
Wincepb50-081205-kb958927-mipsiv.msi530,94403-Dec-200820:56
Wincepb50-081205-kb958927-mipsiv_fp.msi531,45603-Dec-200820:56
Wincepb50-081205-kb958927-sh4.msi521,72803-Dec-200820:56
Wincepb50-081205-kb958927-x86.msi512,00003-Dec-200820:56


The English version of this software update package has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Collapse this tableExpand this table
File nameFile sizeDateTimePath
Rtl8139.lib225,57824-Nov-200822:21Public\Common\Oak\Lib\Armv4i\Debug
Rtl8139.lib138,06024-Nov-200822:21Public\Common\Oak\Lib\Armv4i\Retail
Rtl8139.lib227,21824-Nov-200822:21Public\Common\Oak\Lib\Mipsii\Debug
Rtl8139.lib142,86824-Nov-200822:21Public\Common\Oak\Lib\Mipsii\Retail
Rtl8139.lib227,30024-Nov-200822:21Public\Common\Oak\Lib\Mipsii_fp\Debug
Rtl8139.lib142,94824-Nov-200822:21Public\Common\Oak\Lib\Mipsii_fp\Retail
Rtl8139.lib228,84624-Nov-200822:21Public\Common\Oak\Lib\Mipsiv\Debug
Rtl8139.lib143,42824-Nov-200822:21Public\Common\Oak\Lib\Mipsiv\Retail
Rtl8139.lib228,92824-Nov-200822:22Public\Common\Oak\Lib\Mipsiv_fp\Debug
Rtl8139.lib143,50824-Nov-200822:22Public\Common\Oak\Lib\Mipsiv_fp\Retail
Rtl8139.lib205,88824-Nov-200822:20Public\Common\Oak\Lib\Sh4\Debug
Rtl8139.lib133,37624-Nov-200822:20Public\Common\Oak\Lib\Sh4\Retail
Rtl8139.lib202,98624-Nov-200822:20Public\Common\Oak\Lib\X86\Debug
Rtl8139.lib130,28424-Nov-200822:20Public\Common\Oak\Lib\X86\Retail

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Properties

Article ID: 958927 - Last Review: October 8, 2011 - Revision: 2.0
APPLIES TO
  • Microsoft Windows CE 5.0
Keywords: 
kbexpertiseadvanced kbsurveynew kbqfe KB958927

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com