CORRECÇÃO: Mensagem de erro quando inicia o espelhamento da base de dados no SQL Server 2005 numa base de dados é restaurada ou actualizar a partir do SQL Server 2000: "O serviço Broker ID pela cópia remota da base de dados"<databasename>"não corresponde ao ID no servidor principal"

Traduções de Artigos Traduções de Artigos
Artigo: 959008 - Ver produtos para os quais este artigo se aplica.
Expandir tudo | Reduzir tudo

Nesta página

Sintomas

Considere um dos seguintes cenários:
  • Restaurar uma cópia de segurança da base de dados do Microsoft SQL Server 2000 numa instância do Microsoft SQL Server 2005 utilizando a opção WITH RECOVERY . Também restaurar esta cópia de segurança da base de dados em outra instância do SQL Server 2005 utilizando a opção WITH NORECOVERY .
  • Tem duas instâncias do SQL Server 2000 com uma base de dados que é o mesmo destes casos. Uma instância tem a base de dados o estado de carregamento. A outra instância tem a base de dados no estado normal. Em seguida, actualiza estes instâncias para o SQL Server 2005.
Configurar a base de dados espelhamento nesta base de dados no SQL Server 2005. No entanto, quando inicia o espelhamento da base de dados, recebe a seguinte mensagem de erro:
O ID de Broker de serviço para a cópia remota da base de dados "<DatabaseName> "não coincide com o ID no servidor principal. (Microsoft SQL Server, erro: 1436)
Nota Este problema também ocorre no Microsoft SQL Server 2008.

Normalmente, encontrar este problema quando actualiza uma configuração de envio do registo de Microsoft SQL Server 2000. Considere o seguinte cenário:
  • Tem uma configuração de envio de registo do SQL Server 2000.
  • Actualizar os servidores envolvidos no registo de configuração para o SQL Server 2005 para envio.
  • Após a actualização, configurou o espelhamento da base de dados utilizando a base de dados anteriormente utilizada na configuração de envio do registo.
Quando inicia o espelhamento da base de dados, recebe esta mensagem de erro.

Causa

Bases de dados do SQL Server 2000 não são necessário um ID de serviço Broker. Se restaurar estas bases de dados instâncias do SQL Server 2005 utilizando a opção WITH NORECOVERY , estas bases de dados não serão actualizados. Por conseguinte, o ID de Broker Service destas bases de dados é NULL depois do restauro. Além disso, se actualizar uma instância do SQL Server 2000, bases de dados existentes que se encontram no estado de carregamento não serão actualizados. Por conseguinte, o ID de Broker Service destas bases de dados é NULL após a actualização. Quando inicia o espelhamento da base de dados, o ID do Broker serviço do servidor principal é comparado com o ID do serviço do servidor espelho (mirror). Uma vez que os IDs de Broker Service não correspondem, falha a comparação.

No cenário de actualização de uma configuração envio do registo de SQL Server 2000, a base de dados secundária está no estado de carregamento. Depois de actualizar o servidor que contém a base de dados secundária, a base de dados não tem um ID de Broker Service. Depois de actualizar o servidor que contém a base de dados principal, a dados tem um ID de Broker Service. Quando inicia o espelhamento da base de dados, o ID do Broker serviço do servidor principal é enviado para o servidor de mirror para comparação. Uma vez que o ID do Broker serviço do servidor mirror é NULL, falha a comparação.

Resolução

Informações sobre Service Packs

Para resolver este problema, obtenha o service pack mais recente para o SQL Server 2005. Para obter mais informações, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
913089Como obter o service pack mais recente para o SQL Server 2005

importante Depois de instalar o SQL Server 2005 Service Pack 3, activar sinalizador de rastreamento 8446 no servidor de espelhos (mirror) antes de iniciar o espelhamento da base de dados. Depois de ter iniciado espelhamento da base de dados, pode remover com segurança este sinalizador de rastreio. Para obter mais informações sobre como activar um sinalizador de rastreio, visite o seguinte Web site da Microsoft Developer Network (MSDN):
http://msdn.microsoft.com/en-us/library/ms188396(SQL.90).aspx

Como contornar

Para contornar este problema, siga estes passos:
  1. Efectuar uma cópia de segurança completa da base de dados e cópia de segurança do registo no servidor principal.
  2. Restaure a cópia de segurança da base de dados e cópia de segurança da registo no servidor espelhos (mirror) utilizando a opção WITH NORECOVERY .
  3. Configure o espelhamento da base de dados na base de dados.
  4. Inicie o espelhamento da base de dados.

Ponto Da Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na secção "Aplica-se a". Este problema foi corrigido pela primeira vez no SQL Server 2005 Service Pack 3.

Mais Informação

Para obter mais informações sobre a terminologia de actualização de software, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
824684Descrição da terminologia padrão utilizada para descrever actualizações de software da Microsoft

Referências

Para obter mais informações sobre como actualizar uma configuração de envio de registo do SQL Server 2000, visite o seguinte Web site da MSDN:
http://msdn.microsoft.com/en-us/library/ms188297(SQL.90).aspx

Propriedades

Artigo: 959008 - Última revisão: 16 de dezembro de 2008 - Revisão: 1.0
A informação contida neste artigo aplica-se a:
  • Microsoft SQL Server 2005 Standard Edition
  • Microsoft SQL Server 2005 Developer Edition
  • Microsoft SQL 2005 Server Enterprise
  • Microsoft SQL Server 2005 Standard X64 Edition
  • Microsoft SQL Server 2005 Standard Edition for Itanium Based Systems
  • Microsoft SQL Server 2005 Enterprise X64 Edition
  • Microsoft SQL Server 2005 Enterprise Edition for Itanium Based Systems
  • Microsoft SQL 2005 Server Workgroup
Palavras-chave: 
kbmt kbsqlservlogship kbtshoot kbsql2005engine kbexpertiseadvanced kbfix kbbug KB959008 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática? erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 959008

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com