REVISIÓN: El proceso de sincronización es lento y el uso de CPU es alto en el equipo está configurado como distribuidor de SQL Server 2005

Seleccione idioma Seleccione idioma
Id. de artículo: 959013 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

En esta página

Síntomas

Al sincronizar una suscripción a una publicación de la duplicación transaccional en Microsoft SQL Server 2005, el proceso de sincronización es lento. Durante el proceso de sincronización, el uso de CPU es alto en el equipo está configurado como distribuidor.

El problema se produce cuando se cumplen las condiciones siguientes:
  • El MSrepl_commands tabla contiene muchas filas de la base de datos publicador. Por ejemplo, el MSrepl_commands tabla contiene 800.000 filas para la base de datos publicador.
  • El proceso de sincronización inicializa el suscriptor o reinicializa el suscriptor. Como alternativa, incrementalmente agregar un artículo en la publicación antes de sincronizar la suscripción.
Nota Este problema no es específico de duplicación transaccional en SQL Server 2005. Este problema puede producirse también para cualquier consulta si se cumplen las condiciones siguientes:
  • Consultar una tabla que contiene muchas filas. Por ejemplo, la tabla contiene 800.000 filas.
  • Utilizar la sugerencia de consulta FAST o la sugerencia de consulta TOP en la consulta.

Causa

Este problema se produce porque SQL Server 2005 genera un plan de ejecución ineficiente para una de las consultas en el procedimiento sp_MSget_repl_commands almacenados. Este problema se produce sólo si la consulta que realiza mal utiliza la sugerencia de consulta FAST o la sugerencia de consulta TOP. El plan de ejecución de la consulta que realiza mal muestra que un predicado de combinación no se trasladará a Clustered Index Seek operador.

Solución

Información de Service Pack

Para resolver este problema, obtenga el service pack más reciente para SQL Server 2005. Para obtener más información, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
913089Cómo obtener el service pack más reciente para SQL Server 2005

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "La información de este artículo se refiere a:". Este problema se corrigió por primera vez en SQL Server 2005 Service Pack 3.

Más información

Esta revisión introduce el indicador de traza 4126. Debe habilitar este indicador de traza resolver este problema. Para habilitar el indicador de traza, utilice la instrucción DBCC TRACEON o especifique el indicador de traza 4126 como un parámetro de inicio para el servicio de SQL Server.

Para obtener más información sobre el mismo problema que se produce en SQL Server 2000, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
929131REVISIÓN: En SQL Server 2000, el proceso de sincronización es lento y el uso de CPU es alto en el equipo está configurado como distribuidor

Para obtener más información acerca de la terminología relativa de la actualización de software, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
824684Descripción de la terminología estándar utilizada para describir las actualizaciones de software de Microsoft

Propiedades

Id. de artículo: 959013 - Última revisión: martes, 16 de diciembre de 2008 - Versión: 1.0
La información de este artículo se refiere a:
  • Microsoft SQL Server 2005 Standard Edition
  • Microsoft SQL Server 2005 Developer Edition
  • Microsoft SQL Server 2005 Enterprise Edition
  • Microsoft SQL Server 2005 Standard X64 Edition
  • Microsoft SQL Server 2005 Standard Edition for Itanium Based Systems
  • Microsoft SQL Server 2005 Enterprise X64 Edition
  • Microsoft SQL Server 2005 Enterprise Edition for Itanium Based Systems
  • Microsoft SQL Server 2005 Workgroup Edition
Palabras clave: 
kbmt kbtshoot kbsql2005engine kbexpertiseadvanced kbfix kbbug KB959013 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 959013

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com