Article ID: 959038 - Last Review: December 31, 2008 - Revision: 1.1

The execution of a task sequence that you create in System Center Configuration Manager 2007 may continue when a program in the task sequence returns a failure exit code

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SYMPTOMS

Consider the following scenario:
  • You create a task sequence in the Configuration Manager Console in Microsoft System Center Configuration Manager 2007. The task sequence runs more than one program.
  • The following option is not checked:
    If an application installation fails, continue installing other applications in the list
  • A program in the task sequence returns a failure exit code.
In this scenario, the execution of the task sequence may continue. That is, the ContinueOnError task sequence variable does not work correctly when its value is FALSE. Therefore, some programs are executed unexpectedly.

CAUSE

This problem occurs because the task sequence engine misinterprets the process failure exit code.

RESOLUTION

Service Pack Information

To resolve this problem, obtain the latest service pack for Microsoft System Center Configuration Manager 2007, available from this Microsoft web site: http://www.microsoft.com/downloads/details.aspx?FamilyID=3318741a-c038-4ab1-852a-e9c13f8a8140 (http://www.microsoft.com/downloads/details.aspx?FamilyID=3318741a-c038-4ab1-852a-e9c13f8a8140)
For a list of issues resolved in this service pack, click on the following article number in the Microsoft Knowledgebase:
971348  (http://support.microsoft.com/kb/971348/ ) List of hotfixes and updates that are contained in System Center Configuration Manager 2007 Service Pack 2

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

You must have System Center Configuration Manager 2007 Service Pack 1 installed to apply this hotfix.

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
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File nameFile versionFile sizeDateTimePlatform
Sccm2007ac-sp1-kb959038-x86.mspNot applicable365,56830-Nov-200821:30Not applicable
Smsswd.exe4.0.6221.1131137,72830-Nov-200821:30x86
Smsswd.exe4.0.6221.1131738,81630-Nov-200821:30IA-64
Smsswd.exe4.0.6221.1131325,63230-Nov-200821:30x64

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/ ) Description of the standard terminology that is used to describe Microsoft software updates

APPLIES TO
  • Microsoft System Center Configuration Manager 2007
Keywords: 
kbautohotfix kbexpertiseinter kbsurveynew kbbug kbfix kbhotfixserver kbqfe kbpubtypekc KB959038
 

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