Article ID: 959065 - Last Review: October 20, 2008 - Revision: 1.0

Wrong database name is added to Recovery Storage Group when more than one database exists in a Storage Group

Expand all | Collapse all
Source: Microsoft Support

RAPID PUBLISHING

RAPID PUBLISHING ARTICLES PROVIDE INFORMATION DIRECTLY FROM WITHIN THE MICROSOFT SUPPORT ORGANIZATION. THE INFORMATION CONTAINED HEREIN IS CREATED IN RESPONSE TO EMERGING OR UNIQUE TOPICS, OR IS INTENDED SUPPLEMENT OTHER KNOWLEDGE BASE INFORMATION.

Symptom



When you use Recovery Storage Group (RSG) and add multiple databases to it, you experience the following:

Recovery configured through Database Recovery Management in Exchange Management Console has an issue with picking the Database name if you have multiple databases in storage group (for example Corp1.edb, Corp2.edb and Corp3.edb). In Recovery Storage Group, the name of first database will appear as the last database in the storage group (in this example Corp3.edb). You would have this:

Corp3.edb > this is the problem (should be Corp1.edb)

Corp2.edb

Corp3.edb

 

So if you restore multiple databases in Recovery Storage Group, first database will not restore successfully.

Cause

This is due to the EXDRA XML bug. We are aware of this issue and currently working on the fix, and will update this article once this is released.

Resolution



There are two ways to work around this issue, until the fix is released:

•             Instead of using Exchange Management Console or EXTRA you can use the Exchange Management Shell to create and add databases to Recovery Storage Group and that works fine. For more information on how to do that, please read this.

•             You can rename the first database name in Active Directory to the correct name before doing the restore in Recovery Storage Group. The Active Directory attribute that should be changed on the RSG database is msExchEDBFile. We recommend that you use the workaround #1 above.

DISCLAIMER

MICROSOFT AND/OR ITS SUPPLIERS MAKE NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY, RELIABILITY OR ACCURACY OF THE INFORMATION CONTAINED IN THE DOCUMENTS AND RELATED GRAPHICS PUBLISHED ON THIS WEBSITE (THE “MATERIALS”) FOR ANY PURPOSE. THE MATERIALS MAY INCLUDE TECHNICAL INACCURACIES OR TYPOGRAPHICAL ERRORS AND MAY BE REVISED AT ANY TIME WITHOUT NOTICE.

TO THE MAXIMUM EXTENT PERMITTED BY APPLICABLE LAW, MICROSOFT AND/OR ITS SUPPLIERS DISCLAIM AND EXCLUDE ALL REPRESENTATIONS, WARRANTIES, AND CONDITIONS WHETHER EXPRESS, IMPLIED OR STATUTORY, INCLUDING BUT NOT LIMITED TO REPRESENTATIONS, WARRANTIES, OR CONDITIONS OF TITLE, NON INFRINGEMENT, SATISFACTORY CONDITION OR QUALITY, MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE, WITH RESPECT TO THE MATERIALS.

APPLIES TO
  • Microsoft Exchange Server 2007 Standard Edition
  • Microsoft Exchange Server 2007 Service Pack 1
  • Microsoft Exchange Server 2007 Enterprise Edition
Keywords: 
kbnomt kbrapidpub KB959065