Applications ou services qui utilisent le redirecteur NFS peuvent se bloquer lorsqu'un client en fonction de Linux ou un client basés sur UNIX se déconnecte d'un serveur Terminal Server Windows Server 2003 sans se déconnecter

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Sommaire

Symptômes

Envisagez le scénario suivant :
  • À partir d'un ordinateur en fonction de Linux ou d'un ordinateur UNIX, vous utilisez un client de RDP (Remote Desktop Protocol) tiers pour se connecter à un serveur Terminal Server Windows Server 2003.
  • Dans la session services Terminal Server, vous mapper des lecteurs réseau à l'ordinateur en fonction de Linux ou à l'ordinateur UNIX à l'aide de NFS (Network File System).
  • Lorsqu'une application s'exécute dans la session, vous déconnectez du serveur Terminal Server sans se déconnecter.
Dans ce scénario, les applications ou services qui utilisent le redirecteur NFS sur Windows Server 2003 terminal server peut se bloquer. Par exemple, l'utilitaire net.exe et l'utilitaire Pddm.exe utilisent le redirecteur NFS. Si vous utilisez une application pour surveiller le serveur problématique, l'application peut se bloquer également.

Lorsque ce problème se produit, vous devez redémarrer le serveur Terminal Server pour restaurer la connexion à l'ordinateur en fonction de Linux ou à l'ordinateur UNIX.

Cause

Ce problème se produit car un verrou mortel se produit dans NFS après que la connexion client vers le serveur Terminal Server est réinitialisée.

Résolution

Informations sur le correctif

Un correctif est désormais disponible auprès de Microsoft. Toutefois, il est conçu uniquement pour corriger le problème décrit dans cet article. S'il s'appliquent uniquement aux systèmes rencontrant ce problème spécifique. Ce correctif peut subir des tests supplémentaires. Par conséquent, si vous n'êtes pas gravement touché par ce problème, nous vous recommandons d'attendre la prochaine mise à jour logicielles qui contiendra ce correctif.

Pour résoudre ce problème immédiatement, contactez services de support technique Microsoft afin d'obtenir le correctif logiciel. Pour une liste complète des numéros de téléphone services de support technique Microsoft et des informations sur les frais engendrés, reportez-vous au site de Web Microsoft suivant :
http://support.microsoft.com/contactus/?ws=support
note Dans certains cas, les frais aucuns de support peuvent être facturés si un technicien du support technique Microsoft détermine qu'une mise à jour spécifique peut résoudre votre problème. Les coûts habituels du support technique s'appliqueront aux autres questions et problèmes non traités par la mise à jour en question.

Conditions préalables

Pour appliquer ce correctif, vous devez exécuter Windows Server 2003 Service Pack 2 sur l'ordinateur.

Demande de redémarrage

Vous devez redémarrer l'ordinateur après avoir appliqué ce correctif.

Informations sur le remplacement de correctif

Ce correctif ne remplace pas un correctif précédemment publiée.

Informations de fichier

La version anglaise de ce correctif dispose les attributs de fichier (ou attributs de fichier version ultérieure) répertoriés dans le tableau suivant. Les dates et heures de ces fichiers sont exprimées en temps universel coordonné (UTC). Lorsque vous affichez les informations de fichier, il est convertie en heure locale. Pour connaître le décalage entre l'heure UTC et l'heure locale, utilisez l'onglet Fuseau horaire dans l'élément Date et heure du Panneau de configuration.
Windows Server 2003 avec Service Pack 2, x 86 versions
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Nom de fichierVersion du fichierTaille du fichierDateHeurePlate-formeSP demandeSuccursale de service
Nfsrdr.sys5.2.3790.3251324,09620-Nov 200811:10x 86SERVICE PACK 1SP1QFE
Nfsrdr.sys5.2.3790.4414324,60820-Nov 200815:16x 86SERVICE PACK 2SP2QFE
Windows Server 2003 avec Service Pack 2, versions 64 x
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Nom de fichierVersion du fichierTaille du fichierDateHeurePlate-formeSP demandeSuccursale de service
Nfsrdr.sys5.2.3790.3251480,25620-Nov 200822:11x 64SERVICE PACK 1SP1QFE
Nfsrdr.sys5.2.3790.4414480,76820-Nov 200822:24x 64SERVICE PACK 2SP2QFE
Windows Server 2003 avec Service Pack 2, versions Itanium
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Nom de fichierVersion du fichierTaille du fichierDateHeurePlate-formeSP demandeSuccursale de service
Nfsrdr.sys5.2.3790.3251858,11220-Nov 200822:06IA-64SERVICE PACK 1SP1QFE
Nfsrdr.sys5.2.3790.4414859,13620-Nov 200822:14IA-64SERVICE PACK 2SP2QFE

Statut

Microsoft a confirmé que c'est un problème dans les produits Microsoft répertoriés dans la section « S'applique à ».

Plus d'informations

Lorsque la routine MRxCreateVNetRoot renvoie le code d'erreur STATUS_CONNECTION_RESET, la connexion client vers le serveur Terminal Server est réinitialisée. Pour plus d'informations sur la terminologie mise à jour logicielles, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
824684 Description de la terminologie standard utilisée pour décrire les mises à jour logicielles Microsoft

Propriétés

Numéro d'article: 959200 - Dernière mise à jour: mercredi 31 décembre 2008 - Version: 1.0
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Datacenter Edition for Itanium-Based Systems
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
Mots-clés : 
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