Aplicações ou serviços que utilizam o redireccionador NFS poderão falhar quando um cliente baseado no Linux ou desliga um cliente baseado em UNIX de um servidor de terminal Windows Server 2003 sem terminar sessão

Traduções de Artigos Traduções de Artigos
Artigo: 959200 - Ver produtos para os quais este artigo se aplica.
Expandir tudo | Reduzir tudo

Nesta página

Sintomas

Considere o seguinte cenário:
  • De um computador com o Linux ou de um computador baseado em UNIX, utilize um cliente de RDP (Remote Desktop Protocol) outros fabricantes para ligar a um servidor de terminais Windows Server 2003.
  • Na sessão dos serviços de terminal, pode mapear unidades de rede para o computador baseado no Linux ou para o computador baseadas em UNIX utilizando Network File System (NFS).
  • Quando uma aplicação está em execução na sessão, desligue a servidor de terminais sem terminar sessão.
Neste cenário, as aplicações ou serviços que utilizam o redireccionador NFS no Windows Server 2003 poderá falhar o servidor de terminais. Por exemplo, o utilitário NET.exe e o utilitário Pddm.exe utilizam o redireccionador NFS. Se utilizar uma aplicação para monitorizar o servidor problemático, a aplicação também poderá falhar.

Quando este problema ocorre, é necessário reiniciar o servidor de terminais para restaurar a ligação para o computador baseado no Linux ou para o computador baseado no UNIX.

Causa

Este problema ocorre porque um impasse ocorre no NFS após a ligação de cliente ao servidor de terminais é reposta.

Resolução

Informações sobre a correcção

Uma correcção suportada está agora disponível da Microsoft. Contudo, destina-se a corrigir o problema descrito neste artigo. Aplique-a apenas em sistemas que tenham este problema específico. Esta correcção poderá submetida a testes adicionais. Por conseguinte, se não estiver a ser gravemente afectado por este problema, recomendamos que aguarde pela próxima actualização de software que contenha esta correcção.

Para resolver este problema imediatamente, contacte o suporte técnico da Microsoft para obter a correcção. Para obter uma lista completa dos números de telefone de suporte técnico da Microsoft e informações sobre os custos de suporte, visite o seguinte Web site da Microsoft:
http://support.microsoft.com/contactus/?ws=support
Nota Em casos especiais, os custos normalmente inerentes às chamadas de suporte poderão ser anulados, se um técnico de suporte da Microsoft determinar que uma actualização específica resolverá o problema. Os custos normais do suporte serão aplicados a problemas adicionais e questões de suporte que não se enquadrem na atualização específica em questão.

Pré-requisitos

Para aplicar esta correcção, tem de ter Windows Server 2003 Service Pack 2 no computador.

Requisito de reinício

Tem de reiniciar o computador depois de aplicar esta correcção.

Informações sobre substituição de correcções

Esta correcção não substitui uma correcção disponibilizada anteriormente.

Informações do ficheiro

A versão inglesa desta correcção tem os atributos de ficheiro (ou atributos de ficheiro posteriores) listados na seguinte tabela. As datas e horas destes ficheiros são indicadas na hora universal coordenada (UTC). Quando visualiza as informações do ficheiro, é convertido para a hora local. Para determinar a diferença entre a UTC e a hora local, utilize o separador fuso horário no item data e hora no painel de controlo.
Windows Server 2003 com Service Pack 2, x 86 versões
Reduzir esta tabelaExpandir esta tabela
Nome de ficheiroVersão do ficheiroTamanho do ficheiroDataTempoPlataformaSP requisitoRamo de serviço
Nfsrdr.sys5.2.3790.3251324,09620 De Novembro de 200811: 10x 86SP1SP1QFE
Nfsrdr.sys5.2.3790.4414324,60820 De Novembro de 200815: 16x 86SP2SP2QFE
Windows Server 2003 com Service Pack 2, versões baseadas em 64 x
Reduzir esta tabelaExpandir esta tabela
Nome de ficheiroVersão do ficheiroTamanho do ficheiroDataTempoPlataformaSP requisitoRamo de serviço
Nfsrdr.sys5.2.3790.3251480,25620 De Novembro de 200822: 11x 64SP1SP1QFE
Nfsrdr.sys5.2.3790.4414480,76820 De Novembro de 200822: 24x 64SP2SP2QFE
Windows Server 2003 com Service Pack 2, versões baseadas em Itanium
Reduzir esta tabelaExpandir esta tabela
Nome de ficheiroVersão do ficheiroTamanho do ficheiroDataTempoPlataformaSP requisitoRamo de serviço
Nfsrdr.sys5.2.3790.3251858,11220 De Novembro de 200822: 06IA-64SP1SP1QFE
Nfsrdr.sys5.2.3790.4414859,13620 De Novembro de 200822: 14IA-64SP2SP2QFE

Ponto Da Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na secção "Aplica-se a".

Mais Informação

Quando a rotina MRxCreateVNetRoot devolve o código de erro STATUS_CONNECTION_RESET, a ligação de cliente ao servidor de terminais é reposta. Para obter mais informações sobre a terminologia de actualização de software, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
824684Descrição da terminologia padrão utilizada para descrever actualizações de software da Microsoft

Propriedades

Artigo: 959200 - Última revisão: 31 de dezembro de 2008 - Revisão: 1.0
A informação contida neste artigo aplica-se a:
  • Microsoft Windows Server 2003 Web Edition
  • Microsoft Windows Server 2003 Datacenter Edition
  • Microsoft Windows Server 2003, Datacenter Edition for Itanium-Based Systems
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003 Enterprise Edition
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003 Standard Edition
Palavras-chave: 
kbmt kbexpertiseadvanced kbfix kbautohotfix kbsurveynew kbqfe kbhotfixserver KB959200 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática? erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 959200

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com