Aplicativos ou serviços que utilizar o redirecionador NFS podem falhar quando um cliente baseado em Linux ou um cliente baseado no UNIX desconecta de um servidor de terminal do Windows Server 2003 sem fazer logoff

Traduções deste artigo Traduções deste artigo
ID do artigo: 959200 - Exibir os produtos aos quais esse artigo se aplica.
Expandir tudo | Recolher tudo

Neste artigo

Sintomas

Considere o seguinte cenário:
  • De um computador baseado em Linux ou de um computador baseado no UNIX, você usa um cliente do RDP (Remote Desktop Protocol) de terceiros para se conectar a um servidor de terminal Windows Server 2003.
  • Na sessão de serviços de terminal, você mapear unidades de rede para o computador baseado no Linux ou para o computador baseado no UNIX usando o NFS (Network File System).
  • Quando um aplicativo está sendo executado na sessão, você se desconectar do servidor de terminal sem fazer logoff.
Neste cenário, aplicativos ou serviços que usam o redirecionador NFS no Windows Server 2003 terminal server pode falhar. Por exemplo, o utilitário NET.exe e o utilitário Pddm.exe usam o redirecionador NFS. Se você usar um aplicativo para monitorar o servidor problemático, o aplicativo também pode falhar.

Quando esse problema ocorre, você precise reiniciar o servidor de terminal para restaurar a conexão para o computador baseado no Linux ou para o computador baseado no UNIX.

Causa

Esse problema ocorre porque um deadlock ocorre no NFS após a conexão de cliente para o servidor de terminal é redefinida.

Resolução

Informações sobre o hotfix

Um hotfix com suporte foi disponibilizada pela Microsoft. No entanto, destina-se a corrigir o problema descrito neste artigo. Aplique-o somente aos sistemas que apresentarem esse problema específico. Esta correcção poderá submetida a testes adicionais. Portanto, se você não tiver sido gravemente afetado por esse problema, recomendamos que você aguarde a próxima atualização de software que contém esse hotfix.

Para resolver esse problema imediatamente, contate o Microsoft Customer Atendimento para obter o hotfix. Para obter uma lista completa de telefones do serviço de suporte a clientes da Microsoft e informações sobre os custos de suporte, visite o seguinte site:
http://support.microsoft.com/contactus/?ws=support
Observação Em alguns casos, as taxas cobradas pelas ligações para chamadas de suporte podem ser canceladas se um profissional de suporte da Microsoft determinar que uma atualização específica resolverá o problema. Os custos normais de suporte serão aplicados a questões e problemas que não se qualificam à atualização específica em questão de suporte adicionais.

Pré-requisitos

Para aplicar esse hotfix, você deve estar executando o Windows Server 2003 Service Pack 2 no computador.

Requisitos de reinicialização

Reinicie o computador após aplicar esse hotfix.

Informações sobre a substituição do hotfix

Esse hotfix não substitui um hotfix lançado anteriormente.

Informações sobre o arquivo

A versão em inglês deste hotfix tem atributos de arquivo (ou atributos de arquivo posteriores) listados na tabela a seguir. As datas e horas desses arquivos estão listadas no horário de universal coordenado (UTC). Quando você exibe as informações do arquivo, ele é convertido para a hora local. Para encontrar a diferença entre o UTC e a hora local, use a guia fuso horário no item Data e hora no painel de controle.
Windows Server 2003 com Service Pack 2, x 86-based versões
Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataformaSP requisitoRamificação do serviço
Nfsrdr.sys5.2.3790.3251324,09620 De novembro de 200811: 10x 86SP1SP1QFE
Nfsrdr.sys5.2.3790.4414324,60820 De novembro de 200815: 16x 86SP2SP2QFE
Windows Server 2003 com Service Pack 2, versões com base em 64 x
Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataformaSP requisitoRamificação do serviço
Nfsrdr.sys5.2.3790.3251480,25620 De novembro de 200822: 11x 64SP1SP1QFE
Nfsrdr.sys5.2.3790.4414480,76820 De novembro de 200822: 24x 64SP2SP2QFE
Windows Server 2003 com Service Pack 2, versões com base em Itanium
Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataformaSP requisitoRamificação do serviço
Nfsrdr.sys5.2.3790.3251858,11220 De novembro de 200822: 06IA-64SP1SP1QFE
Nfsrdr.sys5.2.3790.4414859.13620 De novembro de 200822: 14IA-64SP2SP2QFE

Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na seção "Aplica-se a".

Mais Informações

Quando a rotina MRxCreateVNetRoot retorna o código de erro STATUS_CONNECTION_RESET, a conexão de cliente para o servidor de terminal é redefinida. Para obter mais informações sobre terminologia de atualização de software, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
824684Descrição da terminologia padrão que é usada para descrever as atualizações de software

Propriedades

ID do artigo: 959200 - Última revisão: quarta-feira, 31 de dezembro de 2008 - Revisão: 1.0
A informação contida neste artigo aplica-se a:
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Datacenter Edition for Itanium-Based Systems
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
Palavras-chave: 
kbmt kbexpertiseadvanced kbfix kbautohotfix kbsurveynew kbqfe kbhotfixserver KB959200 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 959200

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com