ID Artikel: 959216 - Kajian Terakhir: 12 Juli 2011 - Revisi: 0.1

Pesan galat saat Anda mencoba untuk menginstal sertifikat dengan menggunakan IIS 7,0 Manager: "Tidak dapat menemukan permintaan sertifikat yang terkait dengan file sertifikat ini"

Tips SistemThis article applies to a different operating system than the one you are using. Article content that may not be relevant to you is disabled.
Perbesar semua | Perkecil semua

GEJALA

Ketika Anda mencoba untuk menginstal sertifikat dari PKCS # 7 file dengan menggunakan Internet Information Services (IIS) 7,0 Manager, Anda akan menerima salah satu pesan galat berikut:
Pesan galat 1
Tidak dapat menemukan permintaan sertifikat yang terkait dengan file sertifikat ini. Permintaan sertifikat harus selesai pada komputer di mana itu diciptakan.
Pesan galat 2
Ada kesalahan saat melakukan operasi
Rincian: CertEnroll::CX509Enrollment::p_InstallResponse: ASN1 buruk tag nilai bertemu. 0X8009310B (ASN:276)
Catatan Sertifikat telah terinstal dengan benar meskipun pesan kesalahan.

PENYEBAB

Masalah ini terjadi karena manajer IIS melakukan operasi pencarian untuk mencari nama sertifikat selama instalasi. Namun, kode yang melakukan operasi pencarian ini merindukan kasus khusus ini, dan tidak tahu bagaimana untuk mengambil nama ramah sertifikat dalam file PKCS # 7. Oleh karena itu, lookup operasi gagal, dan Anda menerima pesan galat.

PEMECAHAN MASALAH

Untuk mengatasi masalah ini, Tambahkan nama pada sertifikat. Untuk melakukannya, ikuti langkah-langkah berikut:
  1. Klik Mulai, klik Menjalankan, jenis certmgr.MMC, lalu klik Oke.
  2. Cari sertifikat.
  3. Klik kanan sertifikat, dan kemudian klik Properti.
  4. Mengedit Nama ramah lapangan.

INFORMASI LEBIH LANJUT

Masalah ini dijadwalkan untuk diselesaikan di Windows Server 2008 service pack 3.

Berlaku bagi:
  • Microsoft Internet Information Services 7.0, ketika digunakan dengan:
    • Windows Server 2008 Service Pack 2
Kata kunci: 
kbsurveynew kbtshoot kbnomt kbmt KB959216 KbMtid
Penerjemahan MesinPenerjemahan Mesin
PENTING: Artikel ini diterjemahkan menggunakan perangkat lunak mesin penerjemah Microsoft dan bukan oleh seorang penerjemah. Microsoft menawarkan artikel yang diterjemahkan oleh seorang penerjemah maupun artikel yang diterjemahkan menggunakan mesin sehingga Anda akan memiliki akses ke seluruh artikel baru yang diterbitkan di Pangkalan Pengetahuan (Knowledge Base) dalam bahasa yang Anda gunakan. Namun, artikel yang diterjemahkan menggunakan mesin tidak selalu sempurna. Artikel tersebut mungkin memiliki kesalahan kosa kata, sintaksis, atau tata bahasa, hampir sama seperti orang asing yang berbicara dalam bahasa Anda. Microsoft tidak bertanggung jawab terhadap akurasi, kesalahan atau kerusakan yang disebabkan karena kesalahan penerjemahan konten atau penggunaannya oleh para pelanggan. Microsoft juga sering memperbarui perangkat lunak mesin penerjemah.
Klik disini untuk melihat versi Inggris dari artikel ini:959216  (http://support.microsoft.com/kb/959216/en-us/ )