Errori durante il tentativo di installare un certificato tramite Gestione IIS 7.0

Questo articolo consente di risolvere il problema in cui potrebbe essere generato un errore di runtime imprevisto quando si tenta di installare un certificato usando Microsoft Internet Information Services (IIS) 7.0 Manager

Versione originale del prodotto: Windows Server 2008 Service Pack 2, Internet Information Services 7.0
Numero KB originale: 959216

Sintomi

Quando si tenta di installare un certificato da un PKCS#7 file usando Gestione IIS 7.0, è possibile che venga visualizzato uno dei messaggi di errore seguenti:

  • Messaggio di errore 1

    Impossibile trovare la richiesta di certificato associata a questo file di certificato. Una richiesta di certificato deve essere completata nel computer in cui è stata creata.

  • Messaggio di errore 2

    Errore durante l'esecuzione dell'operazione
    Dettagli: CertEnroll::CX509Enrollment::p_InstallResponse: valore del tag non valido ASN1 soddisfatto.
    0x8009310b (ASN:276)

Nota

Il certificato viene installato correttamente nonostante il messaggio di errore.

Causa

Questo problema si verifica perché Gestione IIS esegue un'operazione di ricerca per cercare un nome descrittivo del certificato durante l'installazione. Tuttavia, il codice che esegue questa operazione di ricerca perde questo caso specifico e non sa come recuperare il nome descrittivo di un certificato in un PKCS#7 file. Ecco perché l'operazione di ricerca ha esito negativo e viene visualizzato il messaggio di errore.

Risoluzione

Per risolvere il problema, aggiungere un nome descrittivo al certificato. Per risolvere il problema, seguire questa procedura:

  1. Selezionare Start, selezionare Esegui, digitare certmgr.msc e quindi selezionare OK.
  2. Selezionare File, quindi Aggiungi/Rimuovi intervalli.
  3. Selezionare Certificati, quindi Aggiungi e quindi OK.
  4. Selezionare Account computer, quindi Avanti e quindi Fine.
  5. Selezionare OK.
  6. Espandere Certificati (computer locale) e Personale, quindi Certificati.
  7. Fare clic con il pulsante destro del mouse sul certificato e quindi scegliere Proprietà.
  8. Modificare il campo Nome descrittivo .

Ulteriori informazioni

Questo problema è pianificato per essere risolto in Windows Server 2008 Service Pack 3.